summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-08-27 22:21:16 +0200
committerSebastian Pipping <sping@gentoo.org>2017-08-27 22:55:33 +0200
commit4221a4e4035cb01ca03fe4ceba8bde369f1806a6 (patch)
treedf3a7b60d08da531ab4b0f0fa677689f3139d70d /www-servers/gatling/gatling-0.15.ebuild
parentmedia-gfx/gimp: SSL homepage (diff)
downloadgentoo-4221a4e4035cb01ca03fe4ceba8bde369f1806a6.tar.gz
gentoo-4221a4e4035cb01ca03fe4ceba8bde369f1806a6.tar.bz2
gentoo-4221a4e4035cb01ca03fe4ceba8bde369f1806a6.zip
www-servers/gatling: 0.15
Also bump EAPI 6, use SSL URLs, and address init script Bashism Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'www-servers/gatling/gatling-0.15.ebuild')
-rw-r--r--www-servers/gatling/gatling-0.15.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/www-servers/gatling/gatling-0.15.ebuild b/www-servers/gatling/gatling-0.15.ebuild
new file mode 100644
index 000000000000..f2b75dd25464
--- /dev/null
+++ b/www-servers/gatling/gatling-0.15.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils toolchain-funcs user
+
+DESCRIPTION="High performance web server"
+HOMEPAGE="https://www.fefe.de/gatling/"
+SRC_URI="https://www.fefe.de/gatling/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="libressl ssl diet"
+REQUIRED_USE="ssl? ( !diet )"
+
+DEPEND=">=dev-libs/libowfat-0.25[diet=]
+ diet? ( dev-libs/dietlibc )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ rm Makefile # leaves us with GNUmakefile
+ epatch "${FILESDIR}/${PN}-0.13-compile.patch"
+ eapply_user
+}
+
+src_compile() {
+ local DIET=
+ use diet && DIET='/usr/bin/diet'
+
+ local targets='gatling'
+ use ssl && targets+=' tlsgatling'
+
+ emake DIET="${DIET}" CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I${ROOT}usr/include/libowfat" \
+ LDFLAGS="${LDFLAGS}" prefix=/usr ${targets} \
+ || die "emake ${targets} failed"
+}
+
+src_install() {
+ doman gatling.1 || die "installing manpage failed"
+
+ newconfd "${FILESDIR}/gatling.confd" gatling || die
+ newinitd "${FILESDIR}/gatling.initd-3" gatling || die
+ dodoc README.{ftp,http} || die "installing docs failed"
+
+ dobin gatling || die "installing gatling binary failed"
+ use ssl && {
+ dodoc README.tls || die "installing docs failed"
+ dobin tlsgatling || die "installing tlsgatling binary failed"
+ }
+}
+
+pkg_setup() {
+ ebegin "Creating gatling user and group"
+ enewgroup gatling
+ enewuser ${PN} -1 -1 /var/www/localhost ${PN}
+}