summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2019-11-14 21:50:36 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-11-17 09:45:47 +0200
commit9906366308c5c5e9e342660e3707fd278b6e7bbf (patch)
tree524a79519e8596e1abd85bb8f0d0219416f32ce7 /www-servers/nginx-unit
parentsci-electronics/kicad: Enforce non-deprecated media-libs/glm version (diff)
downloadgentoo-9906366308c5c5e9e342660e3707fd278b6e7bbf.tar.gz
gentoo-9906366308c5c5e9e342660e3707fd278b6e7bbf.tar.bz2
gentoo-9906366308c5c5e9e342660e3707fd278b6e7bbf.zip
www-servers/nginx-unit: Bump to version 1.13.0
Upstream release 1.13.0, changelog available here: http://unit.nginx.org/CHANGES.txt Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-servers/nginx-unit')
-rw-r--r--www-servers/nginx-unit/Manifest1
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.13.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/www-servers/nginx-unit/Manifest b/www-servers/nginx-unit/Manifest
index 1d0e3a28f48d..1b19103ae934 100644
--- a/www-servers/nginx-unit/Manifest
+++ b/www-servers/nginx-unit/Manifest
@@ -1,2 +1,3 @@
DIST nginx-unit-1.12.0.tar.gz 681661 BLAKE2B 1e497172a37fdcd33d0ced5b97675bff42f4cadab2f9363316e667c90c8b4dc4b43f4b8d5cff9f547daa7e92d532550434907515134a5c958586f1822beea749 SHA512 a55a084ed6e1cd3f784bd81571772ca29ca9a0d19089c9bb74c88258d2e1ef872978219c47b6dc2610711ae1aa95ef68ddb77f45747a2eacdd9d92c6f8fee28b
+DIST nginx-unit-1.13.0.tar.gz 693159 BLAKE2B fd2e803188e66c16d5956f26e693c81273b1f3f69c9b68209f15bca6abd0e06b9fb9e03eb32ab640b8f601260b439abee1c4aa9cd03ed92fd26ab55893a6a6ab SHA512 cf33295604040963545b04f72f1a894431d4ee22a2c7b9560f18a694f110ee3bf243c90f65cfa4760a0009a5a7b132b75e1bb51439b19255e15148e8f4e9b9a7
DIST nginx-unit-1.8.0.tar.gz 511226 BLAKE2B e396b27954840a5f1ad3a4cd9501a5e5fe769a754c51043da784a2c4596e6acc33089f495bf412a0db086e5c715a51292c7dece004a6512564421a431b6c339e SHA512 1d0ad05343ff70aff4c6e221a36c20df95fa2e2262ae5c69963a9bcb9ef883151e8a2fa9fef29f43ac5489aa5cbb3e9dfd10cf5e7f6d7a98742b490ebf3a0413
diff --git a/www-servers/nginx-unit/nginx-unit-1.13.0.ebuild b/www-servers/nginx-unit/nginx-unit-1.13.0.ebuild
new file mode 100644
index 000000000000..b398e40980ae
--- /dev/null
+++ b/www-servers/nginx-unit/nginx-unit-1.13.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python2_7 python3_{5,6,7})
+
+inherit flag-o-matic python-single-r1
+
+MY_P="unit-${PV}"
+DESCRIPTION="Dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php5-6 php7-1 php7-2 php7-3"
+IUSE="${MY_USE} ${MY_USE_PHP} ssl"
+REQUIRED_USE="|| ( ${IUSE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+ php5-6? ( dev-lang/php:5.6[embed] )
+ php7-1? ( dev-lang/php:7.1[embed] )
+ php7-2? ( dev-lang/php:7.2[embed] )
+ php7-3? ( dev-lang/php:7.3[embed] )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby:* )
+ ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply_user
+ sed -i '/^CFLAGS/d' auto/make || die
+}
+
+src_configure() {
+ local opt=(
+ --control=unix:/run/${PN}.sock
+ --log=/var/log/${PN}
+ --modules=$(get_libdir)/${PN}
+ --pid=/run/${PN}.pid
+ --prefix=/usr
+ --state=/var/lib/${PN}
+ )
+ use ssl && opt+=( --openssl )
+ export AR="$(tc-getAR)"
+ export CC="$(tc-getCC)"
+ ./configure ${opt[@]} --ld-opt="${LDFLAGS}" || die "Core configuration failed"
+ # Modules require position-independent code
+ append-cflags $(test-flags-CC -fPIC)
+ for flag in ${MY_USE} ; do
+ if use ${flag} ; then
+ ./configure ${flag} || die "Module configuration failed: ${flag}"
+ fi
+ done
+ for flag in ${MY_USE_PHP} ; do
+ if use ${flag} ; then
+ local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+ ./configure php \
+ --module=${flag} \
+ --config=${php_slot}/bin/php-config \
+ --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+ fi
+ done
+}
+
+src_install() {
+ default
+ diropts -m 0770
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}