summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-10-11 21:23:04 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-10-11 21:23:04 -0400
commit3acb5e0a5f7852dbf2ca957efce4581d945ba5e4 (patch)
tree6024ea0b98886ca660909ffcb0a8c2d56bfbbe89 /www-servers/pound
parentwww-servers/gatling: add libressl support (diff)
downloadgentoo-3acb5e0a5f7852dbf2ca957efce4581d945ba5e4.tar.gz
gentoo-3acb5e0a5f7852dbf2ca957efce4581d945ba5e4.tar.bz2
gentoo-3acb5e0a5f7852dbf2ca957efce4581d945ba5e4.zip
www-servers/pound: add libressl support
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'www-servers/pound')
-rw-r--r--www-servers/pound/pound-2.7f-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/www-servers/pound/pound-2.7f-r1.ebuild b/www-servers/pound/pound-2.7f-r1.ebuild
new file mode 100644
index 00000000000..4efc7af3857
--- /dev/null
+++ b/www-servers/pound/pound-2.7f-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+MY_P=${P/p/P}
+DESCRIPTION="A http/https reverse-proxy and load-balancer"
+HOMEPAGE="http://www.apsis.ch/pound/"
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="libressl"
+
+DEPEND="dev-libs/libpcre
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dodir /usr/sbin
+ cp "${S}"/pound "${D}"/usr/sbin/
+ cp "${S}"/poundctl "${D}"/usr/sbin/
+
+ doman pound.8
+ doman poundctl.8
+ dodoc README FAQ
+
+ dodir /etc/init.d
+ newinitd "${FILESDIR}"/pound.init-1.9 pound
+
+ insinto /etc
+ newins "${FILESDIR}"/pound-2.2.cfg pound.cfg
+}
+
+pkg_postinst() {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "read the man-page for more info."
+ elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+ echo
+ ewarn "You will have to upgrade you configuration file, if you are"
+ ewarn "upgrading from a version <= 2.0."
+ echo
+ ewarn "The 'WebDAV' config statement is no longer supported!"
+ ewarn "Please adjust your configuration, if necessary."
+ echo
+}