summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-14 10:43:27 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-14 12:18:04 +0200
commit0e087bd09a7b0d4737e26c876720a596ed002d28 (patch)
tree23a2ce7a90b89ebba6482a4ed5ca2e37a15268d2 /www-servers/spawn-fcgi/spawn-fcgi-1.6.4-r1.ebuild
parentdev-util/kdevelop: Drop 5.2.3 (diff)
downloadgentoo-0e087bd09a7b0d4737e26c876720a596ed002d28.tar.gz
gentoo-0e087bd09a7b0d4737e26c876720a596ed002d28.tar.bz2
gentoo-0e087bd09a7b0d4737e26c876720a596ed002d28.zip
www-servers/spawn-fcgi: Several fixes to init.d script
- Detect crashes (#567320 by Cédric Krier) - Use proper variable names (#657362 by Jernej Simoncic) Closes: https://bugs.gentoo.org/567320 Closes: https://bugs.gentoo.org/657362 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'www-servers/spawn-fcgi/spawn-fcgi-1.6.4-r1.ebuild')
-rw-r--r--www-servers/spawn-fcgi/spawn-fcgi-1.6.4-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-servers/spawn-fcgi/spawn-fcgi-1.6.4-r1.ebuild b/www-servers/spawn-fcgi/spawn-fcgi-1.6.4-r1.ebuild
new file mode 100644
index 000000000000..92e2c3777b59
--- /dev/null
+++ b/www-servers/spawn-fcgi/spawn-fcgi-1.6.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A FCGI spawner for lighttpd and cherokee and other webservers"
+HOMEPAGE="http://redmine.lighttpd.net/projects/spawn-fcgi"
+SRC_URI="http://www.lighttpd.net/download/${P}.tar.xz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="ipv6"
+
+DEPEND=""
+RDEPEND="
+ !<=www-servers/lighttpd-1.4.20
+ !<=www-servers/cherokee-0.98.1
+"
+
+src_configure() {
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ default
+
+ newconfd "${FILESDIR}"/spawn-fcgi.confd spawn-fcgi
+ newinitd "${FILESDIR}"/spawn-fcgi.initd-r3 spawn-fcgi
+
+ docinto examples
+ dodoc doc/run-generic doc/run-php doc/run-rails
+}