summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-servers/tornado/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-servers/tornado/files')
-rw-r--r--www-servers/tornado/files/4.1.0-drop-intersphinx.patch36
-rw-r--r--www-servers/tornado/files/drop-intersphinx.patch36
-rw-r--r--www-servers/tornado/files/tornado-3.1.1-py2_6-tests-fix.patch31
-rw-r--r--www-servers/tornado/files/unittest2-import-issue-1005.patch41
4 files changed, 144 insertions, 0 deletions
diff --git a/www-servers/tornado/files/4.1.0-drop-intersphinx.patch b/www-servers/tornado/files/4.1.0-drop-intersphinx.patch
new file mode 100644
index 000000000000..e7da6fbefea2
--- /dev/null
+++ b/www-servers/tornado/files/4.1.0-drop-intersphinx.patch
@@ -0,0 +1,36 @@
+diff --git a/docs/Makefile b/docs/Makefile
+index a491685..ba4888f 100644
+--- a/docs/Makefile
++++ b/docs/Makefile
+@@ -1,7 +1,7 @@
+ .PHONY: all
+ all: sphinx
+
+-SPHINXOPTS=-n -W -d build/doctrees .
++SPHINXOPTS=-n -d build/doctrees .
+
+ .PHONY: sphinx
+ sphinx:
+diff --git a/docs/conf.py b/docs/conf.py
+index d9b4761..4c11038 100644
+--- a/docs/conf.py
++++ b/docs/conf.py
+@@ -15,7 +15,6 @@ extensions = [
+ "sphinx.ext.autodoc",
+ "sphinx.ext.coverage",
+ "sphinx.ext.extlinks",
+- "sphinx.ext.intersphinx",
+ "sphinx.ext.viewcode",
+ ]
+
+@@ -94,10 +93,6 @@ extlinks = {
+ 'tornado-%s.tar.g' % version),
+ }
+
+-intersphinx_mapping = {
+- 'python': ('http://python.readthedocs.org/en/latest/', None),
+- }
+-
+ on_rtd = os.environ.get('READTHEDOCS', None) == 'True'
+
+ # On RTD we can't import sphinx_rtd_theme, but it will be applied by
diff --git a/www-servers/tornado/files/drop-intersphinx.patch b/www-servers/tornado/files/drop-intersphinx.patch
new file mode 100644
index 000000000000..7502dc53b820
--- /dev/null
+++ b/www-servers/tornado/files/drop-intersphinx.patch
@@ -0,0 +1,36 @@
+diff --git a/docs/Makefile b/docs/Makefile
+index 7001b80..ab2ffdd 100644
+--- a/docs/Makefile
++++ b/docs/Makefile
+@@ -3,7 +3,7 @@ all: sphinx
+
+ # No -W for doctests because that disallows tests with empty output.
+ SPHINX_DOCTEST_OPTS=-n -d build/doctress .
+-SPHINXOPTS=-n -W -d build/doctrees .
++SPHINXOPTS=-n -d build/doctrees .
+
+ .PHONY: sphinx
+ sphinx:
+diff --git a/docs/conf.py b/docs/conf.py
+index 368e4e8..85a276d 100644
+--- a/docs/conf.py
++++ b/docs/conf.py
+@@ -16,7 +16,6 @@ extensions = [
+ "sphinx.ext.coverage",
+ "sphinx.ext.doctest",
+ "sphinx.ext.extlinks",
+- "sphinx.ext.intersphinx",
+ "sphinx.ext.viewcode",
+ ]
+
+@@ -91,10 +90,6 @@ extlinks = {
+ 'tornado-%s.tar.g' % version),
+ }
+
+-intersphinx_mapping = {
+- 'python': ('https://docs.python.org/3.4/', None),
+- }
+-
+ on_rtd = os.environ.get('READTHEDOCS', None) == 'True'
+
+ # On RTD we can't import sphinx_rtd_theme, but it will be applied by
diff --git a/www-servers/tornado/files/tornado-3.1.1-py2_6-tests-fix.patch b/www-servers/tornado/files/tornado-3.1.1-py2_6-tests-fix.patch
new file mode 100644
index 000000000000..ea18df2393ac
--- /dev/null
+++ b/www-servers/tornado/files/tornado-3.1.1-py2_6-tests-fix.patch
@@ -0,0 +1,31 @@
+diff --git a/tornado/test/twisted_test.py b/tornado/test/twisted_test.py
+index b8d9c6f..998282c 100644
+--- a/tornado/test/twisted_test.py
++++ b/tornado/test/twisted_test.py
+@@ -22,6 +22,7 @@ from __future__ import absolute_import, division, print_function, with_statement
+ import os
+ import shutil
+ import signal
++import sys
+ import tempfile
+ import threading
+
+@@ -477,8 +478,6 @@ if have_twisted:
+ 'twisted.internet.test.test_fdset.ReactorFDSetTestsBuilder': [
+ "test_lostFileDescriptor", # incompatible with epoll and kqueue
+ ],
+- 'twisted.internet.test.test_process.ProcessTestsBuilder': [
+- ],
+ # Process tests appear to work on OSX 10.7, but not 10.6
+ #'twisted.internet.test.test_process.PTYProcessTestsBuilder': [
+ # 'test_systemCallUninterruptedByChildExit',
+@@ -519,6 +518,9 @@ if have_twisted:
+ ],
+ 'twisted.internet.test.test_unix.UNIXPortTestsBuilder': [],
+ }
++ if sys.version_info >= (2,7):
++ twisted_tests['twisted.internet.test.test_process.ProcessTestsBuilder'] = []
++
+ for test_name, blacklist in twisted_tests.items():
+ try:
+ test_class = import_object(test_name)
diff --git a/www-servers/tornado/files/unittest2-import-issue-1005.patch b/www-servers/tornado/files/unittest2-import-issue-1005.patch
new file mode 100644
index 000000000000..3ad5b9158c0a
--- /dev/null
+++ b/www-servers/tornado/files/unittest2-import-issue-1005.patch
@@ -0,0 +1,41 @@
+commit 79e29c62ce095984d0e9da5b7c5072eb9aa6e131
+Author: yac <yac@gentoo.org>
+Date: Sat Mar 8 00:32:09 2014 +0100
+
+ fixes #1005
+
+diff --git a/tornado/test/util.py b/tornado/test/util.py
+index 3604310..e4e37f0 100644
+--- a/tornado/test/util.py
++++ b/tornado/test/util.py
+@@ -3,6 +3,10 @@ from __future__ import absolute_import, division, print_function, with_statement
+ import os
+ import sys
+
++# Tornado's own test suite requires the updated unittest module
++# (either py27+ or unittest2) so tornado.test.util enforces
++# this requirement, but for other users of tornado.testing we want
++# to allow the older version if unitest2 is not available.
+ # Encapsulate the choice of unittest or unittest2 here.
+ # To be used as 'from tornado.test.util import unittest'.
+ if sys.version_info >= (2, 7):
+diff --git a/tornado/testing.py b/tornado/testing.py
+index 96fdd32..cd811d4 100644
+--- a/tornado/testing.py
++++ b/tornado/testing.py
+@@ -45,14 +45,7 @@ try:
+ except ImportError:
+ from io import StringIO # py3
+
+-# Tornado's own test suite requires the updated unittest module
+-# (either py27+ or unittest2) so tornado.test.util enforces
+-# this requirement, but for other users of tornado.testing we want
+-# to allow the older version if unitest2 is not available.
+-try:
+- import unittest2 as unittest
+-except ImportError:
+- import unittest
++from tornado.test.util import unittest
+
+ _next_port = 10000
+