summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2021-05-16 00:48:31 +0300
committerMichał Górny <mgorny@gentoo.org>2021-06-01 22:35:36 +0200
commit02872e75e5649f6c2387d6ba0cf57d47d58b4f14 (patch)
treed721320a55759e6c444391530fe3ecc12b881fcc /www-servers/tornado
parentdev-python/twisted: Bump to python 3.10 (diff)
downloadgentoo-02872e75e5649f6c2387d6ba0cf57d47d58b4f14.tar.gz
gentoo-02872e75e5649f6c2387d6ba0cf57d47d58b4f14.tar.bz2
gentoo-02872e75e5649f6c2387d6ba0cf57d47d58b4f14.zip
www-servers/tornado: Bump to python 3.10
Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Closes: https://github.com/gentoo/gentoo/pull/20835 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-servers/tornado')
-rw-r--r--www-servers/tornado/tornado-6.1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/www-servers/tornado/tornado-6.1.ebuild b/www-servers/tornado/tornado-6.1.ebuild
index aad1b1cbc58d..a956fc321b85 100644
--- a/www-servers/tornado/tornado-6.1.ebuild
+++ b/www-servers/tornado/tornado-6.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -32,6 +32,14 @@ distutils_enable_sphinx docs \
dev-python/sphinx_rtd_theme \
dev-python/sphinxcontrib-asyncio
+python_prepare_all() {
+ # Disable deprecation-warnings-as-errors because tornado has a lot of stuff deprecated in 3.10
+ sed 's/warnings.filterwarnings("error", category=DeprecationWarning, module=r"tornado\\..*")//' \
+ -i tornado/test/runtests.py || die
+
+ distutils-r1_python_prepare_all
+}
+
python_test() {
local -x ASYNC_TEST_TIMEOUT=60
cd "${BUILD_DIR}/lib" || die