summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2020-10-01 19:18:44 -0400
committerAnthony G. Basile <blueness@gentoo.org>2020-10-01 19:19:04 -0400
commitf5155619fbd862fb2acdf6e8d3af6049c5528779 (patch)
tree9e5cf0ecca3480b3a6f51da605d77ecd71c0f4f6 /www-servers/varnish
parentdev-python/protobuf-python: stable 3.12.2-r1 for ppc (diff)
downloadgentoo-f5155619fbd862fb2acdf6e8d3af6049c5528779.tar.gz
gentoo-f5155619fbd862fb2acdf6e8d3af6049c5528779.tar.bz2
gentoo-f5155619fbd862fb2acdf6e8d3af6049c5528779.zip
www-servers/varnish: version bump to 6.5.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'www-servers/varnish')
-rw-r--r--www-servers/varnish/Manifest1
-rw-r--r--www-servers/varnish/varnish-6.5.0.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/www-servers/varnish/Manifest b/www-servers/varnish/Manifest
index e60281b3d7f4..dd921ec46677 100644
--- a/www-servers/varnish/Manifest
+++ b/www-servers/varnish/Manifest
@@ -1,3 +1,4 @@
DIST varnish-6.0.6.tgz 3136931 BLAKE2B 2ce379622b20a939a977a426cb842ba62e4fd5fd3ba785ec21888956b6a8c16e95bd834962a7ba05dc426dfc36067cabb4f8ade2bee7fe2a094a1f2c4c4c9e06 SHA512 c0881ab051bca928c12f35494c5e2a8109390abdf3acf368da404c5537d1ee0f1153b6e329058a7e1168eacf5af9b86ccf9a6e58cd89dd7d51b8b71d25aa7ba0
DIST varnish-6.3.2.tgz 3323908 BLAKE2B 5bde1b2ececeb8aed884db22ed75bfd74f82d68416e71400a4c0d27483fcceb029fe8e724e30754899c872d7028da5cb759545f0743a11d0e90b0fd604af0ad7 SHA512 0f476c642df834737d446b3bc6ac8afa5981d1de5810dc6e8556eb22b2ca26d64eb531f4ad3332eb86e231a7443fe35393177ec6dbee97a837f405d1aa9d03cd
DIST varnish-6.4.0.tgz 3404617 BLAKE2B 0ef0f7303f5c926bb1b80ec14cdd9755d65c1938fa8645240800ac2997f954022133625a74dd9c30ce21850674c3b00777fcc896309f528e6ba90d347333d7f7 SHA512 cda8f9e1d301a2b79db14685a23e25e36225f37065a1b7f37c5ae12fbb0483be51be9ffcc8ba72c1f65f5a022d1e408825694daed6780e206b9ba91feb2a07a1
+DIST varnish-6.5.0.tgz 3476969 BLAKE2B bafa8704f28dfa96f681805cc053dd6415e143016b1bbff7f8962f2c3ac5cd07be6dc2f4129a423ddfcbf9f9f8afc57388930685d0ed400f3c06ba03bd667d87 SHA512 43f8cd6429a903a353ac4448b6e9aff445b0d52178141a148d3b29b987c0974841820af0da4917731775b46899c12b0327d64d12e3ddbb8fd438e2802ac66a1c
diff --git a/www-servers/varnish/varnish-6.5.0.ebuild b/www-servers/varnish/varnish-6.5.0.ebuild
new file mode 100644
index 000000000000..cd7753a43dbf
--- /dev/null
+++ b/www-servers/varnish/varnish-6.5.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit autotools systemd python-r1
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="https://varnish-cache.org/"
+SRC_URI="http://varnish-cache.org/_downloads/${P}.tgz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="jemalloc jit static-libs"
+
+CDEPEND="
+ sys-libs/readline:0=
+ dev-libs/libpcre[jit?]
+ jemalloc? ( dev-libs/jemalloc )
+ sys-libs/ncurses:0="
+
+#varnish compiles stuff at run time
+RDEPEND="
+ ${PYTHON_DEPS}
+ ${CDEPEND}
+ acct-user/varnish
+ acct-group/varnish
+ sys-devel/gcc"
+
+DEPEND="
+ ${CDEPEND}
+ dev-python/docutils
+ dev-python/sphinx
+ virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test" #315725
+
+src_prepare() {
+ # Remove -Werror bug #528354
+ sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac
+
+ # Upstream doesn't put varnish.m4 in the m4/ directory
+ # We link because the Makefiles look for the file in
+ # the original location
+ ln -sf ../varnish.m4 m4/varnish.m4
+
+ eapply_user
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable jit pcre-jit ) \
+ $(use_with jemalloc)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
+
+ newinitd "${FILESDIR}"/varnishlog.initd varnishlog
+ newconfd "${FILESDIR}"/varnishlog.confd varnishlog
+
+ newinitd "${FILESDIR}"/varnishncsa.initd varnishncsa
+ newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
+
+ newinitd "${FILESDIR}"/varnishd.initd-r4 varnishd
+ newconfd "${FILESDIR}"/varnishd.confd-r4 varnishd
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
+
+ diropts -m750
+
+ keepdir /var/lib/varnish
+ keepdir /var/log/varnish
+
+ systemd_dounit "${FILESDIR}/${PN}d.service"
+
+ insinto /etc/varnish/
+ doins lib/libvmod_std/vmod_std.vcc
+ doins etc/example.vcl
+
+ dodoc README.rst
+ dodoc doc/changes.rst
+
+ fowners root:varnish /etc/varnish/
+ fowners varnish:varnish /var/lib/varnish/
+ fperms 0750 /var/lib/varnish/ /etc/varnish/
+}