summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-18 07:32:05 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-18 07:37:49 +0200
commit0ee41a96ac62b2f41c49d3891f70749b98aa83c2 (patch)
tree13d781914e4fd76da82adbf25bc162986b69dc7e /www-servers
parentsys-apps/util-linux: drop 2.39.1 (diff)
downloadgentoo-0ee41a96ac62b2f41c49d3891f70749b98aa83c2.tar.gz
gentoo-0ee41a96ac62b2f41c49d3891f70749b98aa83c2.tar.bz2
gentoo-0ee41a96ac62b2f41c49d3891f70749b98aa83c2.zip
www-servers/puma: add 6.3.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/puma/Manifest1
-rw-r--r--www-servers/puma/puma-6.3.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/www-servers/puma/Manifest b/www-servers/puma/Manifest
index 3f36a0f30d2a..d210674f4a22 100644
--- a/www-servers/puma/Manifest
+++ b/www-servers/puma/Manifest
@@ -2,3 +2,4 @@ DIST puma-5.6.5.tar.gz 314953 BLAKE2B 2aca92ff3d32995be8f05b626c2299c07f8665f345
DIST puma-6.1.1.tar.gz 355892 BLAKE2B 025d8303f01dc09dfc9e15395cbd2a5507b3f578dcd3b22cf0985ca760ed304b2eb1b0f4c442efc542f3261f7300143bf5264bab5543360d1cb07eb0aa3e52d5 SHA512 76988e75110124dcac589fcd01b46ae659e37b7dc2e6901c8d88b3b20ab188c8e6cdefb114f73c9ce829581d5723392d52a8059485ab7c31b77c65204554ac60
DIST puma-6.2.2.tar.gz 358383 BLAKE2B aeea4410eb6b20f294131aa107d4d19ca19bea5a3447cee59250be151b5b8046feae2e2e096f40fade6ac81a6b630cf72608b1c6c76cf05c18be4e81c6f6e143 SHA512 b9eabec30761873d628acfff259cf4e5c55dbda735ecb871b0c6e3607930a96f55fe1ad4df58954b8d0b11995762b4918f47e930ae48ebc9557fdc0182a3db8d
DIST puma-6.3.0.tar.gz 365128 BLAKE2B 4db46fd2bcb3a6766582294cdc7f0bd0e2585da12999ec3091d942946f1f6a3e95272834323ab8efe594d7852f78ef9ee0f5f549cd92bbe086fc5ee2d25b914f SHA512 74c4a58cceac016d0ccfef1312e31208b665e1a88d18dabc1018df26466b626fd85666042f1bcb416650dfb4f9779390b2f9b1fcd83c25816221b05eac8f25f8
+DIST puma-6.3.1.tar.gz 365566 BLAKE2B 4112406abb05569d8dcaf60826e66ef96ea3cae0639f00b750080fecab6bb86d9fcd1533f15aeae4ffe69a15a103c875e5c73b987cc638e895ff719c6699f310 SHA512 9b7521fa85e50503dcb5b425c7f73909162c6634ae0ada963f93eb82804300637125f159a94166b2446283d092c9dcfa10ccf79a0deabca16a1b27c0d3a37a2f
diff --git a/www-servers/puma/puma-6.3.1.ebuild b/www-servers/puma/puma-6.3.1.ebuild
new file mode 100644
index 000000000000..0931b58f74a3
--- /dev/null
+++ b/www-servers/puma/puma-6.3.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_GEMSPEC="puma.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/puma_http11/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/puma
+
+inherit ruby-fakegem
+
+DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
+HOMEPAGE="https://puma.io/"
+SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
+RDEPEND+=" dev-libs/openssl:0="
+
+ruby_add_bdepend "virtual/ruby-ssl
+ test? ( dev-ruby/localhost dev-ruby/rack:2.2 >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
+
+ruby_add_rdepend "dev-ruby/nio4r:2"
+
+all_ruby_prepare() {
+ sed -e '/bundler/ s:^:#:' \
+ -e '/prove/ s:^:#:' \
+ -e '/stub_const/ s:^:#:' \
+ -i test/helper.rb || die
+
+ # Avoid tests failing inconsistently
+ sed -i -e '/test_bad_client/askip "inconsistent results"' test/test_web_server.rb || die
+
+ # Avoid tests depending on specific encoding
+ sed -i -e '/test_lowlevel_error_handler_response/askip "specific encoding required"' test/test_puma_server.rb || die
+
+ # Avoid launcher tests since they make assumptions about bundler use
+ rm -f test/test_launcher.rb test/test_worker_gem_independence.rb test/test_bundle_pruner.rb || die
+
+ # Skip integration tests since they make a lot of assumptions about
+ # the environment
+ rm -f test/test_integration_* test/test_preserve_bundler_env.rb|| die
+
+ # Avoid test that uses unpackaged stub_const
+ sed -i -e '/test_shutdown_with_grace/,/^ end/ s:^:#:' test/test_thread_pool.rb || die
+
+ # Tries to call 'rackup' directly
+ sed -i -e '/def test_bin/,/^ end/ s:^:#:' test/test_rack_handler.rb || die
+
+ sed -e 's/git ls-files --/find/' \
+ -e 's:_relative ": "./:' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ einfo "Running test suite"
+ PUMA_CI_RACK_2=true \
+ ${RUBY} -Ilib:.:test \
+ -e "gem 'rack', '<3'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{require _1}" || die
+}