summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-06-27 17:55:36 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-06-28 04:00:13 +0000
commit12a0ffc1e2d18c7c4342c5359725c59785e51e49 (patch)
treeaaaa45a186152b7852a2aba555c8fb09c7887262 /www-servers
parentdev-python/astropy: ply-3.10 is not compatible, so to simplify, keep bundled ... (diff)
downloadgentoo-12a0ffc1e2d18c7c4342c5359725c59785e51e49.tar.gz
gentoo-12a0ffc1e2d18c7c4342c5359725c59785e51e49.tar.bz2
gentoo-12a0ffc1e2d18c7c4342c5359725c59785e51e49.zip
www-servers/tornado: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/tornado/Manifest1
-rw-r--r--www-servers/tornado/files/4.5.1-drop-intersphinx.patch22
-rw-r--r--www-servers/tornado/tornado-4.5.1.ebuild68
3 files changed, 91 insertions, 0 deletions
diff --git a/www-servers/tornado/Manifest b/www-servers/tornado/Manifest
index 66fca8816cef..140cae4dd422 100644
--- a/www-servers/tornado/Manifest
+++ b/www-servers/tornado/Manifest
@@ -1 +1,2 @@
DIST tornado-4.4.2.tar.gz 460193 SHA256 2898f992f898cd41eeb8d53b6df75495f2f423b6672890aadaf196ea1448edcc SHA512 f330bc62433576708e3c566577cede07c54c19996f374df82d5abc19a669ade549e7b6c27dcae3d421921fec506fae39473443cdb04692553c5ea2f8ec11a327 WHIRLPOOL df04a35ed30f9bbaff87be06c96de7a9038e1535b21d40906eb92a5beeaaf6ac4ea1b14b4f16df1527b9a07d41a5ee4c04ec141a068e3acfb4b6717019ff5fdd
+DIST tornado-4.5.1.tar.gz 483225 SHA256 db0904a28253cfe53e7dedc765c71596f3c53bb8a866ae50123320ec1a7b73fd SHA512 b31b3572bf58df8b758694c32b2233c547d6600b0c27f56cff3521abaad38a1646a528d2c2dfcf13214159bf5ba0f59470ba3d538edf16dc014a8b03f0d3bb87 WHIRLPOOL 31e2bb974c938979b430cdc1a873bd1f5f2b6d5fdec61ef8901e7ea83ec2d6801e004202042dc5070ac4083b6d8fec35166b12aaa0664e0775cb1b7af43c148d
diff --git a/www-servers/tornado/files/4.5.1-drop-intersphinx.patch b/www-servers/tornado/files/4.5.1-drop-intersphinx.patch
new file mode 100644
index 000000000000..606bfc787381
--- /dev/null
+++ b/www-servers/tornado/files/4.5.1-drop-intersphinx.patch
@@ -0,0 +1,22 @@
+diff -Nur tornado-4.5.1.orig/docs/conf.py tornado-4.5.1/docs/conf.py
+--- tornado-4.5.1.orig/docs/conf.py 2017-06-27 17:39:55.881133239 +0000
++++ tornado-4.5.1/docs/conf.py 2017-06-27 17:40:59.910682166 +0000
+@@ -16,7 +16,6 @@
+ "sphinx.ext.autodoc",
+ "sphinx.ext.coverage",
+ "sphinx.ext.doctest",
+- "sphinx.ext.intersphinx",
+ "sphinx.ext.viewcode",
+ ]
+
+@@ -81,10 +80,6 @@
+ ('index', 'tornado.tex', 'Tornado Documentation', 'The Tornado Authors', 'manual', False),
+ ]
+
+-intersphinx_mapping = {
+- 'python': ('https://docs.python.org/3.5/', None),
+- }
+-
+ on_rtd = os.environ.get('READTHEDOCS', None) == 'True'
+
+ # On RTD we can't import sphinx_rtd_theme, but it will be applied by
diff --git a/www-servers/tornado/tornado-4.5.1.ebuild b/www-servers/tornado/tornado-4.5.1.ebuild
new file mode 100644
index 000000000000..ab03eec142c7
--- /dev/null
+++ b/www-servers/tornado/tornado-4.5.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="http://www.tornadoweb.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+CDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+ dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ ( $(python_gen_cond_dep 'dev-python/twisted-names[${PYTHON_USEDEP}]' 'python2_7')
+ $(python_gen_cond_dep 'dev-python/twisted-web[${PYTHON_USEDEP}]' 'python2_7')
+ )
+ )
+ virtual/python-backports_abc[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+# doc without intersphinx does not build (asyncio error)
+#PATCHES=(
+# "${FILESDIR}"/4.5.1-drop-intersphinx.patch
+#)
+
+python_compile_all() {
+ use doc && emake -C docs sphinx
+}
+
+python_test() {
+ "${PYTHON}" -m tornado.test.runtests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+fi
+ distutils-r1_python_install_all
+}