summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-06-08 08:14:53 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-06-08 08:23:14 -0400
commit16c437b88f1dad5bc0a6d2871a406f9d105e1192 (patch)
treec6233fbc8af9d70ea85d3e6d602ada4f689d83a1 /www-servers
parentapp-crypt/cfssl: Remove old (diff)
downloadgentoo-16c437b88f1dad5bc0a6d2871a406f9d105e1192.tar.gz
gentoo-16c437b88f1dad5bc0a6d2871a406f9d105e1192.tar.bz2
gentoo-16c437b88f1dad5bc0a6d2871a406f9d105e1192.zip
www-servers/thttpd: version bump to 2.27.1
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/thttpd/Manifest1
-rw-r--r--www-servers/thttpd/thttpd-2.27.1.ebuild81
-rw-r--r--www-servers/thttpd/thttpd-9999.ebuild19
3 files changed, 92 insertions, 9 deletions
diff --git a/www-servers/thttpd/Manifest b/www-servers/thttpd/Manifest
index 65853b6ecb91..8a4f8a093132 100644
--- a/www-servers/thttpd/Manifest
+++ b/www-servers/thttpd/Manifest
@@ -1,2 +1,3 @@
DIST sthttpd-2.26.4.tar.gz 194544 SHA256 78e87979140cbda123c81b4051552242dbbffb5dec1a17e5f95ec4826b1eaddb SHA512 64d0ab4720cc0a8926bc8537d335f5238e5343cf6caad837fe09fe46bfaaaa7013b690193905b3db31a5e945141e7fb3aca52355459ff151ce56b30cfefccd87 WHIRLPOOL e38cce33dd417ce8e30426d0764797e24ebfab2060bacf2f27ee2717b2025e48e6f32245cc6a5ebfed856f8755098f1540ec7ed2005aad1aeff65454dd731c1a
DIST sthttpd-2.27.0.tar.gz 206781 SHA256 97d660a881331e93818e872ce11536f461105d70a18dfc5de5895851c4b2afdb SHA512 78945867a01de2f9019deb2d1f21cdedf675c9d67f5de672d0d0bfdc397b444ac287a91d96976dddcdca080cc944e72dd3d1f95f31a592eb839125c494799bdc WHIRLPOOL 55ab90405b3affcb260dc4cfa14008f79cc0b2fd808686078b34ae0a6be2cc4941241406d78f9c2d06360ab6a07f1bf4abc1cf814a46ebe136f031058026419f
+DIST thttpd-2.27.1.tar.gz 96430 SHA256 a1ee2806432eaf5b5dd267a0523701f9f1fa00fefd499d5bec42165a41e05846 SHA512 5d42e32652eb2310c7379d2c4373ad8f54b33bd7c2b444f06d1756eb4ed296774ce3144d91bbba85c6ad604e575128dc7199b797dc8d1b4849b0249054ba5d24 WHIRLPOOL e64b132e83b459fb0ab6da6f3a15c4a603f8d4f53f123cabccc82077506a258c616c2703992b671e9193c26c452bd3b6908ebfadfb15301f1e34f8925303f625
diff --git a/www-servers/thttpd/thttpd-2.27.1.ebuild b/www-servers/thttpd/thttpd-2.27.1.ebuild
new file mode 100644
index 000000000000..444e91998588
--- /dev/null
+++ b/www-servers/thttpd/thttpd-2.27.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools eutils flag-o-matic toolchain-funcs user
+
+if [[ ${PV} = 9999* ]]
+then
+ EGIT_REPO_URI="https://github.com/blueness/sthttpd.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ MY_P="s${P}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/blueness/sthttpd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+DESCRIPTION="Fork of thttpd, a small, fast, multiplexing webserver"
+HOMEPAGE="http://opensource.dyc.edu/sthttpd"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+WEBROOT="/var/www/localhost"
+
+THTTPD_USER=thttpd
+THTTPD_GROUP=thttpd
+THTTPD_DOCROOT="${EPREFIX}${WEBROOT}/htdocs"
+
+DOCS=( TODO )
+
+pkg_setup() {
+ ebegin "Creating thttpd user and group"
+ enewgroup ${THTTPD_GROUP}
+ enewuser ${THTTPD_USER} -1 -1 -1 ${THTTPD_GROUP}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/thttpd-renamed-htpasswd.patch
+ mv "${S}"/extras/{htpasswd.c,th_htpasswd.c} || die
+ eapply_user
+ eautoreconf -f -i
+}
+
+src_configure() {
+ econf WEBDIR=${THTTPD_DOCROOT}
+}
+
+src_install () {
+ default
+
+ newinitd "${FILESDIR}"/thttpd.init.1 thttpd
+ newconfd "${FILESDIR}"/thttpd.confd.1 thttpd
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/thttpd.logrotate" thttpd
+
+ insinto /etc/thttpd
+ doins "${FILESDIR}"/thttpd.conf.sample
+
+ #move htdocs to docdir, bug #429632
+ docompress -x /usr/share/doc/"${PF}"/htdocs.dist
+ mv "${ED}"${WEBROOT}/htdocs \
+ "${ED}"/usr/share/doc/"${PF}"/htdocs.dist || die
+ mkdir "${ED}"${WEBROOT}/htdocs || die
+
+ keepdir ${WEBROOT}/htdocs
+
+ chown root:${THTTPD_GROUP} "${ED}/usr/sbin/makeweb" \
+ || die "Failed chown makeweb"
+ chmod 2751 "${ED}/usr/sbin/makeweb" \
+ || die "Failed chmod makeweb"
+ chmod 755 "${ED}/usr/share/doc/${PF}/htdocs.dist/cgi-bin/printenv" \
+ || die "Failed chmod printenv"
+}
diff --git a/www-servers/thttpd/thttpd-9999.ebuild b/www-servers/thttpd/thttpd-9999.ebuild
index 08393701c50c..444e91998588 100644
--- a/www-servers/thttpd/thttpd-9999.ebuild
+++ b/www-servers/thttpd/thttpd-9999.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
inherit autotools eutils flag-o-matic toolchain-funcs user
if [[ ${PV} = 9999* ]]
then
- EGIT_REPO_URI="git://opensource.dyc.edu/s${PN}.git"
- inherit git-2
+ EGIT_REPO_URI="https://github.com/blueness/sthttpd.git"
+ inherit git-r3
KEYWORDS=""
else
MY_P="s${P}"
S="${WORKDIR}/${MY_P}"
- SRC_URI="http://opensource.dyc.edu/pub/sthttpd/${MY_P}.tar.gz"
+ SRC_URI="https://github.com/blueness/sthttpd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
fi
@@ -33,7 +33,7 @@ THTTPD_USER=thttpd
THTTPD_GROUP=thttpd
THTTPD_DOCROOT="${EPREFIX}${WEBROOT}/htdocs"
-DOCS=( README TODO )
+DOCS=( TODO )
pkg_setup() {
ebegin "Creating thttpd user and group"
@@ -43,7 +43,8 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/thttpd-renamed-htpasswd.patch
- mv "${S}"/extras/{htpasswd.c,th_htpasswd.c}
+ mv "${S}"/extras/{htpasswd.c,th_htpasswd.c} || die
+ eapply_user
eautoreconf -f -i
}
@@ -66,8 +67,8 @@ src_install () {
#move htdocs to docdir, bug #429632
docompress -x /usr/share/doc/"${PF}"/htdocs.dist
mv "${ED}"${WEBROOT}/htdocs \
- "${ED}"/usr/share/doc/"${PF}"/htdocs.dist
- mkdir "${ED}"${WEBROOT}/htdocs
+ "${ED}"/usr/share/doc/"${PF}"/htdocs.dist || die
+ mkdir "${ED}"${WEBROOT}/htdocs || die
keepdir ${WEBROOT}/htdocs