summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-11-11 13:04:47 -0500
committerMike Pagano <mpagano@gentoo.org>2022-11-11 13:04:47 -0500
commit3a063e951e6c6f246d677d005666dfa9150636e1 (patch)
tree56e024f495a82cfbfe7876ad5725a96ba5b0d6b1 /www-servers
parentmedia-video/webcamoid: remove RESTRICT="mirror" from 9.0.0 (diff)
downloadgentoo-3a063e951e6c6f246d677d005666dfa9150636e1.tar.gz
gentoo-3a063e951e6c6f246d677d005666dfa9150636e1.tar.bz2
gentoo-3a063e951e6c6f246d677d005666dfa9150636e1.zip
www-servers/nginx-unit: drop 1.26.1
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx-unit/Manifest1
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.26.1.ebuild88
2 files changed, 0 insertions, 89 deletions
diff --git a/www-servers/nginx-unit/Manifest b/www-servers/nginx-unit/Manifest
index 6db8eba44be2..e9d04be7e3e6 100644
--- a/www-servers/nginx-unit/Manifest
+++ b/www-servers/nginx-unit/Manifest
@@ -1,2 +1 @@
-DIST nginx-unit-1.26.1.tar.gz 865811 BLAKE2B eb0b62e48a8d0f9199dfe77a2d6ec90a06ac24f83b362ae16fde83eea53e03923127be7b24da47a83cf51fc4ebe7930cba9a3ee7550a5243f242cc4bfba3a3b9 SHA512 1caadb35cb208067a5d437e1f649c9f9a833a39c4344b2c3a5ae94d9fcd811913e2f23114cf8d7886030306e036da18c55f09044b8a575c1616568321b8d84ec
DIST nginx-unit-1.28.0.tar.gz 878878 BLAKE2B 91906e342e3fc1154c781481110a8e5496a74da010b2c0618c7c27d63cf0926d94f17fd6206d7868e9ad39f0fbbb476fb3410d46b4b7935e942653d8328af840 SHA512 7d2033be3d8e9d15db21b5431348be73a10fbc19bcab7e83d3c5a770e11e23a53967afe051ec53e236896ac9e021d9146501bc32b87254f9b25778b4bc5d1cbe
diff --git a/www-servers/nginx-unit/nginx-unit-1.26.1.ebuild b/www-servers/nginx-unit/nginx-unit-1.26.1.ebuild
deleted file mode 100644
index a8f53d5b68c9..000000000000
--- a/www-servers/nginx-unit/nginx-unit-1.26.1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit flag-o-matic python-single-r1 systemd toolchain-funcs
-
-MY_P="unit-${PV}"
-DESCRIPTION="Dynamic web and application server"
-HOMEPAGE="https://unit.nginx.org"
-SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64"
-MY_USE="perl python ruby"
-MY_USE_PHP="php7-4"
-IUSE="${MY_USE} ${MY_USE_PHP} ssl"
-REQUIRED_USE="|| ( ${IUSE} )
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="perl? ( dev-lang/perl:= )
- php7-4? ( dev-lang/php:7.4[embed] )
- python? ( ${PYTHON_DEPS} )
- ruby? (
- dev-lang/ruby:=
- dev-ruby/rubygems:=
- )
- ssl? ( dev-libs/openssl:0= )
- virtual/libcrypt:0="
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- eapply_user
- sed -i '/^CFLAGS/d' auto/make || die
- default
-}
-
-src_configure() {
- local opt=(
- --control=unix:/run/${PN}.sock
- --log=/var/log/${PN}
- --modules=$(get_libdir)/${PN}
- --pid=/run/${PN}.pid
- --prefix=/usr
- --state=/var/lib/${PN}
- )
-
- use ssl && opt+=( --openssl )
- export AR="$(tc-getAR)"
- export CC="$(tc-getCC)"
- ./configure ${opt[@]} --ld-opt="${LDFLAGS}" || die "Core configuration failed"
-
- # Modules require position-independent code
- append-cflags $(test-flags-CC -fPIC)
-
- for flag in ${MY_USE} ; do
- if use ${flag} ; then
- ./configure ${flag} || die "Module configuration failed: ${flag}"
- fi
- done
-
- for flag in ${MY_USE_PHP} ; do
- if use ${flag} ; then
- local php_slot="/usr/$(get_libdir)/${flag/-/.}"
- ./configure php \
- --module=${flag} \
- --config=${php_slot}/bin/php-config \
- --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
- fi
- done
-}
-
-src_install() {
- default
-
- diropts -m 0770
- keepdir /var/lib/${PN}
- newinitd "${FILESDIR}/${PN}.initd" ${PN}
- systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
-}