summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-13 10:09:35 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-13 10:09:35 +0100
commit4df2160146b9b86175fa8d3c68e42dcc5f0e4fb0 (patch)
tree6030f25ede875f5ff8c9ed163f3945ce4bbc4343 /www-servers
parentdev-libs/rlog: Fixed build with sys-devel/autoconf:2.70 (diff)
downloadgentoo-4df2160146b9b86175fa8d3c68e42dcc5f0e4fb0.tar.gz
gentoo-4df2160146b9b86175fa8d3c68e42dcc5f0e4fb0.tar.bz2
gentoo-4df2160146b9b86175fa8d3c68e42dcc5f0e4fb0.zip
www-servers/varnish: Bump to version 6.5.1
Fixed build with sys-devel/autoconf:2.70 Closes: https://bugs.gentoo.org/751190 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/varnish/Manifest1
-rw-r--r--www-servers/varnish/files/varnish-6.5.1-autoconf-2.70.patch50
-rw-r--r--www-servers/varnish/varnish-6.5.1.ebuild103
3 files changed, 154 insertions, 0 deletions
diff --git a/www-servers/varnish/Manifest b/www-servers/varnish/Manifest
index dd921ec46677..c9c3ff1a66c0 100644
--- a/www-servers/varnish/Manifest
+++ b/www-servers/varnish/Manifest
@@ -2,3 +2,4 @@ DIST varnish-6.0.6.tgz 3136931 BLAKE2B 2ce379622b20a939a977a426cb842ba62e4fd5fd3
DIST varnish-6.3.2.tgz 3323908 BLAKE2B 5bde1b2ececeb8aed884db22ed75bfd74f82d68416e71400a4c0d27483fcceb029fe8e724e30754899c872d7028da5cb759545f0743a11d0e90b0fd604af0ad7 SHA512 0f476c642df834737d446b3bc6ac8afa5981d1de5810dc6e8556eb22b2ca26d64eb531f4ad3332eb86e231a7443fe35393177ec6dbee97a837f405d1aa9d03cd
DIST varnish-6.4.0.tgz 3404617 BLAKE2B 0ef0f7303f5c926bb1b80ec14cdd9755d65c1938fa8645240800ac2997f954022133625a74dd9c30ce21850674c3b00777fcc896309f528e6ba90d347333d7f7 SHA512 cda8f9e1d301a2b79db14685a23e25e36225f37065a1b7f37c5ae12fbb0483be51be9ffcc8ba72c1f65f5a022d1e408825694daed6780e206b9ba91feb2a07a1
DIST varnish-6.5.0.tgz 3476969 BLAKE2B bafa8704f28dfa96f681805cc053dd6415e143016b1bbff7f8962f2c3ac5cd07be6dc2f4129a423ddfcbf9f9f8afc57388930685d0ed400f3c06ba03bd667d87 SHA512 43f8cd6429a903a353ac4448b6e9aff445b0d52178141a148d3b29b987c0974841820af0da4917731775b46899c12b0327d64d12e3ddbb8fd438e2802ac66a1c
+DIST varnish-6.5.1.tgz 3460024 BLAKE2B 20abebf1df826987623c951122dd8ab2b500c0a64aca192fb12db8846e60938c2f444cf5f471d02aee4f3aeea05f4074bec335e963ab8a2fd59bef47e77df501 SHA512 0f34f2c6fe68bfcdba488cda40cc387b3c10343923a75a6a1791c890d20e79c64069697c45720cd5f0cba666d506d3ab6bb814ef4f9120cf0c8519a01144844f
diff --git a/www-servers/varnish/files/varnish-6.5.1-autoconf-2.70.patch b/www-servers/varnish/files/varnish-6.5.1-autoconf-2.70.patch
new file mode 100644
index 000000000000..beb400620fad
--- /dev/null
+++ b/www-servers/varnish/files/varnish-6.5.1-autoconf-2.70.patch
@@ -0,0 +1,50 @@
+From c6f70f8ca126b34a218248109b78a540d3a4989a Mon Sep 17 00:00:00 2001
+From: Simon Stridsberg <simon@devsn.se>
+Date: Tue, 12 Jan 2021 15:34:33 +0000
+Subject: [PATCH] Fix autoconf error in version 2.70
+
+Fixes #3491
+---
+ configure.ac | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index e44b61fffe..3763b3f34d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -40,9 +40,9 @@ AC_PROG_INSTALL
+ AC_ARG_WITH([rst2man],
+ AS_HELP_STRING([--with-rst2man=PATH], [Location of rst2man (auto)]),
+ [RST2MAN="$withval"],
+- AC_CHECK_PROGS(RST2MAN,
++ [AC_CHECK_PROGS(RST2MAN,
+ [rst2man-3.6 rst2man-3 rst2man rst2man.py],
+- [no]))
++ [no])])
+ if test "x$RST2MAN" = "xno"; then
+ AC_MSG_ERROR(
+ [rst2man is needed to build Varnish, please install python3-docutils.])
+@@ -51,9 +51,9 @@ fi
+ AC_ARG_WITH([sphinx-build],
+ AS_HELP_STRING([--with-sphinx-build=PATH], [Location of sphinx-build (auto)]),
+ [SPHINX="$withval"],
+- AC_CHECK_PROGS(SPHINX,
++ [AC_CHECK_PROGS(SPHINX,
+ [sphinx-build-3.6 sphinx-build-3 sphinx-build],
+- [no]))
++ [no])])
+ if test "x$SPHINX" = "xno"; then
+ AC_MSG_ERROR(
+ [sphinx-build is needed to build Varnish, please install python3-sphinx.])
+@@ -62,9 +62,9 @@ fi
+ AC_ARG_WITH([rst2html],
+ AS_HELP_STRING([--with-rst2html=PATH], [Location of rst2html (auto)]),
+ [RST2HTML="$withval"],
+- AC_CHECK_PROGS(RST2HTML,
++ [AC_CHECK_PROGS(RST2HTML,
+ [rst2html-3.6 rst2html-3 rst2html rst2html.py],
+- "no"))
++ "no")])
+
+ if test "x$RST2HTML" = "xno"; then
+ AC_MSG_ERROR(
diff --git a/www-servers/varnish/varnish-6.5.1.ebuild b/www-servers/varnish/varnish-6.5.1.ebuild
new file mode 100644
index 000000000000..02d9937423c0
--- /dev/null
+++ b/www-servers/varnish/varnish-6.5.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit autotools systemd python-r1
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="https://varnish-cache.org/"
+SRC_URI="http://varnish-cache.org/_downloads/${P}.tgz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="jemalloc jit static-libs"
+
+CDEPEND="
+ sys-libs/readline:0=
+ dev-libs/libpcre[jit?]
+ jemalloc? ( dev-libs/jemalloc )
+ sys-libs/ncurses:0="
+
+#varnish compiles stuff at run time
+RDEPEND="
+ ${PYTHON_DEPS}
+ ${CDEPEND}
+ acct-user/varnish
+ acct-group/varnish
+ sys-devel/gcc"
+
+DEPEND="
+ ${CDEPEND}
+ dev-python/docutils
+ dev-python/sphinx
+ virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test" #315725
+
+PATCHES=(
+ "${FILESDIR}/${P}-autoconf-2.70.patch" #751190
+)
+
+src_prepare() {
+ # Remove -Werror bug #528354
+ sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac
+
+ # Upstream doesn't put varnish.m4 in the m4/ directory
+ # We link because the Makefiles look for the file in
+ # the original location
+ ln -sf ../varnish.m4 m4/varnish.m4
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable jit pcre-jit)
+ $(use_with jemalloc)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
+
+ newinitd "${FILESDIR}"/varnishlog.initd varnishlog
+ newconfd "${FILESDIR}"/varnishlog.confd varnishlog
+
+ newinitd "${FILESDIR}"/varnishncsa.initd varnishncsa
+ newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
+
+ newinitd "${FILESDIR}"/varnishd.initd-r4 varnishd
+ newconfd "${FILESDIR}"/varnishd.confd-r4 varnishd
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
+
+ diropts -m750
+
+ keepdir /var/lib/varnish
+ keepdir /var/log/varnish
+
+ systemd_dounit "${FILESDIR}/${PN}d.service"
+
+ insinto /etc/varnish/
+ doins lib/libvmod_std/vmod_std.vcc
+ doins etc/example.vcl
+
+ dodoc README.rst
+ dodoc doc/changes.rst
+
+ fowners root:varnish /etc/varnish/
+ fowners varnish:varnish /var/lib/varnish/
+ fperms 0750 /var/lib/varnish/ /etc/varnish/
+}