summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-10-14 21:36:08 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-10-14 21:36:08 -0400
commit983b4c1124dd5d43b23af9561948ab225c8f4413 (patch)
tree25c2aac1477058af9cfb792dcf6603ce26734ec3 /www-servers
parentnet-dns/avahi: unconditionally depend on xmltoman, bug #563046. (diff)
downloadgentoo-983b4c1124dd5d43b23af9561948ab225c8f4413.tar.gz
gentoo-983b4c1124dd5d43b23af9561948ab225c8f4413.tar.bz2
gentoo-983b4c1124dd5d43b23af9561948ab225c8f4413.zip
www-servers/monkeyd: version bump 1.6.3. enable tls plugin.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/monkeyd/Manifest2
-rw-r--r--www-servers/monkeyd/files/monkeyd-1.6.3-system-mbedtls.patch19
-rw-r--r--www-servers/monkeyd/monkeyd-1.6.3.ebuild (renamed from www-servers/monkeyd/monkeyd-1.6.2.ebuild)14
-rw-r--r--www-servers/monkeyd/monkeyd-9999.ebuild14
4 files changed, 36 insertions, 13 deletions
diff --git a/www-servers/monkeyd/Manifest b/www-servers/monkeyd/Manifest
index 29e9b396ce53..443362c8bd5d 100644
--- a/www-servers/monkeyd/Manifest
+++ b/www-servers/monkeyd/Manifest
@@ -1,2 +1,2 @@
DIST monkey-1.5.6.tar.gz 902636 SHA256 7c3d845306aa74ee6effd7ab6169d16ac4e6450e564954d0d0baa2d1e9be1a22 SHA512 4c7c627cb047252252b22da5fba179a21fb5b8dc6280b96307af52757ad049d24b0daaaea51dca4f0429af5e6499c239f6b62a03654cc9e7ad98ae8f5149b64c WHIRLPOOL aba1a928023fc67224f254182eb9707c6594c7092d9ff98ecfa297c91d5c61f79235e7467192b5d46ac114ae67a3cee98e06704721348a40ee825755ab39d9a1
-DIST monkey-1.6.2.tar.gz 1913867 SHA256 d26ff514d64bb2de503a9a4d61fce20d89deff0f2f9f958977db4b98e44ece3e SHA512 2fe3b82386d580974509b03ea66caa05adec76178296d736d994ff7f4aedd52fcd298fad083050c59378b1a6cc37cbe8fd34c437a95830fd78304c710bb16b8b WHIRLPOOL 1b1bc34b0534130ce489040e2283d9b074c43ca58f9005832ceb92be92d38e70e482daf405022e1933a9300b782231747d91f937a5b2468a44f0eaa5a4fb984a
+DIST monkey-1.6.3.tar.gz 2032771 SHA256 47973b12cc45c185b054e251a6c3d8a36cae70301f614b4132bb1ef504f01cfa SHA512 21d317b55bc22e0ef34a2ff545103fbba3728a47e888db58506891e525e926397af81d0ad42ac134f67ab30548853ea4c98df264fab6238901dd05c5b0f55abe WHIRLPOOL acda82625c281f31212eb22d4cef0f64fa251fad25ba5e8aa9e2f4f2146d5bd626a6c66cdb2d17f6559cc858d09fd0afd2383bcdccbf225b8956e2f8b272726c
diff --git a/www-servers/monkeyd/files/monkeyd-1.6.3-system-mbedtls.patch b/www-servers/monkeyd/files/monkeyd-1.6.3-system-mbedtls.patch
new file mode 100644
index 000000000000..30d13cc426b8
--- /dev/null
+++ b/www-servers/monkeyd/files/monkeyd-1.6.3-system-mbedtls.patch
@@ -0,0 +1,19 @@
+diff -Naur monkey-1.6.3.orig/plugins/tls/CMakeLists.txt monkey-1.6.3/plugins/tls/CMakeLists.txt
+--- monkey-1.6.3.orig/plugins/tls/CMakeLists.txt 2015-10-13 13:23:34.000000000 -0400
++++ monkey-1.6.3/plugins/tls/CMakeLists.txt 2015-10-14 21:28:27.941930485 -0400
+@@ -2,15 +2,6 @@
+ tls.c
+ )
+
+-if(NOT WITH_MBEDTLS_SHARED)
+- option(ENABLE_TESTING OFF)
+- option(ENABLE_PROGRAMS OFF)
+- option(INSTALL_MBEDTLS_HEADERS OFF)
+- set(MK_MBEDTLS_SRC ../../deps/mbedtls-2.1.2)
+- add_subdirectory(${MK_MBEDTLS_SRC} ${CMAKE_BINARY_DIR}/mbedtls-2.1.2)
+- include_directories(${MK_MBEDTLS_SRC}/include)
+-endif()
+-
+ MONKEY_PLUGIN(tls "${src}")
+
+ MONKEY_PLUGIN_LINK_LIB(tls mbedtls)
diff --git a/www-servers/monkeyd/monkeyd-1.6.2.ebuild b/www-servers/monkeyd/monkeyd-1.6.3.ebuild
index e0f015929ad5..fc9146ee2746 100644
--- a/www-servers/monkeyd/monkeyd-1.6.2.ebuild
+++ b/www-servers/monkeyd/monkeyd-1.6.3.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-inherit flag-o-matic toolchain-funcs multilib
+inherit eutils flag-o-matic toolchain-funcs multilib
DESCRIPTION="A small, fast, and scalable web server"
HOMEPAGE="http://www.monkey-project.com/"
@@ -21,22 +21,23 @@ fi
LICENSE="GPL-2"
SLOT="0"
-# Currently monkeyd_plugins_tls is off. It provides mbed TLS (formerly PolarSSL).
# jemalloc is also off until we figure out how to work CMakeLists.txt magic.
-#PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril monkeyd_plugins_tls"
#IUSE="cgi -debug fastcgi jemalloc php static-plugins ${PLUGINS}"
-PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril"
+PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril monkeyd_plugins_tls"
IUSE="cgi -debug fastcgi php static-plugins ${PLUGINS}"
# uclibc is often compiled without backtrace info so we should
# force this off. If someone complains, consider relaxing it.
REQUIRED_USE="
+ monkeyd_plugins_tls? ( !static-plugins )
elibc_uclibc? ( !debug )
cgi? ( php )"
#DEPEND="jemalloc? ( >=dev-libs/jemalloc-3.3.1 )"
-DEPEND="dev-util/cmake"
+DEPEND="
+ dev-util/cmake
+ monkeyd_plugins_tls? ( net-libs/mbedtls:= )"
RDEPEND="
php? ( dev-lang/php )
cgi? ( dev-lang/php[cgi] )"
@@ -56,8 +57,9 @@ pkg_setup() {
}
src_prepare() {
- # Unconditionally get rid of the bundled jemalloc and mbedTLS
+ # Unconditionally get rid of the bundled jemalloc
rm -rf "${S}"/deps
+ epatch "${FILESDIR}"/${P}-system-mbedtls.patch
}
src_configure() {
diff --git a/www-servers/monkeyd/monkeyd-9999.ebuild b/www-servers/monkeyd/monkeyd-9999.ebuild
index e0f015929ad5..fc9146ee2746 100644
--- a/www-servers/monkeyd/monkeyd-9999.ebuild
+++ b/www-servers/monkeyd/monkeyd-9999.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-inherit flag-o-matic toolchain-funcs multilib
+inherit eutils flag-o-matic toolchain-funcs multilib
DESCRIPTION="A small, fast, and scalable web server"
HOMEPAGE="http://www.monkey-project.com/"
@@ -21,22 +21,23 @@ fi
LICENSE="GPL-2"
SLOT="0"
-# Currently monkeyd_plugins_tls is off. It provides mbed TLS (formerly PolarSSL).
# jemalloc is also off until we figure out how to work CMakeLists.txt magic.
-#PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril monkeyd_plugins_tls"
#IUSE="cgi -debug fastcgi jemalloc php static-plugins ${PLUGINS}"
-PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril"
+PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril monkeyd_plugins_tls"
IUSE="cgi -debug fastcgi php static-plugins ${PLUGINS}"
# uclibc is often compiled without backtrace info so we should
# force this off. If someone complains, consider relaxing it.
REQUIRED_USE="
+ monkeyd_plugins_tls? ( !static-plugins )
elibc_uclibc? ( !debug )
cgi? ( php )"
#DEPEND="jemalloc? ( >=dev-libs/jemalloc-3.3.1 )"
-DEPEND="dev-util/cmake"
+DEPEND="
+ dev-util/cmake
+ monkeyd_plugins_tls? ( net-libs/mbedtls:= )"
RDEPEND="
php? ( dev-lang/php )
cgi? ( dev-lang/php[cgi] )"
@@ -56,8 +57,9 @@ pkg_setup() {
}
src_prepare() {
- # Unconditionally get rid of the bundled jemalloc and mbedTLS
+ # Unconditionally get rid of the bundled jemalloc
rm -rf "${S}"/deps
+ epatch "${FILESDIR}"/${P}-system-mbedtls.patch
}
src_configure() {