summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <brahmajit.xyz@gmail.com>2022-07-12 00:54:41 +0530
committerAlfredo Tupone <tupone@gentoo.org>2022-07-11 21:27:27 +0200
commit9b810c67bdeed3a2ea8ddea55034dbf7f3f33de7 (patch)
tree99703d387e890929a73cfcbdd392fca63fde6ff4 /www-servers
parentgames-action/brutal-legend: Split into gog and hb packages (diff)
downloadgentoo-9b810c67bdeed3a2ea8ddea55034dbf7f3f33de7.tar.gz
gentoo-9b810c67bdeed3a2ea8ddea55034dbf7f3f33de7.tar.bz2
gentoo-9b810c67bdeed3a2ea8ddea55034dbf7f3f33de7.zip
www-servers/moonbridge: Fix building on musl. Include fcntl
It is explicitely required to include fcntl.h in musl. Else we get F_SETFD, FD_CLOEXEC undefined errors. Closes: https://bugs.gentoo.org/828671 Signed-off-by: brahmajit das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/26352 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/moonbridge/files/moonbridge-1.0.1-fcntl.patch14
-rw-r--r--www-servers/moonbridge/moonbridge-1.0.1.ebuild5
2 files changed, 18 insertions, 1 deletions
diff --git a/www-servers/moonbridge/files/moonbridge-1.0.1-fcntl.patch b/www-servers/moonbridge/files/moonbridge-1.0.1-fcntl.patch
new file mode 100644
index 000000000000..2a1d15b09238
--- /dev/null
+++ b/www-servers/moonbridge/files/moonbridge-1.0.1-fcntl.patch
@@ -0,0 +1,14 @@
+#It is explicitely required to include fcntl.h in musl.
+#Else we get F_SETFD, FD_CLOEXEC undefined errors.
+#
+#Closes: https://bugs.gentoo.org/828671
+--- a/moonbridge.c
++++ b/moonbridge.c
+@@ -36,6 +36,7 @@
+ #include <getopt.h>
+ #include <sys/file.h>
+ #include <syslog.h>
++#include <fcntl.h>
+ #if defined(__FreeBSD__) || __has_include(<libutil.h>)
+ #include <libutil.h>
+ #endif
diff --git a/www-servers/moonbridge/moonbridge-1.0.1.ebuild b/www-servers/moonbridge/moonbridge-1.0.1.ebuild
index 93fb08c942b9..c718ae8e1f34 100644
--- a/www-servers/moonbridge/moonbridge-1.0.1.ebuild
+++ b/www-servers/moonbridge/moonbridge-1.0.1.ebuild
@@ -27,7 +27,10 @@ BDEPEND="sys-devel/pmake
S="${WORKDIR}"/${MYP}
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-fcntl.patch
+)
DOCS=( README reference.txt )