summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-01 21:07:42 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-01 21:07:42 +0100
commite2c402d072037075abed4a76de937b305d2dfc73 (patch)
treef1d77d29e56e49da9c7b17ac53ab4c37041d1bea /www-servers
parentvirtual/libintl: remove uclibc (diff)
downloadgentoo-e2c402d072037075abed4a76de937b305d2dfc73.tar.gz
gentoo-e2c402d072037075abed4a76de937b305d2dfc73.tar.bz2
gentoo-e2c402d072037075abed4a76de937b305d2dfc73.zip
www-servers/monkeyd: remove uclibc
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/monkeyd/monkeyd-1.6.9-r2.ebuild13
-rw-r--r--www-servers/monkeyd/monkeyd-9999.ebuild13
2 files changed, 2 insertions, 24 deletions
diff --git a/www-servers/monkeyd/monkeyd-1.6.9-r2.ebuild b/www-servers/monkeyd/monkeyd-1.6.9-r2.ebuild
index 0be511e56215..574514f722de 100644
--- a/www-servers/monkeyd/monkeyd-1.6.9-r2.ebuild
+++ b/www-servers/monkeyd/monkeyd-1.6.9-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,11 +25,8 @@ SLOT="0"
PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril monkeyd_plugins_tls"
IUSE="cgi debug fastcgi php static-plugins ${PLUGINS}"
-# uclibc is often compiled without backtrace info so we should
-# force this off. If someone complains, consider relaxing it.
REQUIRED_USE="
monkeyd_plugins_tls? ( !static-plugins )
- elibc_uclibc? ( !debug )
cgi? ( php )"
#DEPEND="jemalloc? ( >=dev-libs/jemalloc-3.3.1 )"
@@ -68,7 +65,6 @@ src_configure() {
append-cflags -fcommon
local myconf=""
- use elibc_uclibc && myconf+=" --uclib-mode"
use elibc_musl && myconf+=" --musl-mode"
#use jemalloc || myconf+=" --malloc-libc"
@@ -98,13 +94,6 @@ src_configure() {
myconf+=" --static-plugins=${enable_plugins%,}"
fi
- # For O_CLOEXEC which is guarded by _GNU_SOURCE in uClibc,
- # but shouldn't because it is POSIX. This needs to be fixed
- # in uClibc. Also, we really should us append-cppflags but
- # monkey's build system doesn't respect CPPFLAGS. This needs
- # to be fixed in monkey.
- use elibc_uclibc && append-cflags -D_GNU_SOURCE
-
# Non-autotools configure
./configure \
--pthread-tls \
diff --git a/www-servers/monkeyd/monkeyd-9999.ebuild b/www-servers/monkeyd/monkeyd-9999.ebuild
index 3308111d6ea3..a0b187211a62 100644
--- a/www-servers/monkeyd/monkeyd-9999.ebuild
+++ b/www-servers/monkeyd/monkeyd-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,11 +25,8 @@ SLOT="0"
PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril monkeyd_plugins_tls"
IUSE="cgi debug fastcgi php static-plugins ${PLUGINS}"
-# uclibc is often compiled without backtrace info so we should
-# force this off. If someone complains, consider relaxing it.
REQUIRED_USE="
monkeyd_plugins_tls? ( !static-plugins )
- elibc_uclibc? ( !debug )
cgi? ( php )"
#DEPEND="jemalloc? ( >=dev-libs/jemalloc-3.3.1 )"
@@ -68,7 +65,6 @@ src_configure() {
append-cflags -fcommon
local myconf=""
- use elibc_uclibc && myconf+=" --uclib-mode"
use elibc_musl && myconf+=" --musl-mode"
#use jemalloc || myconf+=" --malloc-libc"
@@ -98,13 +94,6 @@ src_configure() {
myconf+=" --static-plugins=${enable_plugins%,}"
fi
- # For O_CLOEXEC which is guarded by _GNU_SOURCE in uClibc,
- # but shouldn't because it is POSIX. This needs to be fixed
- # in uClibc. Also, we really should us append-cppflags but
- # monkey's build system doesn't respect CPPFLAGS. This needs
- # to be fixed in monkey.
- use elibc_uclibc && append-cflags -D_GNU_SOURCE
-
# Non-autotools configure
./configure \
--pthread-tls \