summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-11-28 20:39:01 +0100
committerSebastian Pipping <sping@gentoo.org>2020-11-28 20:41:28 +0100
commite3576b0b403212275e8779457e127522b210da8c (patch)
tree3736ee9a5eaa90e277996d671de3409eb2735a4e /www-servers
parentprofiles/arch/arm: Drop outdated clutter wayland related USE masks (diff)
downloadgentoo-e3576b0b403212275e8779457e127522b210da8c.tar.gz
gentoo-e3576b0b403212275e8779457e127522b210da8c.tar.bz2
gentoo-e3576b0b403212275e8779457e127522b210da8c.zip
www-servers/gatling: Respect variable AR
Closes: https://bugs.gentoo.org/756850 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.0, Repoman-2.3.23
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gatling/files/gatling-0.15-ar.patch30
-rw-r--r--www-servers/gatling/gatling-0.15.ebuild1
2 files changed, 31 insertions, 0 deletions
diff --git a/www-servers/gatling/files/gatling-0.15-ar.patch b/www-servers/gatling/files/gatling-0.15-ar.patch
new file mode 100644
index 000000000000..84b13293e426
--- /dev/null
+++ b/www-servers/gatling/files/gatling-0.15-ar.patch
@@ -0,0 +1,30 @@
+From 64933921d28aa96cbece18e43723117661a8056d Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 28 Nov 2020 20:33:21 +0100
+Subject: [PATCH] GNUmakefile: Respect variable AR
+
+GNU make comes with AR predefined:
+$ make -f <(echo $'.PHONY: all\nall:\n\t@echo "AR is \\"$(AR)\\"."')
+AR is "ar".
+
+Original bug report at https://bugs.gentoo.org/756850
+---
+ GNUmakefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/GNUmakefile b/GNUmakefile
+index 6af7b35..e6b32fe 100644
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -195,7 +195,7 @@ dummy.c:
+ touch $@
+
+ libsocketkludge.a: libsocket libiconv dummy.o
+- ar q $@ dummy.o
++ $(AR) q $@ dummy.o
+ -ranlib $@
+
+ LDLIBS+=`cat libsocket libiconv libcrypt`
+--
+2.27.0
+
diff --git a/www-servers/gatling/gatling-0.15.ebuild b/www-servers/gatling/gatling-0.15.ebuild
index e59507c318fb..c18fb7fe8684 100644
--- a/www-servers/gatling/gatling-0.15.ebuild
+++ b/www-servers/gatling/gatling-0.15.ebuild
@@ -25,6 +25,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-0.13-compile.patch"
+ "${FILESDIR}/${P}-ar.patch"
"${FILESDIR}/${P}-gcc10.patch"
)