summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-12-18 10:29:00 +0100
committerHans de Graaff <graaff@gentoo.org>2020-12-18 10:31:05 +0100
commiteadccf4e6ab0d5c93fd83ed1e5e50dd1477d6ae7 (patch)
tree0d479e49f4982eab06350e0272ef68ebef4abb7d /www-servers
parentwww-servers/puma: add 4.3.7 (diff)
downloadgentoo-eadccf4e6ab0d5c93fd83ed1e5e50dd1477d6ae7.tar.gz
gentoo-eadccf4e6ab0d5c93fd83ed1e5e50dd1477d6ae7.tar.bz2
gentoo-eadccf4e6ab0d5c93fd83ed1e5e50dd1477d6ae7.zip
www-servers/puma: add 5.1.1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/puma/Manifest1
-rw-r--r--www-servers/puma/puma-5.1.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/www-servers/puma/Manifest b/www-servers/puma/Manifest
index 68607153151e..381276124b4f 100644
--- a/www-servers/puma/Manifest
+++ b/www-servers/puma/Manifest
@@ -2,3 +2,4 @@ DIST puma-3.12.5.tar.gz 219175 BLAKE2B 55e80fba8fd84004090cb8d30b6fd01652f1beb1d
DIST puma-4.3.4.tar.gz 241806 BLAKE2B 5450f14112ad45c48794186c7e9f078feed28a4194a917c949f4058b9d3a115273df6d93260de330047fa59730cb3ad45f31eb05e5880569e95a0b2c9de99a42 SHA512 619bf44c17622233b673dbf6c8f34b0463cd32684df81c20f31045d3106a86e110753b4da80e7b51b46fe18d90ee107d9a84a975dc3116840d9a9b5962178873
DIST puma-4.3.7.tar.gz 242780 BLAKE2B 22a81839bde50c61147712b85fceb90af8f46ada0b60d1901d0918d75cd7a006a3c71a2c525b83846b3719b44419725fcc38ec7bd32c8bb6acc916ec95ca7aae SHA512 90262ddbb4c9ceceb023538f8f3e4542de6d02763e2dd60dc24fb1bbde45817bb5a6472469da8d384ec25d97f9501c8afbe2c8da3fb690965a38da4d342a8f1c
DIST puma-5.0.4.tar.gz 275942 BLAKE2B 1e607d7ff44ae9b677f6fb41355fe3b660bd880a642e5d3859e177c9327b68c0db729621ef0b3d7a5bb08917249fb7eac688027ceb62f072dabe7ba30086bf79 SHA512 6804ef3bfd4fa3a6695c213e3550244adace91121cb2c45f06fa4c68fb502787c5fdebba41b4754216eab880ca8738ab6f83d0ec9456a86fc6db99a4d4405bd8
+DIST puma-5.1.1.tar.gz 284807 BLAKE2B 59ba17129e55e79aa2f8092d60a5643840bd996b7832d421cb72538fc48b0fb302353bedef56cc9b115bdfb15b33b0f453bfbf759b2e9552a9490a8b0cef3090 SHA512 8653c622c21dca2116219702e801d7aa3272f0771fd5c2d5149927edbd504a9838fb0d442bfc5dc523035a94dad25946738a5dda954fdaa74a9a00c85ed9f86e
diff --git a/www-servers/puma/puma-5.1.1.ebuild b/www-servers/puma/puma-5.1.1.ebuild
new file mode 100644
index 000000000000..5effca51d3dc
--- /dev/null
+++ b/www-servers/puma/puma-5.1.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_GEMSPEC="puma.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
+HOMEPAGE="https://puma.io/"
+SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
+RDEPEND+=" dev-libs/openssl:0"
+
+ruby_add_bdepend "virtual/ruby-ssl
+ test? ( dev-ruby/rack >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
+
+ruby_add_rdepend "dev-ruby/nio4r:2"
+
+all_ruby_prepare() {
+ sed -e '/bundler/ s:^:#:' \
+ -e '/prove/ s:^:#:' \
+ -e '/stub_const/ s:^:#:' \
+ -i test/helper.rb || die
+
+ # Avoid tests failing inconsistently
+ sed -i -e '/test_bad_client/askip "inconsistent results"' test/test_web_server.rb || die
+
+ # Avoid launcher tests since they make assumptions about bundler use
+ rm -f test/test_launcher.rb test/test_worker_gem_independence.rb || die
+
+ # Skip integration tests since they make a lot of assumptions about
+ # the environment
+ rm -f test/test_integration_* test/test_preserve_bundler_env.rb|| die
+
+ # Avoid test that uses unpackaged stub_const
+ sed -i -e '/test_shutdown_with_grace/,/^ end/ s:^:#:' test/test_thread_pool.rb || die
+
+ sed -e 's/git ls-files --/find/' \
+ -e 's:_relative ": "./:' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/puma_http11 extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/puma_http11
+ cp ext/puma_http11/puma_http11$(get_modname) lib/puma/ || die
+}
+
+each_ruby_test() {
+ einfo "Running test suite"
+ ${RUBY} -Ilib:.:test -e "gem 'minitest', '~>5.9'; gem 'test-unit', '~>3.0'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{|f| require f}" || die
+}