summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-11-30 20:00:37 +0100
committerSebastian Pipping <sping@gentoo.org>2020-11-30 20:08:24 +0100
commitf7355478afc4acfcf55febbf66d346ffbebf2e38 (patch)
treedbd3c50f811e71f2e609d31ddf85336d7e4e2612 /www-servers
parentx11-misc/redshift: 1.12-r3: python 3.8 and 3.9 support. (diff)
downloadgentoo-f7355478afc4acfcf55febbf66d346ffbebf2e38.tar.gz
gentoo-f7355478afc4acfcf55febbf66d346ffbebf2e38.tar.bz2
gentoo-f7355478afc4acfcf55febbf66d346ffbebf2e38.zip
www-servers/gatling: Migrate to acct-user/acct-group packages
Closes: https://bugs.gentoo.org/706812 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.0, Repoman-2.3.23
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gatling/gatling-0.16-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/www-servers/gatling/gatling-0.16-r1.ebuild b/www-servers/gatling/gatling-0.16-r1.ebuild
new file mode 100644
index 000000000000..6616e0b4eca0
--- /dev/null
+++ b/www-servers/gatling/gatling-0.16-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="High performance web server"
+HOMEPAGE="https://www.fefe.de/gatling/"
+SRC_URI="https://www.fefe.de/gatling/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="libressl ssl diet"
+REQUIRED_USE="ssl? ( !diet )"
+
+DEPEND=">=dev-libs/libowfat-0.32-r2[diet=]
+ diet? ( dev-libs/dietlibc )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )"
+RDEPEND="${DEPEND}
+ acct-group/gatling
+ acct-user/gatling
+ "
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.13-compile.patch"
+ "${FILESDIR}/${PN}-0.15-ar.patch"
+)
+
+src_prepare() {
+ default
+ rm Makefile # leaves us with GNUmakefile
+}
+
+src_compile() {
+ local DIET=
+ use diet && DIET='/usr/bin/diet'
+
+ local targets='gatling'
+ use ssl && targets+=' tlsgatling'
+
+ emake DIET="${DIET}" CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I${ROOT}/usr/include/libowfat" \
+ LDFLAGS="${LDFLAGS}" prefix=/usr ${targets}
+}
+
+src_install() {
+ doman gatling.1
+
+ newconfd "${FILESDIR}/gatling.confd" gatling
+ newinitd "${FILESDIR}/gatling.initd-3" gatling
+ dodoc README.{ftp,http}
+
+ dobin gatling
+ use ssl && {
+ dodoc README.tls
+ dobin tlsgatling
+ }
+}