summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-apps/fusion-icon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-apps/fusion-icon')
-rw-r--r--x11-apps/fusion-icon/Manifest1
-rw-r--r--x11-apps/fusion-icon/files/fusion-icon-0.1-qt4-interface-subprocess-call.patch22
-rw-r--r--x11-apps/fusion-icon/fusion-icon-0.1-r2.ebuild57
-rw-r--r--x11-apps/fusion-icon/fusion-icon-0.1-r3.ebuild62
-rw-r--r--x11-apps/fusion-icon/fusion-icon-0.1-r4.ebuild47
-rw-r--r--x11-apps/fusion-icon/metadata.xml6
6 files changed, 195 insertions, 0 deletions
diff --git a/x11-apps/fusion-icon/Manifest b/x11-apps/fusion-icon/Manifest
new file mode 100644
index 000000000000..e6d452d59735
--- /dev/null
+++ b/x11-apps/fusion-icon/Manifest
@@ -0,0 +1 @@
+DIST fusion-icon-0.1.tar.gz 30508 SHA256 2e6757fd4fb8ed7d1640fcabfbe10a39f36cf41504eda0dd13605db70273fe79 SHA512 0c22d0c7a22a9c20f1285114f8b785aff6cf863d4fe3ea1198618b13d7144f459f131dccf885442908fcd82ab4ff69e5fc42e95314836725b0e51fa3190c2bcc WHIRLPOOL 7534f46df3965aa963a95b4ec796c5ef99980c9640a6d0ced6a542d5b22430b9c996d11236bbdf1c8f9f9b00bcf4346e9aaca85da571a81c16777c4e33b3b719
diff --git a/x11-apps/fusion-icon/files/fusion-icon-0.1-qt4-interface-subprocess-call.patch b/x11-apps/fusion-icon/files/fusion-icon-0.1-qt4-interface-subprocess-call.patch
new file mode 100644
index 000000000000..4829e18e60e6
--- /dev/null
+++ b/x11-apps/fusion-icon/files/fusion-icon-0.1-qt4-interface-subprocess-call.patch
@@ -0,0 +1,22 @@
+--- FusionIcon/interface_qt4/main.py.orig 2012-06-05 17:54:13.000000000 +0400
++++ FusionIcon/interface_qt4/main.py 2012-06-05 18:01:13.000000000 +0400
+@@ -19,6 +19,7 @@
+ import sys, os, time
+ from PyQt4 import QtGui, QtCore
+ from FusionIcon.start import wms, apps, options, decorators, init
++import subprocess
+
+ class Build(QtGui.QApplication):
+ def reload_wm(self):
+@@ -63,9 +64,9 @@
+ actionWD.setChecked(True)
+ self.Tray.menu = QtGui.QMenu()
+ if 'ccsm' in apps:
+- self.Tray.menu.addAction(apps['ccsm'].label, lambda: run(['ccsm']))
++ self.Tray.menu.addAction(apps['ccsm'].label, lambda: subprocess.call(['ccsm']))
+ if 'emerald theme manager' in apps:
+- self.Tray.menu.addAction(apps['emerald theme manager'].label, lambda: run(apps['emerald theme manager'].command))
++ self.Tray.menu.addAction(apps['emerald theme manager'].label, lambda: subprocess.call(apps['emerald theme manager'].command))
+ if 'ccsm' in apps or 'emerald theme manager' in apps:
+ self.Tray.menu.addSeparator()
+ self.Tray.menu.addAction("Reload Window Manager", self.reload_wm)
diff --git a/x11-apps/fusion-icon/fusion-icon-0.1-r2.ebuild b/x11-apps/fusion-icon/fusion-icon-0.1-r2.ebuild
new file mode 100644
index 000000000000..79515c6a8030
--- /dev/null
+++ b/x11-apps/fusion-icon/fusion-icon-0.1-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit distutils gnome2-utils
+
+MINIMUM_COMPIZ_RELEASE=0.6.0
+
+DESCRIPTION="Compiz Fusion Tray Icon and Manager"
+HOMEPAGE="http://compiz.org"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk qt4"
+
+REQUIRED_USE="|| ( gtk qt4 )"
+
+RDEPEND="
+ >=dev-python/compizconfig-python-${MINIMUM_COMPIZ_RELEASE}
+ >=x11-wm/compiz-${MINIMUM_COMPIZ_RELEASE}
+ x11-apps/xvinfo
+ gtk? ( >=dev-python/pygtk-2.10:2 )
+ qt4? ( dev-python/PyQt4[X] )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+PYTHON_MODNAME="FusionIcon"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install
+
+ use gtk || rm -fr "${ED}$(python_get_sitedir)/FusionIcon/interface_gtk"
+ use qt4 || rm -fr "${ED}$(python_get_sitedir)/FusionIcon/interface_qt4"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ use gtk && gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+
+ use gtk && gnome2_icon_cache_update
+}
diff --git a/x11-apps/fusion-icon/fusion-icon-0.1-r3.ebuild b/x11-apps/fusion-icon/fusion-icon-0.1-r3.ebuild
new file mode 100644
index 000000000000..2c1bf38c3768
--- /dev/null
+++ b/x11-apps/fusion-icon/fusion-icon-0.1-r3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit distutils eutils gnome2-utils
+
+MINIMUM_COMPIZ_RELEASE=0.6.0
+
+DESCRIPTION="Compiz Fusion Tray Icon and Manager"
+HOMEPAGE="http://compiz.org"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk qt4"
+
+REQUIRED_USE="|| ( gtk qt4 )"
+
+RDEPEND="
+ >=dev-python/compizconfig-python-${MINIMUM_COMPIZ_RELEASE}
+ >=x11-wm/compiz-${MINIMUM_COMPIZ_RELEASE}
+ x11-apps/xvinfo
+ gtk? ( >=dev-python/pygtk-2.10:2 )
+ qt4? ( dev-python/PyQt4[X] )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+PYTHON_MODNAME="FusionIcon"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-qt4-interface-subprocess-call.patch
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ use gtk || rm -fr "${ED}$(python_get_sitedir)/FusionIcon/interface_gtk"
+ use qt4 || rm -fr "${ED}$(python_get_sitedir)/FusionIcon/interface_qt4"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ use gtk && gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+
+ use gtk && gnome2_icon_cache_update
+}
diff --git a/x11-apps/fusion-icon/fusion-icon-0.1-r4.ebuild b/x11-apps/fusion-icon/fusion-icon-0.1-r4.ebuild
new file mode 100644
index 000000000000..c61d9f1e9c9e
--- /dev/null
+++ b/x11-apps/fusion-icon/fusion-icon-0.1-r4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils gnome2-utils
+
+MINIMUM_COMPIZ_RELEASE=0.6.0
+
+DESCRIPTION="Compiz Fusion Tray Icon and Manager"
+HOMEPAGE="http://compiz.org"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk qt4"
+
+REQUIRED_USE="|| ( gtk qt4 )"
+
+RDEPEND="
+ >=dev-python/compizconfig-python-${MINIMUM_COMPIZ_RELEASE}
+ >=x11-wm/compiz-${MINIMUM_COMPIZ_RELEASE}
+ x11-apps/xvinfo
+ gtk? ( >=dev-python/pygtk-2.10:2[${PYTHON_USEDEP}] )
+ qt4? ( dev-python/PyQt4[X,${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${P}-qt4-interface-subprocess-call.patch )
+
+python_install() {
+ distutils-r1_python_install
+ use gtk || rm -r "${D}$(python_get_sitedir)/FusionIcon/interface_gtk" || die
+ use qt4 || rm -r "${D}$(python_get_sitedir)/FusionIcon/interface_qt4" || die
+}
+
+pkg_postinst() {
+ use gtk && gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ use gtk && gnome2_icon_cache_update
+}
diff --git a/x11-apps/fusion-icon/metadata.xml b/x11-apps/fusion-icon/metadata.xml
new file mode 100644
index 000000000000..b19d78282b3f
--- /dev/null
+++ b/x11-apps/fusion-icon/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-effects</herd>
+<longdescription lang="en">Compiz Fusion Tray Icon and Manager.</longdescription>
+</pkgmetadata>