summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-10-28 18:06:40 -0700
committerMatt Turner <mattst88@gentoo.org>2018-10-28 18:13:08 -0700
commite08033079026092e4aaf3bc2027015e0c92f1b76 (patch)
tree9e86e0bb436a1f184ae744ec4208cc6d66b8e68e /x11-apps/igt-gpu-tools/igt-gpu-tools-1.23.ebuild
parentsys-auth/pambase-20150213-r2: amd64 stable, bug 658646 (diff)
downloadgentoo-e08033079026092e4aaf3bc2027015e0c92f1b76.tar.gz
gentoo-e08033079026092e4aaf3bc2027015e0c92f1b76.tar.bz2
gentoo-e08033079026092e4aaf3bc2027015e0c92f1b76.zip
x11-apps/igt-gpu-tools: Rename and version bump to 1.23
Project is not Intel-specific anymore and changed its name to igt-gpu-tools for version 1.23. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps/igt-gpu-tools/igt-gpu-tools-1.23.ebuild')
-rw-r--r--x11-apps/igt-gpu-tools/igt-gpu-tools-1.23.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-apps/igt-gpu-tools/igt-gpu-tools-1.23.ebuild b/x11-apps/igt-gpu-tools/igt-gpu-tools-1.23.ebuild
new file mode 100644
index 000000000000..65bdd0b60689
--- /dev/null
+++ b/x11-apps/igt-gpu-tools/igt-gpu-tools-1.23.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGIT_REPO_URI="https://gitlab.freedesktop.org/drm/${PN}.git"
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson
+
+DESCRIPTION="Intel GPU userland tools"
+
+HOMEPAGE="https://01.org/linuxgraphics https://gitlab.freedesktop.org/drm/igt-gpu-tools"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://www.x.org/releases/individual/app/${P}.tar.xz"
+fi
+LICENSE="MIT"
+SLOT="0"
+IUSE="alsa chamelium doc glib gsl sound valgrind video_cards_amdgpu video_cards_intel video_cards_nouveau X xrandr xv"
+REQUIRED_USE="chamelium? ( glib gsl )"
+RESTRICT="test"
+
+X86_RDEPEND="
+ xv? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXv
+ )"
+X86_DEPEND="x11-base/xorg-proto
+ >=dev-util/peg-0.1.18"
+RDEPEND="sys-apps/kmod:=
+ sys-libs/libunwind:=
+ sys-process/procps:=
+ virtual/libudev:=
+ >=x11-libs/cairo-1.12.0[X?]
+ >=x11-libs/libdrm-2.4.82[video_cards_amdgpu?,video_cards_intel?,video_cards_nouveau?]
+ >=x11-libs/libpciaccess-0.10
+ alsa? ( media-libs/alsa-lib:= )
+ chamelium? ( dev-libs/xmlrpc-c )
+ glib? ( dev-libs/glib:2 )
+ gsl? ( sci-libs/gsl )
+ valgrind? ( dev-util/valgrind )
+ video_cards_intel? ( sys-libs/zlib:= )
+ xrandr? ( >=x11-libs/libXrandr-1.3 )
+ amd64? ( ${X86_RDEPEND} )
+ x86? ( ${X86_RDEPEND} )"
+DEPEND="${RDEPEND}
+ amd64? ( ${X86_DEPEND} )
+ x86? ( ${X86_DEPEND} )
+ doc? ( >=dev-util/gtk-doc-1.25-r1 )"