summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-10-16 12:52:02 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-10-16 12:54:21 +0200
commita3ecfaada9dcf35866e06567926dcd708142a61a (patch)
treeca7342e6bf51a60035a49881ca93313a6c6e4897 /x11-apps/radeon-profile/radeon-profile-20190903.ebuild
parentwww-servers/tomcat-9.0.27: bump (diff)
downloadgentoo-a3ecfaada9dcf35866e06567926dcd708142a61a.tar.gz
gentoo-a3ecfaada9dcf35866e06567926dcd708142a61a.tar.bz2
gentoo-a3ecfaada9dcf35866e06567926dcd708142a61a.zip
x11-apps/radeon-profile: Bump to version 20190903
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-apps/radeon-profile/radeon-profile-20190903.ebuild')
-rw-r--r--x11-apps/radeon-profile/radeon-profile-20190903.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-apps/radeon-profile/radeon-profile-20190903.ebuild b/x11-apps/radeon-profile/radeon-profile-20190903.ebuild
new file mode 100644
index 000000000000..ad6e34fec998
--- /dev/null
+++ b/x11-apps/radeon-profile/radeon-profile-20190903.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Read current clocks of ATi/AMD Radeon cards"
+HOMEPAGE="https://github.com/marazmista/radeon-profile"
+if [[ "${PV}" == 99999999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/marazmista/radeon-profile.git"
+else
+ SRC_URI="https://github.com/marazmista/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+S="${WORKDIR}/${P}/${PN}"
+
+RDEPEND="
+ dev-qt/qtcharts:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ x11-libs/libX11
+ x11-libs/libXrandr
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-qt/qtconcurrent:5
+ media-libs/mesa[X(+)]
+ x11-libs/libdrm
+"
+
+src_prepare() {
+ default
+ sed 's@TrayIcon;@@' -i extra/${PN}.desktop || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ elog "In order to run ${PN} as non-root user, the"
+ elog " x11-apps/radeon-profile-daemon"
+ elog "package needs to be installed and the daemon must run."
+}