summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-apps/simple-ccsm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-apps/simple-ccsm')
-rw-r--r--x11-apps/simple-ccsm/Manifest1
-rw-r--r--x11-apps/simple-ccsm/metadata.xml6
-rw-r--r--x11-apps/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild54
3 files changed, 61 insertions, 0 deletions
diff --git a/x11-apps/simple-ccsm/Manifest b/x11-apps/simple-ccsm/Manifest
new file mode 100644
index 000000000000..821bd0a4a4ab
--- /dev/null
+++ b/x11-apps/simple-ccsm/Manifest
@@ -0,0 +1 @@
+DIST simple-ccsm-0.8.4.tar.bz2 62423 SHA256 15b24408be48f1e3c69735362dd65ea6b3ddded80e63b87ec40268e2f0f652a3 SHA512 f60a689e18fcea494eacc4eaa8718d77b846af6790cb5de056ecd432fd8b5190ebd4ce6669744b3da408e492f68012503f420e28e66be83b747b2e532b152158 WHIRLPOOL 32cd613ac9ed2e82eb6aa61291824d782a3b3fd7758b36e13cbe0ec28007f3633a95cdaa0fce00db720795039cd73b7244f1100f80ad933a67e21cd498f6f421
diff --git a/x11-apps/simple-ccsm/metadata.xml b/x11-apps/simple-ccsm/metadata.xml
new file mode 100644
index 000000000000..7c85fbdd4d61
--- /dev/null
+++ b/x11-apps/simple-ccsm/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-effects</herd>
+<longdescription lang="en">Simplified Compizconfig Settings Manager.</longdescription>
+</pkgmetadata>
diff --git a/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild b/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild
new file mode 100644
index 000000000000..ef064ce75604
--- /dev/null
+++ b/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="Simplified Compizconfig Settings Manager"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ dev-util/intltool
+ virtual/pkgconfig"
+RDEPEND="
+ >=dev-python/compizconfig-python-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.10:2[${PYTHON_USEDEP}]
+ >=x11-apps/ccsm-${PV}[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # return error if wrong arguments passed to setup.py
+ sed -i -e 's/raise SystemExit/\0(1)/' setup.py || die 'sed on setup.py failed'
+ # fix desktop file
+ sed -i \
+ -e '/Categories/s/Compiz/X-\0/' \
+ -e '/Encoding/d' \
+ "${PN}".desktop.in || die "sed on ${PN}.desktop.in failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ mydistutilsargs=( build --prefix=/usr )
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}