summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-apps/xdm/xdm-1.1.11-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-apps/xdm/xdm-1.1.11-r3.ebuild')
-rw-r--r--x11-apps/xdm/xdm-1.1.11-r3.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/x11-apps/xdm/xdm-1.1.11-r3.ebuild b/x11-apps/xdm/xdm-1.1.11-r3.ebuild
new file mode 100644
index 000000000000..9b25e25ed008
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.1.11-r3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_EAUTORECONF=yes
+
+inherit multilib xorg-2 pam systemd
+
+DEFAULTVT=vt7
+
+DESCRIPTION="X.Org xdm application"
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+IUSE="consolekit ipv6 pam xdm-auth"
+
+RDEPEND="x11-apps/xrdb
+ x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-1.0.2-r3
+ x11-libs/libXinerama
+ x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-apps/sessreg
+ x11-apps/xconsole
+ consolekit? ( sys-auth/consolekit )
+ pam? ( virtual/pam )
+ !<sys-apps/systemd-187"
+DEPEND="${RDEPEND}
+ consolekit? ( !=sys-auth/pambase-20101024-r1 )
+ x11-proto/xineramaproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ PATCHES=(
+ "${FILESDIR}"/${PN}-consolekit.patch
+ "${FILESDIR}"/${P}-cve-2013-2179.patch
+ "${FILESDIR}"/${PN}-1.1.11-arc4random-include.patch
+ "${FILESDIR}"/${PN}-1.1.11-setproctitle-include.patch
+ )
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_with pam)
+ "$(systemd_with_unitdir)"
+ --with-default-vt=${DEFAULTVT}
+ --with-xdmconfigdir=/etc/X11/xdm
+ $(use_with consolekit)
+ )
+}
+
+src_prepare() {
+ # fedora invented that in -187...
+ sed -i -e 's:^Alias=.*$:Alias=display-manager.service:' \
+ xdm.service.in || die
+
+ # disable XDM-AUTHENTICATION-1 wrt bug #445662.
+ # it causes issue with libreoffice and SDL games (bug #306223).
+ if use !xdm-auth; then
+ sed -i -e '/authorize/a\
+DisplayManager*authName: MIT-MAGIC-COOKIE-1' \
+ config/xdm-config.cpp || die
+ fi
+ xorg-2_src_prepare
+}
+
+src_install() {
+ xorg-2_src_install
+
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe "${FILESDIR}"/Xsession
+
+ use pam && pamd_mimic system-local-login xdm auth account session
+
+ # Keep /var/lib/xdm. This is where authfiles are stored. See #286350.
+ keepdir /var/lib/xdm
+}