summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-05-03 16:21:31 -0700
committerMatt Turner <mattst88@gentoo.org>2019-05-03 16:23:44 -0700
commit8d1be7f65bc45ddfea7e75a2c645138b787e4179 (patch)
treefcbed0fe56d369490cdb4145761530b943046601 /x11-apps/xdm/xdm-1.1.11-r3.ebuild
parentprofiles: mask make[guile] for riscv (diff)
downloadgentoo-8d1be7f65bc45ddfea7e75a2c645138b787e4179.tar.gz
gentoo-8d1be7f65bc45ddfea7e75a2c645138b787e4179.tar.bz2
gentoo-8d1be7f65bc45ddfea7e75a2c645138b787e4179.zip
x11-apps/xdm: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps/xdm/xdm-1.1.11-r3.ebuild')
-rw-r--r--x11-apps/xdm/xdm-1.1.11-r3.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/x11-apps/xdm/xdm-1.1.11-r3.ebuild b/x11-apps/xdm/xdm-1.1.11-r3.ebuild
deleted file mode 100644
index 7799fbfa3e79..000000000000
--- a/x11-apps/xdm/xdm-1.1.11-r3.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-XORG_EAUTORECONF=yes
-
-inherit multilib xorg-2 pam systemd
-
-DEFAULTVT=vt7
-
-DESCRIPTION="X.Org xdm application"
-
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
-IUSE="consolekit ipv6 pam xdm-auth"
-
-RDEPEND="x11-apps/xrdb
- x11-libs/libXdmcp
- x11-libs/libXaw
- >=x11-apps/xinit-1.0.2-r3
- x11-libs/libXinerama
- x11-libs/libXmu
- x11-libs/libX11
- x11-libs/libXt
- x11-apps/sessreg
- x11-apps/xconsole
- consolekit? ( sys-auth/consolekit )
- pam? ( virtual/pam )
- !<sys-apps/systemd-187"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto
- consolekit? ( !=sys-auth/pambase-20101024-r1 )"
-
-pkg_setup() {
- PATCHES=(
- "${FILESDIR}"/${PN}-consolekit.patch
- "${FILESDIR}"/${P}-cve-2013-2179.patch
- "${FILESDIR}"/${PN}-1.1.11-arc4random-include.patch
- "${FILESDIR}"/${PN}-1.1.11-setproctitle-include.patch
- )
-
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
- $(use_with pam)
- "$(systemd_with_unitdir)"
- --with-default-vt=${DEFAULTVT}
- --with-xdmconfigdir=/etc/X11/xdm
- $(use_with consolekit)
- )
-}
-
-src_prepare() {
- # fedora invented that in -187...
- sed -i -e 's:^Alias=.*$:Alias=display-manager.service:' \
- xdm.service.in || die
-
- # disable XDM-AUTHENTICATION-1 wrt bug #445662.
- # it causes issue with libreoffice and SDL games (bug #306223).
- if use !xdm-auth; then
- sed -i -e '/authorize/a\
-DisplayManager*authName: MIT-MAGIC-COOKIE-1' \
- config/xdm-config.cpp || die
- fi
- xorg-2_src_prepare
-}
-
-src_install() {
- xorg-2_src_install
-
- exeinto /usr/$(get_libdir)/X11/xdm
- doexe "${FILESDIR}"/Xsession
-
- use pam && pamd_mimic system-local-login xdm auth account session
-
- # Keep /var/lib/xdm. This is where authfiles are stored. See #286350.
- keepdir /var/lib/xdm
-}