summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-apps/xman/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-apps/xman/files')
-rw-r--r--x11-apps/xman/files/xman-1.1.3-mandb-2.7.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/x11-apps/xman/files/xman-1.1.3-mandb-2.7.patch b/x11-apps/xman/files/xman-1.1.3-mandb-2.7.patch
new file mode 100644
index 000000000000..f42ce577c2be
--- /dev/null
+++ b/x11-apps/xman/files/xman-1.1.3-mandb-2.7.patch
@@ -0,0 +1,60 @@
+From 438763b6e231410b95b5e352feb65c63cd54de6a Mon Sep 17 00:00:00 2001
+From: Julien Cristau <jcristau@debian.org>
+Date: Fri, 7 Nov 2014 16:19:57 +0000
+Subject: [PATCH] If we have man-db, don't try and emulate man's pipeline
+
+Just let man itself do the formatting / zsoelim / ... dance.
+
+Debian bug#764792 <https://bugs.debian.org/764792>
+
+Signed-off-by: Julien Cristau <jcristau@debian.org>
+---
+ xman/configure.ac | 5 +++++
+ xman/misc.c | 8 ++++++++
+ 2 files changed, 13 insertions(+)
+
+diff --git a/xman/configure.ac b/xman/configure.ac
+index 9a80cbb..8bb44f2 100644
+--- a/xman/configure.ac
++++ b/xman/configure.ac
+@@ -44,6 +44,11 @@ if test "x$GROFF" = "xfound" ; then
+ AC_DEFINE([HAS_GROFF], 1, [Define to 1 if you have the groff package.])
+ fi
+
++AC_CHECK_PROG([MANDB], [mandb], [yes], [no])
++if test x"$MANDB" = xyes; then
++ AC_DEFINE([HAVE_MANDB], 1, [Define if the man implementation is man-db])
++fi
++
+ AC_CHECK_FUNCS([mkstemp])
+
+ AC_ARG_WITH(helpdir,
+diff --git a/xman/misc.c b/xman/misc.c
+index 06891cd..da8744a 100644
+--- a/xman/misc.c
++++ b/xman/misc.c
+@@ -661,6 +661,13 @@ static Boolean
+ ConstructCommand(char *cmdbuf, const char *path,
+ const char *filename, const char *tempfile)
+ {
++#ifdef HAVE_MANDB
++ int used = snprintf(cmdbuf, BUFSIZ, "man -l %s > %s 2>/dev/null",
++ filename, tempfile);
++ if (used >= BUFSIZ - 1)
++ return FALSE;
++ return TRUE;
++#else
+ /* The original code did the following to produce a command line:
+ * sprintf(cmdbuf,"cd %s ; %s %s %s > %s %s", path, TBL,
+ * filename, FORMAT, man_globals->tempfile, "2> /dev/null");
+@@ -783,6 +790,7 @@ ConstructCommand(char *cmdbuf, const char *path,
+ return (FALSE);
+
+ return (TRUE);
++#endif /* man-db */
+ }
+ #endif /* HANDLE_ROFFSEQ */
+
+--
+2.1.1
+