summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-01-10 20:23:58 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-22 16:57:16 -0500
commit0a05dafd1c87c7f9943c77e89763a93d203e441a (patch)
tree97926d0d8659be531748c7a2904353d694a2372d /x11-apps
parentx11-apps/xconsole: EAPI 7 (diff)
downloadgentoo-0a05dafd1c87c7f9943c77e89763a93d203e441a.tar.gz
gentoo-0a05dafd1c87c7f9943c77e89763a93d203e441a.tar.bz2
gentoo-0a05dafd1c87c7f9943c77e89763a93d203e441a.zip
x11-apps/xsm: EAPI 7
Drop the rsh flag to stick with the default behavior of using SSH. When disabled, it would replace the command path with "no". Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xsm/metadata.xml3
-rw-r--r--x11-apps/xsm/xsm-1.0.4.ebuild19
2 files changed, 7 insertions, 15 deletions
diff --git a/x11-apps/xsm/metadata.xml b/x11-apps/xsm/metadata.xml
index e8a1a945c76f..e943b72b8a48 100644
--- a/x11-apps/xsm/metadata.xml
+++ b/x11-apps/xsm/metadata.xml
@@ -5,7 +5,4 @@
<email>x11@gentoo.org</email>
<name>X11</name>
</maintainer>
-<use>
- <flag name="rsh">This allows the use of rsh (remote shell) and rcp (remote copy).</flag>
-</use>
</pkgmetadata>
diff --git a/x11-apps/xsm/xsm-1.0.4.ebuild b/x11-apps/xsm/xsm-1.0.4.ebuild
index ddd4fcc32c10..a29b381dec80 100644
--- a/x11-apps/xsm/xsm-1.0.4.ebuild
+++ b/x11-apps/xsm/xsm-1.0.4.ebuild
@@ -1,32 +1,27 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit xorg-2
+inherit xorg-3
DESCRIPTION="X Session Manager"
+
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="rsh"
+
RDEPEND="x11-libs/libXaw
x11-libs/libX11
x11-libs/libXt
x11-libs/libICE
- x11-libs/libSM
- rsh? ( net-misc/netkit-rsh )"
+ x11-libs/libSM"
DEPEND="${RDEPEND}"
pkg_setup() {
# (#158056) /usr/$(get_libdir)/X11/xsm could be a symlink
- local XSMPATH="${EROOT}usr/$(get_libdir)/X11/xsm"
+ local XSMPATH="${EROOT}/usr/$(get_libdir)/X11/xsm"
if [[ -L ${XSMPATH} ]]; then
einfo "Removing symlink ${XSMPATH}"
rm -f ${XSMPATH} || die "failed to remove symlink ${XSMPATH}"
fi
- xorg-2_pkg_setup
-}
-
-src_configure() {
- XORG_CONFIGURE_OPTIONS="$(use_with rsh rsh /usr/bin/rsh)"
- xorg-2_src_configure
+ xorg-3_pkg_setup
}