summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-04 02:25:30 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-04 02:25:36 +0100
commit1f20db400637e0b9b5c0a147ccfdef132df226b4 (patch)
tree60b1a72a2c6c5029a3147198ef0e16c2533c3cb4 /x11-apps
parentx11-apps/radeon-profile: Removed old (diff)
downloadgentoo-1f20db400637e0b9b5c0a147ccfdef132df226b4.tar.gz
gentoo-1f20db400637e0b9b5c0a147ccfdef132df226b4.tar.bz2
gentoo-1f20db400637e0b9b5c0a147ccfdef132df226b4.zip
x11-apps/radeon-profile: Revbump to fix segfault
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/radeon-profile/files/radeon-profile-20200824-segfault.patch33
-rw-r--r--x11-apps/radeon-profile/radeon-profile-20200824-r1.ebuild65
2 files changed, 98 insertions, 0 deletions
diff --git a/x11-apps/radeon-profile/files/radeon-profile-20200824-segfault.patch b/x11-apps/radeon-profile/files/radeon-profile-20200824-segfault.patch
new file mode 100644
index 000000000000..141dd46d8f79
--- /dev/null
+++ b/x11-apps/radeon-profile/files/radeon-profile-20200824-segfault.patch
@@ -0,0 +1,33 @@
+From a98da7fd620a9b102a74affe16c0c0daccb97fc4 Mon Sep 17 00:00:00 2001
+From: Haakon Drews <fawz@negentropy.io>
+Date: Mon, 4 Jan 2021 02:21:17 +0100
+Subject: [PATCH] Fix segfault when running as regular user
+
+Bug: https://github.com/marazmista/radeon-profile/issues/244
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ radeon-profile/gpu.cpp | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/radeon-profile/gpu.cpp b/radeon-profile/gpu.cpp
+index ccd99d3..f5e32a3 100644
+--- a/radeon-profile/gpu.cpp
++++ b/radeon-profile/gpu.cpp
+@@ -69,7 +69,13 @@ void gpu::detectCards() {
+
+ int pciIdx = ueventContents.indexOf(QRegExp("PCI_SLOT_NAME.+"));
+ if (pciIdx != -1)
+- gsi.name = globalStuff::grabSystemInfo("lspci -s " + ueventContents[pciIdx].split('=')[1])[0].split(':')[2].trimmed();
++ {
++ auto input = globalStuff::grabSystemInfo("lspci -s " + ueventContents[pciIdx].split('=')[1]);
++ if(input.size() < 3)
++ gsi.name = "UNKNOWN";
++ else
++ gsi.name = input[0].split(':')[2].trimmed();
++ }
+
+ gpuList.append(gsi);
+
+--
+2.30.0
+
diff --git a/x11-apps/radeon-profile/radeon-profile-20200824-r1.ebuild b/x11-apps/radeon-profile/radeon-profile-20200824-r1.ebuild
new file mode 100644
index 000000000000..1024baeddcbe
--- /dev/null
+++ b/x11-apps/radeon-profile/radeon-profile-20200824-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Read current clocks of ATi/AMD Radeon cards"
+HOMEPAGE="https://github.com/marazmista/radeon-profile"
+if [[ "${PV}" == 99999999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/marazmista/radeon-profile.git"
+else
+ SRC_URI="https://github.com/marazmista/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+S="${WORKDIR}/${P}/${PN}"
+
+RDEPEND="
+ !<x11-apps/radeon-profile-daemon-20190603-r1
+ dev-qt/qtcharts:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ x11-libs/libX11
+ x11-libs/libXrandr
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-qt/qtconcurrent:5
+ media-libs/mesa[X(+)]
+ x11-libs/libdrm
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20200504-run_subdir.patch"
+ "${FILESDIR}/${PN}-20200824-segfault.patch"
+)
+
+src_prepare() {
+ eapply -p2 "${PATCHES[@]}"
+ eapply_user
+ sed 's@TrayIcon;@@' -i extra/${PN}.desktop || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ elog "In order to run ${PN} as non-root user, the"
+ elog " x11-apps/radeon-profile-daemon"
+ elog "package needs to be installed and the daemon must run."
+}