summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-03-09 21:59:34 -0800
committerMatt Turner <mattst88@gentoo.org>2018-03-09 22:02:35 -0800
commit24bbbc560dd65325ff66bda7b1b6500c98fca683 (patch)
tree63e0b66f0f7264eca75cafa21796a396f2ff39be /x11-apps
parentx11-apps/xsetroot: Version bump to 1.1.2 (diff)
downloadgentoo-24bbbc560dd65325ff66bda7b1b6500c98fca683.tar.gz
gentoo-24bbbc560dd65325ff66bda7b1b6500c98fca683.tar.bz2
gentoo-24bbbc560dd65325ff66bda7b1b6500c98fca683.zip
x11-apps/xsm: Version bump to 1.0.4
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xsm/Manifest1
-rw-r--r--x11-apps/xsm/xsm-1.0.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/x11-apps/xsm/Manifest b/x11-apps/xsm/Manifest
index cb6d08838e7b..c799f05991dc 100644
--- a/x11-apps/xsm/Manifest
+++ b/x11-apps/xsm/Manifest
@@ -1 +1,2 @@
DIST xsm-1.0.3.tar.bz2 161012 BLAKE2B 2628e4234b5fed58ebefb35f454c36e268c75cafa784ed709833d5979ee4484ada8f315d75b6204e64a0efd0f1fd7a14662afb430c0e84bc81a40eefda9380cf SHA512 930a12272011ddd7c60e62b32b485c383292163f8aed6086c756f71cece62d0c316d89a6056751818b3b0ee26f68cca6e0fc914cd58d9b20da0a3b7ccf2145f0
+DIST xsm-1.0.4.tar.bz2 170933 BLAKE2B 05cf4614440f36da6ed1e8e0949ef6955da03d1fe0cc2d0323150b34ea01c293301aa49006a93fe7c44c842db41fb6b66a2f4a4051ddf2258143e54a6e99b390 SHA512 d4e4da7c309a4eae126d2b58a13684f4dbc06b09f76dde9c89c707375df2843614f3d83bc44f9cd02f239200db3397abd86796dca0dbafc69f60482b0af5a176
diff --git a/x11-apps/xsm/xsm-1.0.4.ebuild b/x11-apps/xsm/xsm-1.0.4.ebuild
new file mode 100644
index 000000000000..cc08af1187c3
--- /dev/null
+++ b/x11-apps/xsm/xsm-1.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="X Session Manager"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="rsh"
+RDEPEND="x11-libs/libXaw
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM
+ rsh? ( net-misc/netkit-rsh )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ # (#158056) /usr/$(get_libdir)/X11/xsm could be a symlink
+ local XSMPATH="${EROOT}usr/$(get_libdir)/X11/xsm"
+ if [[ -L ${XSMPATH} ]]; then
+ einfo "Removing symlink ${XSMPATH}"
+ rm -f ${XSMPATH} || die "failed to remove symlink ${XSMPATH}"
+ fi
+ xorg-2_pkg_setup
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS="$(use_with rsh rsh /usr/bin/rsh)"
+ xorg-2_src_configure
+}