summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-08-03 11:33:38 -0700
committerMatt Turner <mattst88@gentoo.org>2021-08-03 12:16:46 -0700
commit269a8d023aa22eab0351c9114e3cceeea717946e (patch)
tree873310c6e4bfb56c9825a6f8198fff1244126dc5 /x11-apps
parentsys-libs/libcxx: Extend checkout to fix building 13+ (diff)
downloadgentoo-269a8d023aa22eab0351c9114e3cceeea717946e.tar.gz
gentoo-269a8d023aa22eab0351c9114e3cceeea717946e.tar.bz2
gentoo-269a8d023aa22eab0351c9114e3cceeea717946e.zip
x11-apps/xrestop: Rename from x11-misc/xrestop
I'm not sure what the history is, but this package's upstream is now on the FreeDesktop Gitlab. The 0.4 ebuild has a SRC_URI that no longer resolves, and there isn't a 0.4 tarball on freedesktop.org. Anyway, a version 0.5 has been released from FreeDesktop, so we'll switch to that and change the maintainer to x11@ at the same time. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xrestop/Manifest1
-rw-r--r--x11-apps/xrestop/files/xrestop-0.4-tinfo.patch10
-rw-r--r--x11-apps/xrestop/metadata.xml8
-rw-r--r--x11-apps/xrestop/xrestop-0.4.ebuild37
4 files changed, 56 insertions, 0 deletions
diff --git a/x11-apps/xrestop/Manifest b/x11-apps/xrestop/Manifest
new file mode 100644
index 000000000000..2c9ad1225da8
--- /dev/null
+++ b/x11-apps/xrestop/Manifest
@@ -0,0 +1 @@
+DIST xrestop-0.4.tar.gz 92308 BLAKE2B 5bfe6e9ccd49038e7884be8379e79f3de2bc960588dc21fbbe40d2acb89c6505efd78a9415e0ba8feb24986f11f066ce641b9c933f241776bbc1b3e59fd520f0 SHA512 eb7bf2f3ab7b73708c96d56fd466cb362d711242dd46992fa3e693af2d26995e9baa91075eb445ef227e1342deec5e0e22b37139e80399e4051c9f5cad8fd9b6
diff --git a/x11-apps/xrestop/files/xrestop-0.4-tinfo.patch b/x11-apps/xrestop/files/xrestop-0.4-tinfo.patch
new file mode 100644
index 000000000000..ef2de121e839
--- /dev/null
+++ b/x11-apps/xrestop/files/xrestop-0.4-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -65,6 +65,7 @@
+
+ # check for ncurses, fall back to curses
+ AC_CHECK_LIB([ncurses], [initscr],,AC_CHECK_LIB([curses], [initscr]))
++AC_SEARCH_LIBS([stdscr], [tinfo])
+
+ if test "x$GCC" = "xyes"; then
+ GCC_WARNINGS="-Wall -fno-strict-aliasing"
diff --git a/x11-apps/xrestop/metadata.xml b/x11-apps/xrestop/metadata.xml
new file mode 100644
index 000000000000..e943b72b8a48
--- /dev/null
+++ b/x11-apps/xrestop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-apps/xrestop/xrestop-0.4.ebuild b/x11-apps/xrestop/xrestop-0.4.ebuild
new file mode 100644
index 000000000000..42d0def453a2
--- /dev/null
+++ b/x11-apps/xrestop/xrestop-0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="'Top' like statistics of X11 client's server side resource usage"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/xrestop"
+SRC_URI="http://projects.o-hand.com/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ppc ~ppc64 sparc x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXres
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}