summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-11-29 14:12:32 -0800
committerMatt Turner <mattst88@gentoo.org>2021-11-29 14:14:17 -0800
commit2acb137954d957911d53633d7d8a8e166b3d79d1 (patch)
tree7b5be0991f490078af9b95e1276e9f9c30ac39a2 /x11-apps
parentsys-kernel/gentoo-kernel: add big-endian config part for 5.10.82 (diff)
downloadgentoo-2acb137954d957911d53633d7d8a8e166b3d79d1.tar.gz
gentoo-2acb137954d957911d53633d7d8a8e166b3d79d1.tar.bz2
gentoo-2acb137954d957911d53633d7d8a8e166b3d79d1.zip
x11-apps/xauth: Version bump to 1.1.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xauth/Manifest1
-rw-r--r--x11-apps/xauth/xauth-1.1.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-apps/xauth/Manifest b/x11-apps/xauth/Manifest
index 60ccd1526952..97ffb3f1ffda 100644
--- a/x11-apps/xauth/Manifest
+++ b/x11-apps/xauth/Manifest
@@ -1 +1,2 @@
+DIST xauth-1.1.1.tar.bz2 167315 BLAKE2B fbe36f867031c734e3a8ae9719145caa16828d4df156503c299812fb63f86462561ffea945f12fabc5e036cc63664ee1d8b5b37630dee8d4af6f2473aa5fcd1a SHA512 998c3158378fff50d368959c29335173b8d98e02591cb3d7b2f9534b5a44b19deb4cb7da9bf291ca5a37f69f833d72839b2c6611723306d10c1b4968ae4d4120
DIST xauth-1.1.tar.bz2 163510 BLAKE2B 0b55ee9ec35ca436c36effe2ba4eee55f76a311a5482d1d72e80e5afea30c682de3f686b2956d17278721e190dd9bec4d93db6507853841a633c931312df745d SHA512 b6ecd59a853a491ef45bf8cfbff63bed36645f81cb79ae9d18458b57f7502bccf92f0d979d3337578518646f680ad379e67b1dac15a927cbb11372733e7a3a0c
diff --git a/x11-apps/xauth/xauth-1.1.1.ebuild b/x11-apps/xauth/xauth-1.1.1.ebuild
new file mode 100644
index 000000000000..3805e3986bdf
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xorg-3
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="X authority file utility"
+IUSE="ipv6"
+RESTRICT="test" # Depends on dead cmdtest package
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ )
+ xorg-3_src_configure
+}