summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-07-15 11:51:13 -0400
committerMatt Turner <mattst88@gentoo.org>2023-07-15 12:01:27 -0400
commit7d955e7833932970414565bf3da651685d3f038a (patch)
tree81f94eab6d188d0365ff86c32b160d4ff754947a /x11-apps
parentdev-python/setuptools: Move wheel to RDEP in 67.8.0 too (diff)
downloadgentoo-7d955e7833932970414565bf3da651685d3f038a.tar.gz
gentoo-7d955e7833932970414565bf3da651685d3f038a.tar.bz2
gentoo-7d955e7833932970414565bf3da651685d3f038a.zip
x11-apps/xeyes: Version bump to 1.3.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xeyes/Manifest1
-rw-r--r--x11-apps/xeyes/xeyes-1.3.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-apps/xeyes/Manifest b/x11-apps/xeyes/Manifest
index 2cf0a58a5603..b7dad3383938 100644
--- a/x11-apps/xeyes/Manifest
+++ b/x11-apps/xeyes/Manifest
@@ -1 +1,2 @@
DIST xeyes-1.2.0.tar.bz2 139218 BLAKE2B 0869cff711a58e937ebaf0ca5095654657f0782e7acac3553ef48469cd780c0fd1707df3aa60ed047cae44009b524cbb86eea1836c08fbbc4a1cc31fb99cbda7 SHA512 2d1614614b3ba3d1ebaa0e9801a2e159389b94aaacafb962d326b7e6dc712c1eb2c12a50ceb10b3135cf0eee6ae86bbf84e73098deb08e73792f14a60616b4d8
+DIST xeyes-1.3.0.tar.xz 130444 BLAKE2B 17e73743765b7bdb8e26c8ac7babb91ee1c72c6ecf8bdaaf112d192f6db34ab926d6699ccd7b9a1bbe1ca98dcab0ea61a3eaeec10b8ce5b67bcbe40b19842208 SHA512 6108a476cd0807ce2a522d905894817f7f14f653f928c218c96c078f0822d9abef5fb941d3e7163a1cadaa7d74f1bd09bbf60345a7ac0fe906667af5a0490906
diff --git a/x11-apps/xeyes/xeyes-1.3.0.ebuild b/x11-apps/xeyes/xeyes-1.3.0.ebuild
new file mode 100644
index 000000000000..b5a953d35c2b
--- /dev/null
+++ b/x11-apps/xeyes/xeyes-1.3.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org xeyes application"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=x11-libs/libXi-1.7
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libxcb"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+XORG_CONFIGURE_OPTIONS=( --with-xrender --with-present )