summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-26 15:48:13 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-26 17:21:35 +0200
commite4d117192dda3135b1260f7d48257b00a724b414 (patch)
tree4bb657aaba1aee7cb69b3d168275c8df09d62243 /x11-apps
parentprofiles/package.mask: mask =x11-base/xorg-server-1.20.9. (diff)
downloadgentoo-e4d117192dda3135b1260f7d48257b00a724b414.tar.gz
gentoo-e4d117192dda3135b1260f7d48257b00a724b414.tar.bz2
gentoo-e4d117192dda3135b1260f7d48257b00a724b414.zip
x11-apps/radeon-profile: bump to v20200824
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/radeon-profile/Manifest1
-rw-r--r--x11-apps/radeon-profile/radeon-profile-20200824.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-apps/radeon-profile/Manifest b/x11-apps/radeon-profile/Manifest
index a328f14c44c1..99d2ded170cb 100644
--- a/x11-apps/radeon-profile/Manifest
+++ b/x11-apps/radeon-profile/Manifest
@@ -1 +1,2 @@
DIST radeon-profile-20200504.tar.gz 395674 BLAKE2B 6435dfcf9d2ce25789f429f12071cdb1c3f85050654b7fdec45c51a59d562d60369b28cfcd2854dfd5841e4af8f9166afed266e0a48d9010619972b653e0d4a8 SHA512 73f7eb59369af57aba5f067202fb1f772e48260c42ad194876926c29d278022daa86235f8d591bc763b8c6d80682553fe9a55f848137a8ec1de1bf9531c162c6
+DIST radeon-profile-20200824.tar.gz 395416 BLAKE2B 0f1b9ac59c1e5da97cc0446d32f1fab6435d9049a5dc362d5896849e580382ede745e1759aef3ba659dec0f8f2ae12bb68f0f65313d24f9e3f4cdfa6f7d4887e SHA512 e3e9cf9aa46f81772406f7dc18a3768777b9f2ccdcda18094862183b31857099bf22e2a8b548ade5dedd04a38c8eab7a31127db3b7726adc901c7123a47f81de
diff --git a/x11-apps/radeon-profile/radeon-profile-20200824.ebuild b/x11-apps/radeon-profile/radeon-profile-20200824.ebuild
new file mode 100644
index 000000000000..d836b3ad1f83
--- /dev/null
+++ b/x11-apps/radeon-profile/radeon-profile-20200824.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Read current clocks of ATi/AMD Radeon cards"
+HOMEPAGE="https://github.com/marazmista/radeon-profile"
+if [[ "${PV}" == 99999999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/marazmista/radeon-profile.git"
+else
+ SRC_URI="https://github.com/marazmista/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+S="${WORKDIR}/${P}/${PN}"
+
+RDEPEND="
+ !<x11-apps/radeon-profile-daemon-20190603-r1
+ dev-qt/qtcharts:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ x11-libs/libX11
+ x11-libs/libXrandr
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-qt/qtconcurrent:5
+ media-libs/mesa[X(+)]
+ x11-libs/libdrm
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20200504-run_subdir.patch"
+)
+
+src_prepare() {
+ eapply -p2 "${PATCHES[@]}"
+ eapply_user
+ sed 's@TrayIcon;@@' -i extra/${PN}.desktop || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ elog "In order to run ${PN} as non-root user, the"
+ elog " x11-apps/radeon-profile-daemon"
+ elog "package needs to be installed and the daemon must run."
+}