summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-03-10 23:19:05 -0700
committerMatt Turner <mattst88@gentoo.org>2019-03-10 23:21:06 -0700
commitfe2828046e6cc5fc7cc425cbd4e43adae8e3281a (patch)
tree12a9f2504719c90ffe34f4b6631e4c93ecf2f9b4 /x11-apps
parentmedia-gfx/exiv2: remove vulnerable 0.26_p20180811-r3 (diff)
downloadgentoo-fe2828046e6cc5fc7cc425cbd4e43adae8e3281a.tar.gz
gentoo-fe2828046e6cc5fc7cc425cbd4e43adae8e3281a.tar.bz2
gentoo-fe2828046e6cc5fc7cc425cbd4e43adae8e3281a.zip
x11-apps/mkfontscale: Add patch from upstream
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/mkfontscale/files/mkfontscale-1.2.0-Revert-Use-autoconf-instead-of-sed-to-substitute-bin.patch51
-rw-r--r--x11-apps/mkfontscale/mkfontscale-1.2.0-r1.ebuild (renamed from x11-apps/mkfontscale/mkfontscale-1.2.0.ebuild)8
2 files changed, 57 insertions, 2 deletions
diff --git a/x11-apps/mkfontscale/files/mkfontscale-1.2.0-Revert-Use-autoconf-instead-of-sed-to-substitute-bin.patch b/x11-apps/mkfontscale/files/mkfontscale-1.2.0-Revert-Use-autoconf-instead-of-sed-to-substitute-bin.patch
new file mode 100644
index 000000000000..fdeea14e31dc
--- /dev/null
+++ b/x11-apps/mkfontscale/files/mkfontscale-1.2.0-Revert-Use-autoconf-instead-of-sed-to-substitute-bin.patch
@@ -0,0 +1,51 @@
+From 29cab25240cf30f546671f265167a2eeadfd4c75 Mon Sep 17 00:00:00 2001
+From: Alan Coopersmith <alan.coopersmith@oracle.com>
+Date: Thu, 7 Mar 2019 13:23:00 -0800
+Subject: [PATCH app/mkfontscale] Revert "Use autoconf instead of sed to
+ substitute @bindir@ in mkfontdir.in"
+
+This reverts commit 1f9d14bec07092d62da29a5a233cefbf84d47289.
+It caused https://gitlab.freedesktop.org/xorg/app/mkfontscale/issues/5
+---
+ Makefile.am | 9 ++++++++-
+ configure.ac | 1 -
+ 2 files changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 7bb11ea..c36d171 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -23,6 +23,13 @@ SUBDIRS = man
+ bin_PROGRAMS = mkfontscale
+ bin_SCRIPTS = mkfontdir
+
++CLEANFILES = $(bin_SCRIPTS)
++EXTRA_DIST = $(bin_SCRIPTS:=.in)
++DIR_SUBSTS = -e 's|@bindir[@]|$(bindir)|g'
++
++mkfontdir: mkfontdir.in
++ $(AM_V_GEN)$(SED) $(DIR_SUBSTS) < $(srcdir)/mkfontdir.in > $@
++
+ AM_CPPFLAGS = @MKFONTSCALE_CFLAGS@ @X11_CFLAGS@ -D_BSD_SOURCE
+ AM_CFLAGS = $(CWARNFLAGS)
+ mkfontscale_LDADD = @MKFONTSCALE_LIBS@
+@@ -59,4 +66,4 @@ lint:
+ $(LINT) $(ALL_LINT_FLAGS) $(mkfontscale_SOURCES)
+ endif LINT
+
+-EXTRA_DIST = README.md
++EXTRA_DIST += README.md
+diff --git a/configure.ac b/configure.ac
+index 5f5e463..7363bba 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -63,6 +63,5 @@ XORG_WITH_LINT
+
+ AC_CONFIG_FILES([
+ Makefile
+- mkfontdir
+ man/Makefile])
+ AC_OUTPUT
+--
+2.19.2
+
diff --git a/x11-apps/mkfontscale/mkfontscale-1.2.0.ebuild b/x11-apps/mkfontscale/mkfontscale-1.2.0-r1.ebuild
index c0f737d6f423..3228a01ba4ee 100644
--- a/x11-apps/mkfontscale/mkfontscale-1.2.0.ebuild
+++ b/x11-apps/mkfontscale/mkfontscale-1.2.0-r1.ebuild
@@ -15,11 +15,15 @@ COMMON_DEPEND="
media-libs/freetype:2
sys-libs/zlib
app-arch/bzip2"
-DEPEND="x11-base/xorg-proto"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto"
RDEPEND="${COMMON_DEPEND}
- ${DEPEND}
!<x11-apps/mkfontdir-1.2.0"
+PATCHES=(
+ "${FILESDIR}"/${P}-Revert-Use-autoconf-instead-of-sed-to-substitute-bin.patch
+)
+
XORG_CONFIGURE_OPTIONS=(
--with-bzip2
)