summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-10-09 19:46:49 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-09 22:34:07 -0400
commitcaddee5cb2550393651e0bcb962f4d4671ab09b0 (patch)
tree08af9e0edc2ee44adafc38e5c4ea64c245d6e942 /x11-base/xorg-server
parentvirtual/opencl: Drop old versions (diff)
downloadgentoo-caddee5cb2550393651e0bcb962f4d4671ab09b0.tar.gz
gentoo-caddee5cb2550393651e0bcb962f4d4671ab09b0.tar.bz2
gentoo-caddee5cb2550393651e0bcb962f4d4671ab09b0.zip
x11-base/xorg-server: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base/xorg-server')
-rw-r--r--x11-base/xorg-server/Manifest1
-rw-r--r--x11-base/xorg-server/files/xorg-server-21.1.3-gcc12.patch84
-rw-r--r--x11-base/xorg-server/files/xorg-server-21.1.3-present-null-check.patch36
-rw-r--r--x11-base/xorg-server/xorg-server-21.1.3-r2.ebuild189
-rw-r--r--x11-base/xorg-server/xorg-server-21.1.3-r3.ebuild190
5 files changed, 0 insertions, 500 deletions
diff --git a/x11-base/xorg-server/Manifest b/x11-base/xorg-server/Manifest
index 02f162f18bb8..253c3b834577 100644
--- a/x11-base/xorg-server/Manifest
+++ b/x11-base/xorg-server/Manifest
@@ -1,2 +1 @@
-DIST xorg-server-21.1.3.tar.xz 4955948 BLAKE2B 1907007e4131378ead2b8757e84e8e9403148c9b3cdffc68d7c54faf5ab0efa6b594b635940fce8af4b8334e4a1c67984f59fc2f3642e48b54eb2f2dcc7fd8f5 SHA512 cf5fed023eadda62ae732f8c4d427c272ebe005188341290f3d03147042c103b00cbb94d86a0256da815fb9b9a3da315c21a05ee0c926c1a2ff0c54ab0c0638b
DIST xorg-server-21.1.4.tar.xz 4940176 BLAKE2B 8f68c7de102f7f8d0f56566a518025bb32c079184d5a5556dc8e651111b6a018669102b18ec2e9470d3ab91f51291618f9c49281915d885fc30446e1b54d2134 SHA512 eb5b8520d02908f72719e6ecfbf7a9bf139acb65ccae04d1db4223a8a2384cd3a94bd5afef10cce327b751b800cc2b79bfaa5ae35c95c3a217f775168082e68f
diff --git a/x11-base/xorg-server/files/xorg-server-21.1.3-gcc12.patch b/x11-base/xorg-server/files/xorg-server-21.1.3-gcc12.patch
deleted file mode 100644
index d34809e0a776..000000000000
--- a/x11-base/xorg-server/files/xorg-server-21.1.3-gcc12.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-https://gitlab.freedesktop.org/xorg/xserver/-/commit/c6b0dcb82d4db07a2f32c09a8c09c85a5f57248e
-https://bugs.gentoo.org/839822
-
-From c6b0dcb82d4db07a2f32c09a8c09c85a5f57248e Mon Sep 17 00:00:00 2001
-From: Olivier Fourdan <ofourdan@redhat.com>
-Date: Thu, 20 Jan 2022 10:20:38 +0100
-Subject: [PATCH] render: Fix build with gcc 12
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-The xserver fails to compile with the latest gcc 12:
-
- render/picture.c: In function ‘CreateSolidPicture’:
- render/picture.c:874:26: error: array subscript ‘union _SourcePict[0]’ is partly outside array bounds of ‘unsigned char[16]’ [-Werror=array-bounds]
- 874 | pPicture->pSourcePict->type = SourcePictTypeSolidFill;
- | ^~
- render/picture.c:868:45: note: object of size 16 allocated by ‘malloc’
- 868 | pPicture->pSourcePict = (SourcePictPtr) malloc(sizeof(PictSolidFill));
- | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
- render/picture.c: In function ‘CreateLinearGradientPicture’:
- render/picture.c:906:26: error: array subscript ‘union _SourcePict[0]’ is partly outside array bounds of ‘unsigned char[32]’ [-Werror=array-bounds]
- 906 | pPicture->pSourcePict->linear.type = SourcePictTypeLinear;
- | ^~
- render/picture.c:899:45: note: object of size 32 allocated by ‘malloc’
- 899 | pPicture->pSourcePict = (SourcePictPtr) malloc(sizeof(PictLinearGradient));
- | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
- render/picture.c: In function ‘CreateConicalGradientPicture’:
- render/picture.c:989:26: error: array subscript ‘union _SourcePict[0]’ is partly outside array bounds of ‘unsigned char[32]’ [-Werror=array-bounds]
- 989 | pPicture->pSourcePict->conical.type = SourcePictTypeConical;
- | ^~
- render/picture.c:982:45: note: object of size 32 allocated by ‘malloc’
- 982 | pPicture->pSourcePict = (SourcePictPtr) malloc(sizeof(PictConicalGradient));
- | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
- cc1: some warnings being treated as errors
- ninja: build stopped: subcommand failed.
-
-This is because gcc 12 has become stricter and raises a warning now.
-
-Fix the warning/error by allocating enough memory to store the union
-struct.
-
-Signed-off-by: Olivier Fourdan <ofourdan@redhat.com>
-Acked-by: Michel Dänzer <mdaenzer@redhat.com>
-Closes: https://gitlab.freedesktop.org/xorg/xserver/-/issues/1256
---- a/render/picture.c
-+++ b/render/picture.c
-@@ -865,7 +865,7 @@ CreateSolidPicture(Picture pid, xRenderColor * color, int *error)
- }
-
- pPicture->id = pid;
-- pPicture->pSourcePict = (SourcePictPtr) malloc(sizeof(PictSolidFill));
-+ pPicture->pSourcePict = (SourcePictPtr) malloc(sizeof(SourcePict));
- if (!pPicture->pSourcePict) {
- *error = BadAlloc;
- free(pPicture);
-@@ -896,7 +896,7 @@ CreateLinearGradientPicture(Picture pid, xPointFixed * p1, xPointFixed * p2,
- }
-
- pPicture->id = pid;
-- pPicture->pSourcePict = (SourcePictPtr) malloc(sizeof(PictLinearGradient));
-+ pPicture->pSourcePict = (SourcePictPtr) malloc(sizeof(SourcePict));
- if (!pPicture->pSourcePict) {
- *error = BadAlloc;
- free(pPicture);
-@@ -936,7 +936,7 @@ CreateRadialGradientPicture(Picture pid, xPointFixed * inner,
- }
-
- pPicture->id = pid;
-- pPicture->pSourcePict = (SourcePictPtr) malloc(sizeof(PictRadialGradient));
-+ pPicture->pSourcePict = (SourcePictPtr) malloc(sizeof(SourcePict));
- if (!pPicture->pSourcePict) {
- *error = BadAlloc;
- free(pPicture);
-@@ -979,7 +979,7 @@ CreateConicalGradientPicture(Picture pid, xPointFixed * center, xFixed angle,
- }
-
- pPicture->id = pid;
-- pPicture->pSourcePict = (SourcePictPtr) malloc(sizeof(PictConicalGradient));
-+ pPicture->pSourcePict = (SourcePictPtr) malloc(sizeof(SourcePict));
- if (!pPicture->pSourcePict) {
- *error = BadAlloc;
- free(pPicture);
-GitLab
diff --git a/x11-base/xorg-server/files/xorg-server-21.1.3-present-null-check.patch b/x11-base/xorg-server/files/xorg-server-21.1.3-present-null-check.patch
deleted file mode 100644
index 15d653320708..000000000000
--- a/x11-base/xorg-server/files/xorg-server-21.1.3-present-null-check.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-https://gitlab.freedesktop.org/xorg/xserver/-/commit/22d58188
-https://bugs.gentoo.org/830482
-
-From: =?UTF-8?q?B=C5=82a=C5=BCej=20Szczygie=C5=82?= <spaz16@wp.pl>
-Date: Thu, 13 Jan 2022 00:47:27 +0100
-Subject: [PATCH] present: Check for NULL to prevent crash
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Closes: https://gitlab.freedesktop.org/xorg/xserver/-/issues/1275
-Signed-off-by: Błażej Szczygieł <spaz16@wp.pl>
-Tested-by: Aaron Plattner <aplattner@nvidia.com>
---- a/present/present_scmd.c
-+++ b/present/present_scmd.c
-@@ -158,6 +158,9 @@ present_scmd_get_crtc(present_screen_priv_ptr screen_priv, WindowPtr window)
- if (!screen_priv->info)
- return NULL;
-
-+ if (!screen_priv->info->get_crtc)
-+ return NULL;
-+
- return (*screen_priv->info->get_crtc)(window);
- }
-
-@@ -196,6 +199,9 @@ present_flush(WindowPtr window)
- if (!screen_priv->info)
- return;
-
-+ if (!screen_priv->info->flush)
-+ return;
-+
- (*screen_priv->info->flush) (window);
- }
-
-GitLab
diff --git a/x11-base/xorg-server/xorg-server-21.1.3-r2.ebuild b/x11-base/xorg-server/xorg-server-21.1.3-r2.ebuild
deleted file mode 100644
index 774aa6cf5f64..000000000000
--- a/x11-base/xorg-server/xorg-server-21.1.3-r2.ebuild
+++ /dev/null
@@ -1,189 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-XORG_TARBALL_SUFFIX="xz"
-XORG_EAUTORECONF="no"
-inherit xorg-3 meson
-EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
-
-DESCRIPTION="X.Org X servers"
-SLOT="0/${PV}"
-if [[ ${PV} != 9999* ]]; then
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-IUSE_SERVERS="xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} debug +elogind minimal selinux suid systemd test +udev unwind xcsecurity"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- media-libs/libglvnd[X]
- dev-libs/libbsd
- dev-libs/openssl:0=
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libdrm-2.4.89
- >=x11-libs/libpciaccess-0.12.901
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont2-2.0.1
- >=x11-libs/libxcvt-0.1.0
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/libxshmfence-1.1
- >=x11-libs/pixman-0.27.2
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-2.4.1-r3
- >=x11-libs/libXext-1.0.5
- x11-libs/libXv
- xephyr? (
- x11-libs/libxcb[xkb]
- x11-libs/xcb-util
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
- !minimal? (
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXext-1.0.5
- >=media-libs/mesa-18[X(+),egl(+),gbm(+)]
- >=media-libs/libepoxy-1.5.4[X,egl(+)]
- )
- udev? ( virtual/libudev:= )
- unwind? ( sys-libs/libunwind:= )
- selinux? (
- sys-process/audit
- sys-libs/libselinux:=
- )
- systemd? (
- sys-apps/dbus
- sys-apps/systemd
- )
- elogind? (
- sys-apps/dbus
- sys-auth/elogind[pam]
- sys-auth/pambase[elogind]
- )
- !!x11-drivers/nvidia-drivers[-libglvnd(+)]
-"
-DEPEND="${CDEPEND}
- >=x11-base/xorg-proto-2021.4.99.2
- >=x11-libs/xtrans-1.3.5
- media-fonts/font-util
-"
-RDEPEND="${CDEPEND}
- !systemd? ( gui-libs/display-manager-init )
- selinux? ( sec-policy/selinux-xserver )
- xorg? ( >=x11-apps/xinit-1.3.3-r1 )
-"
-BDEPEND="
- sys-devel/flex
-"
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(ver_cut 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )
- elogind? ( udev )
- ?? ( elogind systemd )"
-
-UPSTREAMED_PATCHES=(
- "${FILESDIR}"/${P}-gcc12.patch
-)
-
-PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
- # needed for new eselect-opengl, bug #541232
- "${FILESDIR}"/${PN}-1.18-support-multiple-Files-sections.patch
-)
-
-src_configure() {
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
-
- local emesonargs=(
- --localstatedir "${EPREFIX}/var"
- --sysconfdir "${EPREFIX}/etc/X11"
- --buildtype $(usex debug debug plain)
- -Db_ndebug=$(usex debug false true)
- $(meson_use !minimal dri1)
- $(meson_use !minimal dri2)
- $(meson_use !minimal dri3)
- $(meson_use !minimal glamor)
- $(meson_use !minimal glx)
- $(meson_use udev)
- $(meson_use udev udev_kms)
- $(meson_use unwind libunwind)
- $(meson_use xcsecurity)
- $(meson_use selinux xselinux)
- $(meson_use xephyr)
- $(meson_use xnest)
- $(meson_use xorg)
- $(meson_use xvfb)
- -Ddocs=false
- -Ddrm=true
- -Ddtrace=false
- -Dipv6=true
- -Dhal=false
- -Dlinux_acpi=false
- -Dlinux_apm=false
- -Dsecure-rpc=false
- -Dsha1=libcrypto
- -Dxkb_output_dir="${EPREFIX}/var/lib/xkb"
- )
-
- if [[ ${PV} == 9999 ]] ; then
- # Gone in 21.1.x, but not in master.
- emesonargs+=( -Dxwayland=false )
- fi
-
- if use systemd || use elogind; then
- emesonargs+=(
- -Dsystemd_logind=true
- $(meson_use suid suid_wrapper)
- )
- else
- emesonargs+=(
- -Dsystemd_logind=false
- -Dsuid_wrapper=false
- )
- fi
-
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
-
- # The meson build system does not support install-setuid
- if ! use systemd && ! use elogind; then
- if use suid; then
- chmod u+s "${ED}"/usr/bin/Xorg
- fi
- fi
-
- if ! use xorg; then
- rm -f "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x || die
- fi
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}
diff --git a/x11-base/xorg-server/xorg-server-21.1.3-r3.ebuild b/x11-base/xorg-server/xorg-server-21.1.3-r3.ebuild
deleted file mode 100644
index 7e002dc7081c..000000000000
--- a/x11-base/xorg-server/xorg-server-21.1.3-r3.ebuild
+++ /dev/null
@@ -1,190 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-XORG_TARBALL_SUFFIX="xz"
-XORG_EAUTORECONF="no"
-inherit xorg-3 meson
-EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
-
-DESCRIPTION="X.Org X servers"
-SLOT="0/${PV}"
-if [[ ${PV} != 9999* ]]; then
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-IUSE_SERVERS="xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} debug +elogind minimal selinux suid systemd test +udev unwind xcsecurity"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- media-libs/libglvnd[X]
- dev-libs/libbsd
- dev-libs/openssl:0=
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libdrm-2.4.89
- >=x11-libs/libpciaccess-0.12.901
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont2-2.0.1
- >=x11-libs/libxcvt-0.1.0
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/libxshmfence-1.1
- >=x11-libs/pixman-0.27.2
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-2.4.1-r3
- >=x11-libs/libXext-1.0.5
- x11-libs/libXv
- xephyr? (
- x11-libs/libxcb[xkb]
- x11-libs/xcb-util
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
- !minimal? (
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXext-1.0.5
- >=media-libs/mesa-18[X(+),egl(+),gbm(+)]
- >=media-libs/libepoxy-1.5.4[X,egl(+)]
- )
- udev? ( virtual/libudev:= )
- unwind? ( sys-libs/libunwind:= )
- selinux? (
- sys-process/audit
- sys-libs/libselinux:=
- )
- systemd? (
- sys-apps/dbus
- sys-apps/systemd
- )
- elogind? (
- sys-apps/dbus
- sys-auth/elogind[pam]
- sys-auth/pambase[elogind]
- )
- !!x11-drivers/nvidia-drivers[-libglvnd(+)]
-"
-DEPEND="${CDEPEND}
- >=x11-base/xorg-proto-2021.4.99.2
- >=x11-libs/xtrans-1.3.5
- media-fonts/font-util
-"
-RDEPEND="${CDEPEND}
- !systemd? ( gui-libs/display-manager-init )
- selinux? ( sec-policy/selinux-xserver )
- xorg? ( >=x11-apps/xinit-1.3.3-r1 )
-"
-BDEPEND="
- sys-devel/flex
-"
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(ver_cut 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )
- elogind? ( udev )
- ?? ( elogind systemd )"
-
-UPSTREAMED_PATCHES=(
- "${FILESDIR}"/${P}-gcc12.patch
- "${FILESDIR}"/${P}-present-null-check.patch
-)
-
-PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
- # needed for new eselect-opengl, bug #541232
- "${FILESDIR}"/${PN}-1.18-support-multiple-Files-sections.patch
-)
-
-src_configure() {
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
-
- local emesonargs=(
- --localstatedir "${EPREFIX}/var"
- --sysconfdir "${EPREFIX}/etc/X11"
- --buildtype $(usex debug debug plain)
- -Db_ndebug=$(usex debug false true)
- $(meson_use !minimal dri1)
- $(meson_use !minimal dri2)
- $(meson_use !minimal dri3)
- $(meson_use !minimal glamor)
- $(meson_use !minimal glx)
- $(meson_use udev)
- $(meson_use udev udev_kms)
- $(meson_use unwind libunwind)
- $(meson_use xcsecurity)
- $(meson_use selinux xselinux)
- $(meson_use xephyr)
- $(meson_use xnest)
- $(meson_use xorg)
- $(meson_use xvfb)
- -Ddocs=false
- -Ddrm=true
- -Ddtrace=false
- -Dipv6=true
- -Dhal=false
- -Dlinux_acpi=false
- -Dlinux_apm=false
- -Dsecure-rpc=false
- -Dsha1=libcrypto
- -Dxkb_output_dir="${EPREFIX}/var/lib/xkb"
- )
-
- if [[ ${PV} == 9999 ]] ; then
- # Gone in 21.1.x, but not in master.
- emesonargs+=( -Dxwayland=false )
- fi
-
- if use systemd || use elogind; then
- emesonargs+=(
- -Dsystemd_logind=true
- $(meson_use suid suid_wrapper)
- )
- else
- emesonargs+=(
- -Dsystemd_logind=false
- -Dsuid_wrapper=false
- )
- fi
-
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
-
- # The meson build system does not support install-setuid
- if ! use systemd && ! use elogind; then
- if use suid; then
- chmod u+s "${ED}"/usr/bin/Xorg
- fi
- fi
-
- if ! use xorg; then
- rm -f "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x || die
- fi
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}