summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-15 18:26:01 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-15 21:37:23 -0500
commit25f28d4c27bb6d0c290e8280758a0b679fafcfcc (patch)
tree713e10d7022817f89b52da73034525af88dd7a8b /x11-base
parentx11-base/xorg-server: Make xinit dependency optional (diff)
downloadgentoo-25f28d4c27bb6d0c290e8280758a0b679fafcfcc.tar.gz
gentoo-25f28d4c27bb6d0c290e8280758a0b679fafcfcc.tar.bz2
gentoo-25f28d4c27bb6d0c290e8280758a0b679fafcfcc.zip
x11-base/xorg-server: Version bump to 1.20.14
Bug: https://bugs.gentoo.org/829208 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-server/Manifest1
-rw-r--r--x11-base/xorg-server/xorg-server-1.20.14.ebuild209
2 files changed, 210 insertions, 0 deletions
diff --git a/x11-base/xorg-server/Manifest b/x11-base/xorg-server/Manifest
index 86960fe2445a..67586e999e7f 100644
--- a/x11-base/xorg-server/Manifest
+++ b/x11-base/xorg-server/Manifest
@@ -1,2 +1,3 @@
DIST xorg-server-1.20.13.tar.xz 5122260 BLAKE2B 4435d25d8b379142fcc4bf60d82e52417ac3ab22a77ededa1472785d67c23bfb95be8e10465fc4859645405b8e580d6dcb262caea39c408e724d0e5ea61b37af SHA512 4e0b7bd4e070dc52cb2c51c2056feb133de2c0487d359392ed63abba9702910cd2e2983e9415973d8d6e9672eac78be6f39202687fc56610877914ce722554b3
+DIST xorg-server-1.20.14.tar.xz 5178288 BLAKE2B e60cbb6f3023639598d518fb53e3df3a2aced8f8950279f3a1642ad0a9545bea756574c4d41383cba966dc76c317859065b2290c8420668547f26f1d6e508da3 SHA512 be3dc32cce7d55d7e38c5f6557027f13f39224c76cc83e5800555d5ce89dbdc3731773a2d186a5b97db9fc8731a2b2dd6e9829af2b01ee2559246d4aef7c4963
DIST xorg-server-21.1.1.tar.xz 4958508 BLAKE2B fadac208773700b91003ef18d46e6f2c6b501e59b7491c943f406641e9ff3837a8126034c023e9b6d2d4131ee438c1ef94fa458af1828d4be325519b47069a79 SHA512 8608ed9c1537c95e8a3adea5e3e372a3c5eb841f8e27c84283093f22fb1909e16a800006510da684b13f8f237f33b8a4be3e2537f5f9ab9af4c5ad12770eef0d
diff --git a/x11-base/xorg-server/xorg-server-1.20.14.ebuild b/x11-base/xorg-server/xorg-server-1.20.14.ebuild
new file mode 100644
index 000000000000..c212211e5a0b
--- /dev/null
+++ b/x11-base/xorg-server/xorg-server-1.20.14.ebuild
@@ -0,0 +1,209 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3 toolchain-funcs
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
+
+DESCRIPTION="X.Org X servers"
+SLOT="0/${PV}"
+if [[ ${PV} != 9999* ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+IUSE_SERVERS="dmx kdrive xephyr xnest xorg xvfb"
+IUSE="${IUSE_SERVERS} debug +elogind minimal selinux suid systemd test +udev unwind xcsecurity"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ media-libs/libglvnd[X]
+ dev-libs/openssl:0=
+ >=x11-apps/iceauth-1.0.2
+ >=x11-apps/rgb-1.0.3
+ >=x11-apps/xauth-1.0.3
+ x11-apps/xkbcomp
+ >=x11-libs/libdrm-2.4.89
+ >=x11-libs/libpciaccess-0.12.901
+ >=x11-libs/libXau-1.0.4
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXfont2-2.0.1
+ >=x11-libs/libxkbfile-1.0.4
+ >=x11-libs/libxshmfence-1.1
+ >=x11-libs/pixman-0.27.2
+ >=x11-misc/xbitmaps-1.0.1
+ >=x11-misc/xkeyboard-config-2.4.1-r3
+ dmx? (
+ x11-libs/libXt
+ >=x11-libs/libdmx-1.0.99.1
+ >=x11-libs/libX11-1.1.5
+ >=x11-libs/libXaw-1.0.4
+ >=x11-libs/libXext-1.0.99.4
+ >=x11-libs/libXfixes-5.0
+ >=x11-libs/libXi-1.2.99.1
+ >=x11-libs/libXmu-1.0.3
+ x11-libs/libXrender
+ >=x11-libs/libXres-1.0.3
+ >=x11-libs/libXtst-1.0.99.2
+ )
+ kdrive? (
+ >=x11-libs/libXext-1.0.5
+ x11-libs/libXv
+ )
+ xephyr? (
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-renderutil
+ x11-libs/xcb-util-wm
+ )
+ !minimal? (
+ >=x11-libs/libX11-1.1.5
+ >=x11-libs/libXext-1.0.5
+ >=media-libs/mesa-18[X(+),egl(+),gbm(+)]
+ >=media-libs/libepoxy-1.5.4[X,egl(+)]
+ )
+ udev? ( virtual/libudev:= )
+ unwind? ( sys-libs/libunwind )
+ >=x11-apps/xinit-1.3.3-r1
+ systemd? (
+ sys-apps/dbus
+ sys-apps/systemd
+ )
+ elogind? (
+ sys-apps/dbus
+ sys-auth/elogind[pam]
+ sys-auth/pambase[elogind]
+ )
+ !!x11-drivers/nvidia-drivers[-libglvnd(+)]
+"
+DEPEND="${CDEPEND}
+ >=x11-base/xorg-proto-2018.4
+ >=x11-libs/xtrans-1.3.5
+"
+RDEPEND="${CDEPEND}
+ !systemd? ( gui-libs/display-manager-init )
+ selinux? ( sec-policy/selinux-xserver )
+"
+BDEPEND="
+ sys-devel/flex
+"
+PDEPEND="
+ xorg? ( >=x11-base/xorg-drivers-$(ver_cut 1-2) )"
+
+REQUIRED_USE="!minimal? (
+ || ( ${IUSE_SERVERS} )
+ )
+ elogind? ( udev )
+ ?? ( elogind systemd )
+ xephyr? ( kdrive )"
+
+UPSTREAMED_PATCHES=(
+)
+
+PATCHES=(
+ "${UPSTREAMED_PATCHES[@]}"
+ "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
+ # needed for new eselect-opengl, bug #541232
+ "${FILESDIR}"/${PN}-1.18-support-multiple-Files-sections.patch
+)
+
+src_configure() {
+ # localstatedir is used for the log location; we need to override the default
+ # from ebuild.sh
+ # sysconfdir is used for the xorg.conf location; same applies
+ # NOTE: fop is used for doc generating; and I have no idea if Gentoo
+ # package it somewhere
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ $(use_enable dmx)
+ $(use_enable kdrive)
+ $(use_enable test unit-tests)
+ $(use_enable unwind libunwind)
+ $(use_enable !minimal record)
+ $(use_enable !minimal xfree86-utils)
+ $(use_enable !minimal dri)
+ $(use_enable !minimal dri2)
+ $(use_enable !minimal dri3)
+ $(use_enable !minimal glamor)
+ $(use_enable !minimal glx)
+ $(use_enable xcsecurity)
+ $(use_enable xephyr)
+ $(use_enable xnest)
+ $(use_enable xorg)
+ $(use_enable xvfb)
+ $(use_enable udev config-udev)
+ $(use_with systemd systemd-daemon)
+ --enable-ipv6
+ --disable-xwayland
+ --enable-libdrm
+ --sysconfdir="${EPREFIX}"/etc/X11
+ --localstatedir="${EPREFIX}"/var
+ --with-fontrootdir="${EPREFIX}"/usr/share/fonts
+ --with-xkb-output="${EPREFIX}"/var/lib/xkb
+ --disable-config-hal
+ --disable-linux-acpi
+ --without-dtrace
+ --without-doxygen
+ --without-fop
+ --without-xmlto
+ --with-os-vendor=Gentoo
+ --with-sha1=libcrypto
+ CPP="$(tc-getPROG CPP cpp)"
+ )
+
+ if use systemd || use elogind; then
+ XORG_CONFIGURE_OPTIONS+=(
+ --enable-systemd-logind
+ --disable-install-setuid
+ $(use_enable suid suid-wrapper)
+ )
+ else
+ XORG_CONFIGURE_OPTIONS+=(
+ --disable-systemd-logind
+ --disable-suid-wrapper
+ $(use_enable suid install-setuid)
+ )
+ fi
+
+ xorg-3_src_configure
+}
+
+server_based_install() {
+ if ! use xorg; then
+ rm -f "${ED}"/usr/share/man/man1/Xserver.1x \
+ "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
+ "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
+ "${ED}"/usr/share/man/man1/Xserver.1x || die
+ fi
+}
+
+src_install() {
+ xorg-3_src_install
+
+ server_based_install
+
+ if ! use minimal && use xorg; then
+ # Install xorg.conf.example into docs
+ dodoc "${S}"/hw/xfree86/xorg.conf.example
+
+ rm \
+ "${ED}"/usr/bin/cvt \
+ "${ED}"/usr/share/man/man1/cvt.1 || die
+ fi
+
+ # install the @x11-module-rebuild set for Portage
+ insinto /usr/share/portage/config/sets
+ newins "${FILESDIR}"/xorg-sets.conf xorg.conf
+
+ find "${ED}"/var -type d -empty -delete || die
+}
+
+pkg_postrm() {
+ # Get rid of module dir to ensure opengl-update works properly
+ if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
+ rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
+ fi
+}