summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-24 13:47:42 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-24 13:50:03 -0700
commitb6ce56827df33165e2e25b58f78085cdb31fd899 (patch)
tree5975938148718dac3211d375eb0e1e5163aee1de /x11-base
parentgames-action/transistor: New package at version 1.50440.8123.23365 (diff)
downloadgentoo-b6ce56827df33165e2e25b58f78085cdb31fd899.tar.gz
gentoo-b6ce56827df33165e2e25b58f78085cdb31fd899.tar.bz2
gentoo-b6ce56827df33165e2e25b58f78085cdb31fd899.zip
x11-base/xorg-proto: Version bump to 2022.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-proto/Manifest1
-rw-r--r--x11-base/xorg-proto/xorg-proto-2022.1.ebuild54
-rw-r--r--x11-base/xorg-proto/xorg-proto-9999.ebuild2
3 files changed, 56 insertions, 1 deletions
diff --git a/x11-base/xorg-proto/Manifest b/x11-base/xorg-proto/Manifest
index 1ee1022273af..d970c3efb4c3 100644
--- a/x11-base/xorg-proto/Manifest
+++ b/x11-base/xorg-proto/Manifest
@@ -1 +1,2 @@
DIST xorgproto-2021.5.tar.gz 1132811 BLAKE2B 3fe288cf8a848436dacc0ebf437b6a1d2c81878abaf8c542ff45e70389643cb2bc25bdab5ab6ff9d44a4f9bbdbd24757d21617c2c6a0754870afcd9f60ccbb05 SHA512 9c9ec62f0af68fd0dff24010986326a2b201be2b56b8b94abfe7258bf66b3c4c37088596c43a234aae63b1d781f7797caf408e434c98e8805803bc890b8aacb0
+DIST xorgproto-2022.1.tar.gz 1107316 BLAKE2B b7c60d77978f95b62208c5c5974c7310a9b6197c8b14218ba319eb44660f20c5eb33ef106beccae16f79a0530a20bd38b6aa2de81329c4b48a2da285ab903c31 SHA512 e34404eb9f7edfebdecbf38c66491fbca91929c59b5762d3266b2808cdae3f4e65589001d29bf5374effc56173a5467f5a107bf4fe05acae69839b841e83f72c
diff --git a/x11-base/xorg-proto/xorg-proto-2022.1.ebuild b/x11-base/xorg-proto/xorg-proto-2022.1.ebuild
new file mode 100644
index 000000000000..a86a2415e1b6
--- /dev/null
+++ b/x11-base/xorg-proto/xorg-proto-2022.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+MY_PN="${PN/xorg-/xorg}"
+MY_P="${MY_PN}-${PV}"
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/${MY_PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson python-any-r1
+
+DESCRIPTION="X.Org combined protocol headers"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND=""
+
+python_check_deps() {
+ has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/share/doc/{xorgproto,${P}} || die
+}
diff --git a/x11-base/xorg-proto/xorg-proto-9999.ebuild b/x11-base/xorg-proto/xorg-proto-9999.ebuild
index 865b171e534e..a86a2415e1b6 100644
--- a/x11-base/xorg-proto/xorg-proto-9999.ebuild
+++ b/x11-base/xorg-proto/xorg-proto-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7