summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-31 09:43:53 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-31 09:46:40 -0700
commitd55b33426a17d54b94b6d6d5d74c57c0c0faa708 (patch)
treead2ba0df7bd442b1c7360be3ecf9475733ed8f94 /x11-base
parentdev-java/netty-common: Stabilize 4.0.36-r2 arm64, #835504 (diff)
downloadgentoo-d55b33426a17d54b94b6d6d5d74c57c0c0faa708.tar.gz
gentoo-d55b33426a17d54b94b6d6d5d74c57c0c0faa708.tar.bz2
gentoo-d55b33426a17d54b94b6d6d5d74c57c0c0faa708.zip
x11-base/xwayland: Version bump to 22.1.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xwayland/Manifest1
-rw-r--r--x11-base/xwayland/xwayland-22.1.1.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/x11-base/xwayland/Manifest b/x11-base/xwayland/Manifest
index c5a07650c2a4..21207253b1f5 100644
--- a/x11-base/xwayland/Manifest
+++ b/x11-base/xwayland/Manifest
@@ -1,2 +1,3 @@
DIST xwayland-21.1.4.tar.xz 1261712 BLAKE2B 698886d450f340c4a275f583d27382a5ee22c09255d907bbe2babc6794da1827bd5bf3e575b9da77ff3b3c5c4cd3e30cc10b89d14e0f6365d2a71f8ade61e410 SHA512 54e18565b4c2514534501ddcc76058d6911cf0c2185cddf5c54833d317f51ba8eb8934bd9be269518ece05f3bc8cda81600b25871c61437c923eba916eccc525
DIST xwayland-22.1.0.tar.xz 1271896 BLAKE2B bd090032a31a2872d3e1095ca2f73d8945eb9f29801ea5164b867132c98e4195eb84adc404048b294e148181b38b9172453e276f78a1a9575889fbc77c31d740 SHA512 01306d2127e9d02e457d86208d6fb285379ed8fab2837febe56aaee4b236bc052ad65ca8ec35555b983d15f0d8dd01d20526a17b40225d2a4b91c53202ec10b5
+DIST xwayland-22.1.1.tar.xz 1272176 BLAKE2B 5dabf9d6cf6ed217cdf5694dba9c63059bcc43e2bb413c1edcd5d8775a906270b28e9dddb90bedacdefe27bd792339c346782511102b42250e2a940aa664e9cb SHA512 435cdf59f2be1ff7cb3dbb04e7a8920d9c48471fbeffca96c9dab2be400b168bfdb73b9e818829c555ab5d6fd83345eb693b3ba785d4ef701bdb27c8344077b5
diff --git a/x11-base/xwayland/xwayland-22.1.1.ebuild b/x11-base/xwayland/xwayland-22.1.1.ebuild
new file mode 100644
index 000000000000..242b2daef28f
--- /dev/null
+++ b/x11-base/xwayland/xwayland-22.1.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Standalone X server running under Wayland"
+HOMEPAGE="https://wayland.freedesktop.org/xserver.html"
+SRC_URI="https://xorg.freedesktop.org/archive/individual/xserver/${P}.tar.xz"
+
+IUSE="selinux video_cards_nvidia unwind xcsecurity"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ dev-libs/libbsd
+ dev-libs/openssl:=
+ >=dev-libs/wayland-1.20
+ >=dev-libs/wayland-protocols-1.22
+ media-fonts/font-util
+ >=media-libs/libepoxy-1.5.4[X,egl(+)]
+ media-libs/libglvnd[X]
+ >=media-libs/mesa-21.1[X(+),egl(+),gbm(+)]
+ >=x11-libs/libdrm-2.4.89
+ >=x11-libs/libXau-1.0.4
+ x11-libs/libxcvt
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXfont2-2.0.1
+ x11-libs/libxkbfile
+ >=x11-libs/libxshmfence-1.1
+ >=x11-libs/pixman-0.27.2
+ >=x11-misc/xkeyboard-config-2.4.1-r3
+
+ unwind? ( sys-libs/libunwind )
+ video_cards_nvidia? ( gui-libs/egl-wayland )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+ >=x11-libs/xtrans-1.3.5
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-apps/xkbcomp
+ !<=x11-base/xorg-server-1.20.11
+ selinux? ( sec-policy/selinux-xserver )
+"
+BDEPEND="
+ sys-devel/flex
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/xwayland-drop-redundantly-installed-files.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use selinux xselinux)
+ $(meson_use unwind libunwind)
+ $(meson_use xcsecurity)
+ $(meson_use video_cards_nvidia xwayland_eglstream)
+ -Ddpms=true
+ -Ddri3=true
+ -Ddrm=true
+ -Ddtrace=false
+ -Dglamor=true
+ -Dglx=true
+ -Dipv6=true
+ -Dsecure-rpc=false
+ -Dscreensaver=true
+ -Dsha1=libcrypto
+ -Dxace=true
+ -Dxdmcp=true
+ -Dxinerama=true
+ -Dxvfb=true
+ -Dxv=true
+ -Dxwayland-path="${EPREFIX}"/usr/bin
+ -Ddocs=false
+ -Ddevel-docs=false
+ -Ddocs-pdf=false
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ dosym ../bin/Xwayland /usr/libexec/Xwayland
+
+ meson_src_install
+}