summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-06-20 11:40:00 -0400
committerMatt Turner <mattst88@gentoo.org>2019-06-20 11:49:00 -0400
commitfe9995b039361f8d8dd70ba159533472c3672210 (patch)
tree41442cd9d43992d6d6c5c6f3d42b31b6f2c8e67a /x11-base
parentx11-base/xorg-proto: EAPI 7 and propagate keywords (diff)
downloadgentoo-fe9995b039361f8d8dd70ba159533472c3672210.tar.gz
gentoo-fe9995b039361f8d8dd70ba159533472c3672210.tar.bz2
gentoo-fe9995b039361f8d8dd70ba159533472c3672210.zip
x11-base/xorg-proto: Version bump to 2019.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-proto/Manifest1
-rw-r--r--x11-base/xorg-proto/xorg-proto-2019.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/x11-base/xorg-proto/Manifest b/x11-base/xorg-proto/Manifest
index 0b690c721ab6..84bf8519ad3b 100644
--- a/x11-base/xorg-proto/Manifest
+++ b/x11-base/xorg-proto/Manifest
@@ -1 +1,2 @@
DIST xorgproto-2018.4.tar.gz 493597 BLAKE2B f25a637317ff2d7ba34d416368261b5afb617e42a1fb642cc78ab3e877752a81291fe0523d1af6cd0fe27399676b14a70ceea7178d521187423bb503c9b1c63b SHA512 f79a47fc3de04d7258769869c11e99eff7fa4a4b5925cf60f9f7579f946d7d0e737224e9a54d18e439a3586126e66e0764c0f09ed50987c781955b9b9a1e0362
+DIST xorgproto-2019.1.tar.gz 1119813 BLAKE2B eed29e0e236cc448b2ff220a844c68f69b0d1d2d7cfb4e82219731bbedadfc9352cf894ce8ba3c2a9f7dd1689a46be0a9ed4b0d061c661b752b0e81ef1057f27 SHA512 7d3a5b24cf5c5ff78c63f61b7e4e2fe6f8b6ca64c345422a1943688af8dccd621cf22833035ee632d37ebb96bf4864d1c18a8015373d69e734299cccb481615a
diff --git a/x11-base/xorg-proto/xorg-proto-2019.1.ebuild b/x11-base/xorg-proto/xorg-proto-2019.1.ebuild
new file mode 100644
index 000000000000..2d1025ecb913
--- /dev/null
+++ b/x11-base/xorg-proto/xorg-proto-2019.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/xorg-/xorg}"
+MY_P="${MY_PN}-${PV}"
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/${MY_PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson
+
+DESCRIPTION="X.Org combined protocol headers"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ !<x11-proto/bigreqsproto-1.1.2-r1
+ !<x11-proto/compositeproto-0.4.2-r2
+ !<x11-proto/damageproto-1.2.1-r2
+ !<x11-proto/dmxproto-2.3.1-r2
+ !<x11-proto/dri2proto-2.8-r2
+ !<x11-proto/dri3proto-1.0-r1
+ !<x11-proto/fixesproto-5.0-r2
+ !<x11-proto/fontsproto-2.1.3-r1
+ !<x11-proto/glproto-1.4.17-r2
+ !<x11-proto/inputproto-2.3.2-r1
+ !<x11-proto/kbproto-1.0.7-r1
+ !<x11-proto/presentproto-1.1-r1
+ !<x11-proto/randrproto-1.5.0-r1
+ !<x11-proto/recordproto-1.14.2-r2
+ !<x11-proto/renderproto-0.11.1-r2
+ !<x11-proto/resourceproto-1.2.0-r1
+ !<x11-proto/scrnsaverproto-1.2.2-r2
+ !<x11-proto/trapproto-3.4.3-r1
+ !<x11-proto/videoproto-2.3.3-r1
+ !<x11-proto/xcmiscproto-1.2.2-r1
+ !<x11-proto/xextproto-7.3.0-r1
+ !<x11-proto/xf86bigfontproto-1.2.0-r2
+ !<x11-proto/xf86dgaproto-2.1-r3
+ !<x11-proto/xf86driproto-2.1.1-r2
+ !<x11-proto/xf86miscproto-0.9.3-r1
+ !<x11-proto/xf86vidmodeproto-2.3.1-r2
+ !<x11-proto/xineramaproto-1.2.1-r2
+ !<x11-proto/xproto-7.0.31-r1
+
+ !x11-proto/fontcacheproto
+ !x11-proto/xf86rushproto"
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}