summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2015-11-11 21:37:01 -0800
committerMatt Turner <mattst88@gentoo.org>2015-11-11 21:37:01 -0800
commit82d42b0206c8c7c9e6639231c1d995a39df90241 (patch)
treeeee0da9076764cdf924e878824b5082103b1785c /x11-drivers/xf86-video-ati
parentmedia-gfx/fontforge: Bump to 20150824 (diff)
downloadgentoo-82d42b0206c8c7c9e6639231c1d995a39df90241.tar.gz
gentoo-82d42b0206c8c7c9e6639231c1d995a39df90241.tar.bz2
gentoo-82d42b0206c8c7c9e6639231c1d995a39df90241.zip
x11-drivers/xf86-video-ati: Version bump to 7.6.1.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/Manifest1
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-7.6.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-ati/Manifest b/x11-drivers/xf86-video-ati/Manifest
index 7d030a4fbe16..c535968198aa 100644
--- a/x11-drivers/xf86-video-ati/Manifest
+++ b/x11-drivers/xf86-video-ati/Manifest
@@ -2,3 +2,4 @@ DIST xf86-video-ati-6.14.6.tar.bz2 1139495 SHA256 aa5286b3e4f0187d7df14785c06dd8
DIST xf86-video-ati-7.3.0.tar.bz2 816346 SHA256 107c072c4919a996e04f47afdb53d5946a3ad574f270b8c560ef8b3a032046fe SHA512 185fd0714cae2b5fd29be201dd272f58964303c1bd3e006bfd85e7b260afc0787ee4eb3954fb8452e8876f0094ac8b0be67ebeb29e1b768937afeeecdad3dc32 WHIRLPOOL f70b29c585f4b51aa487173a14050a0bd5772143884d3bc3ef5be00fd3701a4c95ea83079ac045f3c215a0f1c41d8cc83f0db60a151da9b624c4808efbcac19e
DIST xf86-video-ati-7.4.0.tar.bz2 832763 SHA256 96230ca9859a2a3e347b7f37597b7b344e80b83f378d3a8463ab1ceb69df76d9 SHA512 94f3620972f21dab3c4ead8d18dcd0333903fe820b647f86a0e6efe4edb712ec0450a1cfd32b1ff51ab803ae76aaa889fc8c8cad7b6c52a3b51462c780111458 WHIRLPOOL 7bd0e6d98db97d4fa282e975826aab2e6ade9ce9bdbb958df41f0961a62fc7f78c18755ec10bc1665a80e24db890ca5d9cacbeba19eb70a53a226133e7817044
DIST xf86-video-ati-7.5.0.tar.bz2 809756 SHA256 ec3e6f06b6cf9a40c72aafa3448aae8b034c80b37410ca9442d5cf6806e07936 SHA512 51ea3934285c579314614e336cee0d5c079a466cdc94f2c8649d9499515af3dfb37a7ac87ed69c6dbf6befa5bfca27f8305bbc028ff722e2f87143da5f101f7c WHIRLPOOL ba132708f423cebde7398cc6c9c18334a544ebaef4a60104ea27abeb4afa4a01b9a3dffa00c89e01a6cbf858cc410041d102c8327bc2167ebca5e941d4463f23
+DIST xf86-video-ati-7.6.1.tar.bz2 823043 SHA256 2516d9eeb8da8bcd3a01365ed1314919777910fa904ab268af342b5693e1d34c SHA512 b829b1db2088161a2486f396a9b36afd6fbbc765fb495450fb1c2de33951e6270c7ef6665c8275c66dfc6509af71b9882c342d236fc0537ff0dde117683c4891 WHIRLPOOL 91787a77590fbbf30b73fd1c4f7e427ea3eee25b4ba16f52ae2d9d0967b596b33a2bb04bbc8edc83baf48db6cabb459cf81b43da644dd0c1ee415fc650105ffc
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-7.6.1.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-7.6.1.ebuild
new file mode 100644
index 000000000000..a63aa0b96ac8
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-7.6.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DRI=always
+inherit linux-info xorg-2
+
+DESCRIPTION="ATI video driver"
+HOMEPAGE="http://www.x.org/wiki/ati/"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="+glamor udev"
+
+RDEPEND=">=x11-libs/libdrm-2.4.58[video_cards_radeon]
+ >=x11-libs/libpciaccess-0.8.0
+ glamor? ( || (
+ x11-base/xorg-server[glamor]
+ >=x11-libs/glamor-0.6
+ ) )
+ udev? ( virtual/udev )"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xf86driproto
+ x11-proto/xproto"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ if kernel_is -ge 3 9; then
+ CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
+ else
+ CONFIG_CHECK="~DRM_RADEON_KMS ~!FB_RADEON"
+ fi
+ fi
+ check_extra_config
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable glamor)
+ $(use_enable udev)
+ )
+ xorg-2_src_configure
+}