summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-04-07 20:20:40 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-04-07 20:21:07 +0200
commitb2cd4598fa3308b4056b830a6132382da628a162 (patch)
tree145d44595c376a238c81bcbdae742539f41714d7 /x11-drivers/xf86-video-ati
parentapp-crypt/gnupg: Version bump to 2.0.30 (diff)
downloadgentoo-b2cd4598fa3308b4056b830a6132382da628a162.tar.gz
gentoo-b2cd4598fa3308b4056b830a6132382da628a162.tar.bz2
gentoo-b2cd4598fa3308b4056b830a6132382da628a162.zip
x11-drivers/xf86-video-ati: Version bump to 7.7.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/Manifest1
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-7.7.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-ati/Manifest b/x11-drivers/xf86-video-ati/Manifest
index d94a9d477cf6..b3fa42ccd920 100644
--- a/x11-drivers/xf86-video-ati/Manifest
+++ b/x11-drivers/xf86-video-ati/Manifest
@@ -3,3 +3,4 @@ DIST xf86-video-ati-7.5.0.tar.bz2 809756 SHA256 ec3e6f06b6cf9a40c72aafa3448aae8b
DIST xf86-video-ati-7.6.1.tar.bz2 823043 SHA256 2516d9eeb8da8bcd3a01365ed1314919777910fa904ab268af342b5693e1d34c SHA512 b829b1db2088161a2486f396a9b36afd6fbbc765fb495450fb1c2de33951e6270c7ef6665c8275c66dfc6509af71b9882c342d236fc0537ff0dde117683c4891 WHIRLPOOL 91787a77590fbbf30b73fd1c4f7e427ea3eee25b4ba16f52ae2d9d0967b596b33a2bb04bbc8edc83baf48db6cabb459cf81b43da644dd0c1ee415fc650105ffc
DIST xf86-video-ati-7.6.1_p20160324.tar.xz 224552 SHA256 33d9aa1c81a7f1f70d82b161c3c1bcb70f75c243bcd757fa72098238ff3f76ed SHA512 9b3e8fc53e664cfef6620a3c7fbba0c77489fc745b280523973ab0c3d486b94954924b4be5d96e0f2f44b020e36a888d3cd4f915b28a184b359f4cccedde2812 WHIRLPOOL bc8f86b5f10dbc0df9a536088619e69434416dda2bc29a3e64cc6c0f72e77fd0890cd263feb5ad47475e3cc43250fa81b9e3495b37c715c1405e022be067d29b
DIST xf86-video-ati-7.6.1_p20160401.tar.xz 224876 SHA256 51ce0d1bb58fd96789de4f184d560bb1da3d91f20ed049f29ca89c3664e1f51a SHA512 625570350b3519b7b0e562f11bf6162e8c9a45b3277f7789d0a5f805f04e22a2f7fa786f74223be40e9ee92c584016bafc9efbec52dae841f2bb2f0eafbb85df WHIRLPOOL 8906a40b90fe8023fe01dad79ef4746932156c1d89816ecfbfe8777b19fdc57872e57331016b23a1ce99495b1fe33b0cf9bed909786d6cd414666d5cf2999dfd
+DIST xf86-video-ati-7.7.0.tar.bz2 836902 SHA256 844d1c577b145c90dc8ef027678f0c27f554363f782cd696a3aea26415b2c1c3 SHA512 002ae681c35c8293d7b11b1fe7ec7fad569a18bcb2091ae54e682de3878ffc681780d802a450f51cf4bcb81a7f137fb6b1c739c467e8f15f4ab8640fb2e472df WHIRLPOOL 69552ee1d715eaf9c0f65da15aa7d0cc1a2a2befe1d8c098b7a8ead11e7201c90b39a9e87811d59026af335532be2da62fe0deb784f8c8c509addcdaf33a5414
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-7.7.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-7.7.0.ebuild
new file mode 100644
index 000000000000..b56347c9c0c1
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-7.7.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DRI=always
+inherit linux-info xorg-2
+
+DESCRIPTION="ATI video driver"
+HOMEPAGE="http://www.x.org/wiki/ati/"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="+glamor udev"
+
+RDEPEND=">=x11-libs/libdrm-2.4.58[video_cards_radeon]
+ >=x11-libs/libpciaccess-0.8.0
+ glamor? ( x11-base/xorg-server[glamor] )
+ udev? ( virtual/udev )"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xf86driproto
+ x11-proto/xproto"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ if kernel_is -ge 3 9; then
+ CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
+ else
+ CONFIG_CHECK="~DRM_RADEON_KMS ~!FB_RADEON"
+ fi
+ fi
+ check_extra_config
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable glamor)
+ $(use_enable udev)
+ )
+ xorg-2_src_configure
+}