summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-drivers/xf86-video-sis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-drivers/xf86-video-sis')
-rw-r--r--x11-drivers/xf86-video-sis/Manifest1
-rw-r--r--x11-drivers/xf86-video-sis/metadata.xml5
-rw-r--r--x11-drivers/xf86-video-sis/xf86-video-sis-0.10.7.ebuild19
3 files changed, 25 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-sis/Manifest b/x11-drivers/xf86-video-sis/Manifest
new file mode 100644
index 000000000000..aba0a6b8d7d8
--- /dev/null
+++ b/x11-drivers/xf86-video-sis/Manifest
@@ -0,0 +1 @@
+DIST xf86-video-sis-0.10.7.tar.bz2 699499 SHA256 be2eb6acba081e88dabc5be9db379e3da89a4d4edeb68064f204bf343a411cd0 SHA512 095fd47803e8296ca3769b5c62e9399b6759023660c42b215b708dfed456e3cf2dad93b8abcb48887bd40e0d0b1435d4e1d711a721f5cb55bef4d7093ab387fa WHIRLPOOL 1e02d08750b8a274d834f3268df2ecc9d3949a960796f9b3669ec48050fd6d24a8ba9aac0f2bc4514ee654956cdc058d136363fbe111b8e25e21f370baead8ef
diff --git a/x11-drivers/xf86-video-sis/metadata.xml b/x11-drivers/xf86-video-sis/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-drivers/xf86-video-sis/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/x11-drivers/xf86-video-sis/xf86-video-sis-0.10.7.ebuild b/x11-drivers/xf86-video-sis/xf86-video-sis-0.10.7.ebuild
new file mode 100644
index 000000000000..9de335400e3f
--- /dev/null
+++ b/x11-drivers/xf86-video-sis/xf86-video-sis-0.10.7.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+XORG_DRI=dri
+inherit xorg-2
+
+DESCRIPTION="SiS and XGI video driver"
+KEYWORDS="amd64 ia64 ppc x86 ~x86-fbsd"
+IUSE="dri"
+
+DEPEND=">=x11-proto/xf86dgaproto-2.1"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable dri)
+ )
+}