summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-01-20 22:34:03 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-01-20 22:34:03 +0100
commit819f77d36db9c6e16022c1cf0bce18dfe6d4ac7c (patch)
tree1d28ef8039946cd1271389c13861600b07facc38 /x11-drivers/xf86-video-virtualbox
parentapp-emulation/virtualbox-bin: (diff)
downloadgentoo-819f77d36db9c6e16022c1cf0bce18dfe6d4ac7c.tar.gz
gentoo-819f77d36db9c6e16022c1cf0bce18dfe6d4ac7c.tar.bz2
gentoo-819f77d36db9c6e16022c1cf0bce18dfe6d4ac7c.zip
virtualbox packages: Bump to version 5.0.14
Package-Manager: portage-2.2.27 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-drivers/xf86-video-virtualbox')
-rw-r--r--x11-drivers/xf86-video-virtualbox/Manifest1
-rw-r--r--x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-5.0.14.ebuild174
2 files changed, 175 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-virtualbox/Manifest b/x11-drivers/xf86-video-virtualbox/Manifest
index e08d25af7826..12819929a148 100644
--- a/x11-drivers/xf86-video-virtualbox/Manifest
+++ b/x11-drivers/xf86-video-virtualbox/Manifest
@@ -3,3 +3,4 @@ DIST VirtualBox-4.3.32.tar.bz2 98168101 SHA256 dc5bf4e6f9989792d31bac174d20d7fc9
DIST VirtualBox-4.3.34.tar.bz2 98166680 SHA256 076507e924d3c5ae05c5e80a720b897da4a57a636a506a7d369b28f08b11d6c1 SHA512 1eeca08990d426155550d8920c159e41320bfedb53561b1752bd6816fa588588672ad364e73baf9b7b45e8352ae8feb1c649ba1748253da47586b55fe89e8fe3 WHIRLPOOL 1249e1d61aec38d439d1060457a1a0d0294a65d78dfa426026f3abe1882c429c628ea58f556bdeaf1a88d3cdd3b9095f1e4c6f1fae2176f39f8da5bb3d091809
DIST VirtualBox-5.0.10.tar.bz2 110904399 SHA256 56eafae439b91ea3c3748f2128b2969ba76983acf821acaa08e043c129b45a89 SHA512 8836e5b57ed46b57b12a9fdb6a632e895c3106dad58c3ab3e28f9178ce69499c493a935b6df8b872dc4677c12eb826a46113bdb902e4fb3d2f8ee6d768e53930 WHIRLPOOL 05516c1d9a3cd876a67a73b86df47ec7d1ef08ed921cb3e25ef483676413982ac8a7ce6562f3003240d862a33759aee5e6c94a303a2a35b66025d72cb15d4404
DIST VirtualBox-5.0.12.tar.bz2 111001547 SHA256 de0362b1d404d1ca0298db1984acb6f0f1c6210313aeb744fea345ad9201e86e SHA512 eef01d1a5121905d2fbfcd48081f18db06433187bfbfea6a006b3adea11cad8c8351025fd19fa115c132231592330b17bfeba033a3a168f3064176a3f7586d7a WHIRLPOOL bd73e67c83a524cb021ff92c4c3d655f6a1019e2d48f3ec97aee937543ca9da6f7ba2a1e70a6b75092dce3c8db8f3c7887300104fafa23432b94bc832c5e5447
+DIST VirtualBox-5.0.14.tar.bz2 111033626 SHA256 69abac7255b2251a18fd73c0b7c200d5f8ce72a59fa019b53a5cdbf7f2843002 SHA512 5547da58b50c9cf5d096f81c005134e1f56c4fb55d4d40a6fbd1efe1fe1fbeebc0747f0903933da9238a24c63eeed2c6c15bfc5cae5ce6e3e2eb4a18511d6258 WHIRLPOOL 785e0fa7a0652825b977562a1febbd95463ce49a9257a004827725597e0fbd59f9bdf75cc31f5b04e0f04be3d0d68e90148c06dd5d03875063312f8a3cd5bc86
diff --git a/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-5.0.14.ebuild b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-5.0.14.ebuild
new file mode 100644
index 000000000000..0a9abc4675e4
--- /dev/null
+++ b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-5.0.14.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils linux-mod multilib python-single-r1 versionator toolchain-funcs
+
+MY_PV="${PV/beta/BETA}"
+MY_PV="${MY_PV/rc/RC}"
+MY_P=VirtualBox-${MY_PV}
+DESCRIPTION="VirtualBox video driver"
+HOMEPAGE="http://www.virtualbox.org/"
+SRC_URI="http://download.virtualbox.org/virtualbox/${MY_PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dri"
+
+RDEPEND=">=x11-base/xorg-server-1.7:=[-minimal]
+ x11-libs/libXcomposite"
+DEPEND="${RDEPEND}
+ >=dev-util/kbuild-0.1.9998_pre20131130
+ ${PYTHON_DEPS}
+ >=dev-lang/yasm-0.6.2
+ >=sys-devel/gcc-4.9.0
+ sys-power/iasl
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/resourceproto
+ x11-proto/scrnsaverproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xproto
+ x11-libs/libXdmcp
+ x11-libs/libXau
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXext
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2.4.5 )"
+
+REQUIRED_USE=( "${PYTHON_REQUIRED_USE}" )
+
+BUILD_TARGETS="all"
+BUILD_TARGET_ARCH="${ARCH}"
+MODULE_NAMES="vboxvideo(misc:${WORKDIR}/vboxvideo_drm:${WORKDIR}/vboxvideo_drm)"
+
+S="${WORKDIR}/${MY_P}"
+
+QA_TEXTRELS_x86="usr/lib/VBoxOGL.so"
+
+pkg_setup() {
+ if [ "${MERGE_TYPE}" != "binary" ]; then
+ version_is_at_least 4.9 $(gcc-version) || die "Please set gcc 4.9 or higher as active in gcc-config to build ${PN}"
+ fi
+
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERN_DIR=${KV_OUT_DIR} KERNOUT=${KV_OUT_DIR}"
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Prepare the vboxvideo_drm sources and Makefile in ${WORKDIR}
+ cp -a "${S}"/src/VBox/Additions/linux/drm "${WORKDIR}/vboxvideo_drm" \
+ || die "cannot copy vboxvideo_drm directory"
+ cp "${FILESDIR}/${PN}-3-vboxvideo_drm.makefile" \
+ "${WORKDIR}/vboxvideo_drm/Makefile" \
+ || die "cannot copy vboxvideo_drm Makefile"
+
+ # stupid new header references...
+ for vboxheader in {product,version}-generated.h ; do
+ ln -sf "${S}"/out/linux.${ARCH}/release/${vboxheader} \
+ "${WORKDIR}/vboxvideo_drm/${vboxheader}"
+ done
+
+ # Remove shipped binaries (kBuild,yasm), see bug #232775
+ rm -rf kBuild/bin tools
+
+ # Disable things unused or splitted into separate ebuilds
+ cp "${FILESDIR}/${PN}-5-localconfig" LocalConfig.kmk || die
+
+ # Ugly hack to build the opengl part of the video driver
+ epatch "${FILESDIR}/${PN}-2.2.0-enable-opengl.patch"
+
+ # unset useless/problematic checks in configure
+ epatch "${FILESDIR}/${PN}-5.0.0_beta3-configure_checks.patch"
+
+ # link with lazy on hardened #394757
+ sed -i '/^TEMPLATE_VBOXR3EXE_LDFLAGS.linux/s/$/ -Wl,-z,lazy/' Config.kmk || die
+}
+
+src_configure() {
+ # build the user-space tools, warnings are harmless
+ local cmd=(
+ ./configure
+ --nofatal
+ --disable-xpcom
+ --disable-sdl-ttf
+ --disable-pulse
+ --disable-alsa
+ --with-gcc="$(tc-getCC)"
+ --with-g++="$(tc-getCXX)"
+ --target-arch=${ARCH}
+ --with-linux="${KV_OUT_DIR}"
+ --build-headless
+ )
+ echo "${cmd[@]}"
+ "${cmd[@]}" || die "configure failed"
+ source ./env.sh
+ export VBOX_GCC_OPT="${CFLAGS} ${CPPFLAGS}"
+}
+
+src_compile() {
+ for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
+ /src/VBox/{GuestHost/OpenGL,Additions/x11/x11stubs,Additions/common/crOpenGL} \
+ /src/VBox/Additions/x11/vboxvideo ; do
+ cd "${S}"${each} || die
+ MAKE="kmk" \
+ emake TOOL_YASM_AS=yasm \
+ VBOX_USE_SYSTEM_XORG_HEADERS=1 \
+ KBUILD_PATH="${S}/kBuild" \
+ KBUILD_VERBOSE=2
+ done
+
+ if use dri ; then
+ # Now creating the kernel modules. We must do this _after_
+ # we compiled the user-space tools as we need two of the
+ # automatically generated header files. (>=3.2.0)
+ linux-mod_src_compile
+ fi
+}
+
+src_install() {
+ if use dri; then
+ linux-mod_src_install
+ fi
+
+ cd "${S}/out/linux.${ARCH}/release/bin/additions"
+ insinto /usr/$(get_libdir)/xorg/modules/drivers
+ newins vboxvideo_drv_system.so vboxvideo_drv.so
+
+ # Guest OpenGL driver
+ insinto /usr/$(get_libdir)
+ doins -r VBoxOGL*
+
+ if use dri ; then
+ dosym /usr/$(get_libdir)/VBoxOGL.so \
+ /usr/$(get_libdir)/dri/vboxvideo_dri.so
+ fi
+}
+
+pkg_postinst() {
+ elog "You need to edit the file /etc/X11/xorg.conf and set:"
+ elog ""
+ elog " Driver \"vboxvideo\""
+ elog ""
+ elog "in the Graphics device section (Section \"Device\")"
+ elog ""
+ if use dri; then
+ elog "To use the kernel drm video driver, please add:"
+ elog "\"vboxvideo\" to:"
+ if has_version sys-apps/openrc ; then
+ elog "/etc/conf.d/modules"
+ else
+ elog "/etc/modules.autoload.d/kernel-${KV_MAJOR}.${KV_MINOR}"
+ fi
+ elog ""
+ fi
+}