summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-12-28 14:26:19 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-12-28 14:48:30 -0500
commit3742a22fe46420b694bb5b550341956ccfdd93aa (patch)
tree3d40d3282d59fc54dc9e361633a33b5f0af0e0a2 /x11-drivers
parentdev-python/pylama: Keyword 8.3.6 hppa, #830166 (diff)
downloadgentoo-3742a22fe46420b694bb5b550341956ccfdd93aa.tar.gz
gentoo-3742a22fe46420b694bb5b550341956ccfdd93aa.tar.bz2
gentoo-3742a22fe46420b694bb5b550341956ccfdd93aa.zip
x11-drivers/nvidia-drivers: add out-of-tree modules to README.gentoo
While this applies to every ebuilds that build modules, nvidia-drivers is often a user's first or only experience with these and support requests from those that did not know are somewhat common (e.g. upgraded kernel without rebuilding, or built modules against the wrong kernel). While wiki is better for a lot of these things, having more sources mention this material increase chances to reach users. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild19
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-460.91.03-r2.ebuild19
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-470.62.16.ebuild19
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-470.94.ebuild19
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r10.ebuild19
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r20.ebuild19
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-495.46.ebuild19
7 files changed, 112 insertions, 21 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild
index e2113aa452bb..27bc1f65bc9b 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild
@@ -250,9 +250,22 @@ src_install() {
local DISABLE_AUTOFORMATTING=yes
local DOC_CONTENTS="\
Trusted users should be in the 'video' group to use NVIDIA devices.
-You can add yourself by using: gpasswd -a my-user video
-
-See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options.\
+You can add yourself by using: gpasswd -a my-user video\
+$(usex driver "
+
+Like all out-of-tree kernel modules, it is necessary to rebuild
+${PN} after upgrading or rebuilding the Linux kernel
+by for example running \`emerge @module-rebuild\`. Alternatively,
+if using a distribution kernel (sys-kernel/gentoo-kernel{,-bin}),
+this can be automated by setting USE=dist-kernel globally.
+
+Loaded kernel modules also must not mismatch with the installed
+${PN} version (excluding -r revision), meaning should
+ensure \`eselect kernel list\` points to the kernel that will be
+booted before building and preferably reboot after upgrading
+${PN} (the ebuild will emit a warning if mismatching).
+
+See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options." '')\
$(use amd64 && usex abi_x86_32 '' "
Note that without USE=abi_x86_32 on ${PN}, 32bit applications
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-460.91.03-r2.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-460.91.03-r2.ebuild
index 655467d6bb9f..61240f76f26d 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-460.91.03-r2.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-460.91.03-r2.ebuild
@@ -230,9 +230,22 @@ src_install() {
local DISABLE_AUTOFORMATTING=yes
local DOC_CONTENTS="\
Trusted users should be in the 'video' group to use NVIDIA devices.
-You can add yourself by using: gpasswd -a my-user video
-
-See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options.\
+You can add yourself by using: gpasswd -a my-user video\
+$(usex driver "
+
+Like all out-of-tree kernel modules, it is necessary to rebuild
+${PN} after upgrading or rebuilding the Linux kernel
+by for example running \`emerge @module-rebuild\`. Alternatively,
+if using a distribution kernel (sys-kernel/gentoo-kernel{,-bin}),
+this can be automated by setting USE=dist-kernel globally.
+
+Loaded kernel modules also must not mismatch with the installed
+${PN} version (excluding -r revision), meaning should
+ensure \`eselect kernel list\` points to the kernel that will be
+booted before building and preferably reboot after upgrading
+${PN} (the ebuild will emit a warning if mismatching).
+
+See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options." '')\
$(use amd64 && usex abi_x86_32 '' "
Note that without USE=abi_x86_32 on ${PN}, 32bit applications
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-470.62.16.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-470.62.16.ebuild
index fd2f86147ae7..6de4753fb633 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-470.62.16.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-470.62.16.ebuild
@@ -243,9 +243,22 @@ src_install() {
local DISABLE_AUTOFORMATTING=yes
local DOC_CONTENTS="\
Trusted users should be in the 'video' group to use NVIDIA devices.
-You can add yourself by using: gpasswd -a my-user video
-
-See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options.\
+You can add yourself by using: gpasswd -a my-user video\
+$(usex driver "
+
+Like all out-of-tree kernel modules, it is necessary to rebuild
+${PN} after upgrading or rebuilding the Linux kernel
+by for example running \`emerge @module-rebuild\`. Alternatively,
+if using a distribution kernel (sys-kernel/gentoo-kernel{,-bin}),
+this can be automated by setting USE=dist-kernel globally.
+
+Loaded kernel modules also must not mismatch with the installed
+${PN} version (excluding -r revision), meaning should
+ensure \`eselect kernel list\` points to the kernel that will be
+booted before building and preferably reboot after upgrading
+${PN} (the ebuild will emit a warning if mismatching).
+
+See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options." '')\
$(use amd64 && usex abi_x86_32 '' "
Note that without USE=abi_x86_32 on ${PN}, 32bit applications
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-470.94.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-470.94.ebuild
index 8b978b4e3911..bba3a75169aa 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-470.94.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-470.94.ebuild
@@ -243,9 +243,22 @@ src_install() {
local DISABLE_AUTOFORMATTING=yes
local DOC_CONTENTS="\
Trusted users should be in the 'video' group to use NVIDIA devices.
-You can add yourself by using: gpasswd -a my-user video
-
-See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options.\
+You can add yourself by using: gpasswd -a my-user video\
+$(usex driver "
+
+Like all out-of-tree kernel modules, it is necessary to rebuild
+${PN} after upgrading or rebuilding the Linux kernel
+by for example running \`emerge @module-rebuild\`. Alternatively,
+if using a distribution kernel (sys-kernel/gentoo-kernel{,-bin}),
+this can be automated by setting USE=dist-kernel globally.
+
+Loaded kernel modules also must not mismatch with the installed
+${PN} version (excluding -r revision), meaning should
+ensure \`eselect kernel list\` points to the kernel that will be
+booted before building and preferably reboot after upgrading
+${PN} (the ebuild will emit a warning if mismatching).
+
+See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options." '')\
$(use amd64 && usex abi_x86_32 '' "
Note that without USE=abi_x86_32 on ${PN}, 32bit applications
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r10.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r10.ebuild
index 02a6354ec0a0..9983bd4e0e6b 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r10.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r10.ebuild
@@ -257,9 +257,22 @@ src_install() {
local DISABLE_AUTOFORMATTING=yes
local DOC_CONTENTS="\
Trusted users should be in the 'video' group to use NVIDIA devices.
-You can add yourself by using: gpasswd -a my-user video
-
-See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options.\
+You can add yourself by using: gpasswd -a my-user video\
+$(usex driver "
+
+Like all out-of-tree kernel modules, it is necessary to rebuild
+${PN} after upgrading or rebuilding the Linux kernel
+by for example running \`emerge @module-rebuild\`. Alternatively,
+if using a distribution kernel (sys-kernel/gentoo-kernel{,-bin}),
+this can be automated by setting USE=dist-kernel globally.
+
+Loaded kernel modules also must not mismatch with the installed
+${PN} version (excluding -r revision), meaning should
+ensure \`eselect kernel list\` points to the kernel that will be
+booted before building and preferably reboot after upgrading
+${PN} (the ebuild will emit a warning if mismatching).
+
+See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options." '')\
$(use amd64 && usex abi_x86_32 '' "
Note that without USE=abi_x86_32 on ${PN}, 32bit applications
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r20.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r20.ebuild
index 5506a22853f2..6ef95b7be24f 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r20.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r20.ebuild
@@ -255,9 +255,22 @@ src_install() {
local DISABLE_AUTOFORMATTING=yes
local DOC_CONTENTS="\
Trusted users should be in the 'video' group to use NVIDIA devices.
-You can add yourself by using: gpasswd -a my-user video
-
-See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options.\
+You can add yourself by using: gpasswd -a my-user video\
+$(usex driver "
+
+Like all out-of-tree kernel modules, it is necessary to rebuild
+${PN} after upgrading or rebuilding the Linux kernel
+by for example running \`emerge @module-rebuild\`. Alternatively,
+if using a distribution kernel (sys-kernel/gentoo-kernel{,-bin}),
+this can be automated by setting USE=dist-kernel globally.
+
+Loaded kernel modules also must not mismatch with the installed
+${PN} version (excluding -r revision), meaning should
+ensure \`eselect kernel list\` points to the kernel that will be
+booted before building and preferably reboot after upgrading
+${PN} (the ebuild will emit a warning if mismatching).
+
+See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options." '')\
$(use amd64 && usex abi_x86_32 '' "
Note that without USE=abi_x86_32 on ${PN}, 32bit applications
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-495.46.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-495.46.ebuild
index f1b40b9e892b..38e290de75f8 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-495.46.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-495.46.ebuild
@@ -246,9 +246,22 @@ src_install() {
local DISABLE_AUTOFORMATTING=yes
local DOC_CONTENTS="\
Trusted users should be in the 'video' group to use NVIDIA devices.
-You can add yourself by using: gpasswd -a my-user video
-
-See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options.\
+You can add yourself by using: gpasswd -a my-user video\
+$(usex driver "
+
+Like all out-of-tree kernel modules, it is necessary to rebuild
+${PN} after upgrading or rebuilding the Linux kernel
+by for example running \`emerge @module-rebuild\`. Alternatively,
+if using a distribution kernel (sys-kernel/gentoo-kernel{,-bin}),
+this can be automated by setting USE=dist-kernel globally.
+
+Loaded kernel modules also must not mismatch with the installed
+${PN} version (excluding -r revision), meaning should
+ensure \`eselect kernel list\` points to the kernel that will be
+booted before building and preferably reboot after upgrading
+${PN} (the ebuild will emit a warning if mismatching).
+
+See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options." '')\
$(use amd64 && usex abi_x86_32 '' "
Note that without USE=abi_x86_32 on ${PN}, 32bit applications