summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-02 01:55:05 +0200
committerMatt Turner <mattst88@gentoo.org>2021-05-02 11:24:45 -0400
commit515db778e9a0af94abd5d834493eb0c6847ddff7 (patch)
treead4230f0a20d1877bfaaaf7279339d4c9dbbd0cb /x11-drivers
parentx11-drivers/xf86-input-vmmouse: Define XORG_CONFIGURE_OPTIONS in src_configure (diff)
downloadgentoo-515db778e9a0af94abd5d834493eb0c6847ddff7.tar.gz
gentoo-515db778e9a0af94abd5d834493eb0c6847ddff7.tar.bz2
gentoo-515db778e9a0af94abd5d834493eb0c6847ddff7.zip
x11-drivers/xf86-input-wacom: Define XORG_CONFIGURE_OPTIONS in src_configure
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.39.0.ebuild26
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.40.0.ebuild26
2 files changed, 30 insertions, 22 deletions
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.39.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.39.0.ebuild
index 6810d3ce8285..ee39fbabc711 100644
--- a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.39.0.ebuild
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.39.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,16 +26,6 @@ RDEPEND="dev-libs/libwacom
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-pkg_setup() {
- linux-info_pkg_setup
-
- XORG_CONFIGURE_OPTIONS=(
- --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
- --with-udev-rules-dir="$(get_udevdir)/rules.d"
- $(use_enable debug)
- )
-}
-
pkg_pretend() {
linux-info_pkg_setup
@@ -65,3 +55,17 @@ pkg_pretend() {
fi
fi
}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ xorg-3_pkg_setup
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+ --with-udev-rules-dir="$(get_udevdir)/rules.d"
+ $(use_enable debug)
+ )
+ xorg-3_src_configure
+}
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.40.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.40.0.ebuild
index 9f3d6c1d1a7c..979b98494b56 100644
--- a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.40.0.ebuild
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.40.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,16 +26,6 @@ RDEPEND="dev-libs/libwacom
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-pkg_setup() {
- linux-info_pkg_setup
-
- XORG_CONFIGURE_OPTIONS=(
- --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
- --with-udev-rules-dir="$(get_udevdir)/rules.d"
- $(use_enable debug)
- )
-}
-
pkg_pretend() {
linux-info_pkg_setup
@@ -65,3 +55,17 @@ pkg_pretend() {
fi
fi
}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ xorg-3_pkg_setup
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+ --with-udev-rules-dir="$(get_udevdir)/rules.d"
+ $(use_enable debug)
+ )
+ xorg-3_src_configure
+}