summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-03-19 23:39:49 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-19 23:39:49 +0100
commitc6b48be32da31faf292dae06b4f42209dfa24e0d (patch)
tree7bb5fa86dbb964209fa9ad5b32f5c436792ca34a /x11-drivers
parentx11-drivers/xf86-video-openchrome: Port to EAPI 7 (diff)
downloadgentoo-c6b48be32da31faf292dae06b4f42209dfa24e0d.tar.gz
gentoo-c6b48be32da31faf292dae06b4f42209dfa24e0d.tar.bz2
gentoo-c6b48be32da31faf292dae06b4f42209dfa24e0d.zip
x11-drivers/xf86-video-qxl: Cleanup
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5_p20200205.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5_p20200205.ebuild b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5_p20200205.ebuild
index d4f5d8c3a49e..e8e8ae5dc9bf 100644
--- a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5_p20200205.ebuild
+++ b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5_p20200205.ebuild
@@ -3,18 +3,17 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..9} )
-inherit python-single-r1 xorg-3 autotools
+inherit autotools python-single-r1 xorg-3
-SRC_URI="https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}.tar.xz"
DESCRIPTION="QEMU QXL paravirt video driver"
-KEYWORDS="~amd64 ~x86"
+SRC_URI="https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}.tar.xz"
+S="${WORKDIR}"
+KEYWORDS="~amd64 ~x86"
IUSE="xspice"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-S="${WORKDIR}/"
+REQUIRED_USE="xspice? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
xspice? (
@@ -23,20 +22,25 @@ RDEPEND="
)
x11-base/xorg-server[-minimal]
>=x11-libs/libdrm-2.4.46"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
>=app-emulation/spice-protocol-0.12.0
x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
-src_prepare() {
- python_fix_shebang scripts
+pkg_setup() {
+ use xspice && python-single-r1_pkg_setup
+}
+src_prepare() {
+ xorg-3_src_prepare
eautoreconf
- xorg-3_src_prepare
+ use xspice && python_fix_shebang scripts
}
src_configure() {
- XORG_CONFIGURE_OPTIONS=(
+ local XORG_CONFIGURE_OPTIONS=(
$(use_enable xspice)
)
xorg-3_src_configure