summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2021-02-14 00:53:58 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2021-02-14 00:55:20 +0100
commitdb3da557988e84d9eb824d32eedfb74c910421ce (patch)
treef9dbbbb240148108f2d08c25eea8b07012af1f00 /x11-drivers
parentnet-misc/netevent: Don't build with the -Werror flag (diff)
downloadgentoo-db3da557988e84d9eb824d32eedfb74c910421ce.tar.gz
gentoo-db3da557988e84d9eb824d32eedfb74c910421ce.tar.bz2
gentoo-db3da557988e84d9eb824d32eedfb74c910421ce.zip
x11-drivers/xf86-video-qxl: 2020-02-05 snapshot; py3; eapi7.
Closes: https://bugs.gentoo.org/716338 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-qxl/Manifest1
-rw-r--r--x11-drivers/xf86-video-qxl/metadata.xml11
-rw-r--r--x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5_p20200205.ebuild43
3 files changed, 51 insertions, 4 deletions
diff --git a/x11-drivers/xf86-video-qxl/Manifest b/x11-drivers/xf86-video-qxl/Manifest
index 217767f4ac30..4ac51ead1da6 100644
--- a/x11-drivers/xf86-video-qxl/Manifest
+++ b/x11-drivers/xf86-video-qxl/Manifest
@@ -1 +1,2 @@
DIST xf86-video-qxl-0.1.5.tar.bz2 508266 BLAKE2B ca0fd43830a393d9bb1f5a6ba306f26e07a0b90233fa44f3fbe7a5f21026f1bd6960254db9cd75d947b3c42f6cc8cd3b7cfd71afc2c0a74bd84c60eafcf7e150 SHA512 7510b2d037b3e978df6063b29e2406f3d1270695a239f29fdaec9b1dc65a30ab10cb959f15eb336f78e93aa708d41c64c5ea43803958feffc64542229605b782
+DIST xf86-video-qxl-0.1.5_p20200205.tar.xz 137452 BLAKE2B 1639a393dadcba251a8fe761d52112d51c29e70960524785343379ec088e69c5e2cbd1a9710d72c749dc8b7303b3eceb545fbaec82d5d22613f8ebb0a4e7aca8 SHA512 9a2ba4aa7ef61d3ea0043ff1e3a8f312b7fe00f707045bcb4e4fc1189786b9aba2b6e44696f47e7c215485044f6c953f831ed4da48d4098cd7b62555c74a79f8
diff --git a/x11-drivers/xf86-video-qxl/metadata.xml b/x11-drivers/xf86-video-qxl/metadata.xml
index 1516ec6dde26..7336996231e9 100644
--- a/x11-drivers/xf86-video-qxl/metadata.xml
+++ b/x11-drivers/xf86-video-qxl/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
-<email>x11@gentoo.org</email>
-<name>X11</name>
-</maintainer>
+ <maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+ </maintainer>
+ <use>
+ <flag name="xspice">Include Xspice, a standard X server that is also a Spice server</flag>
+ </use>
</pkgmetadata>
diff --git a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5_p20200205.ebuild b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5_p20200205.ebuild
new file mode 100644
index 000000000000..d4f5d8c3a49e
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5_p20200205.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit python-single-r1 xorg-3 autotools
+
+SRC_URI="https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}.tar.xz"
+DESCRIPTION="QEMU QXL paravirt video driver"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="xspice"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/"
+
+RDEPEND="
+ xspice? (
+ app-emulation/spice
+ ${PYTHON_DEPS}
+ )
+ x11-base/xorg-server[-minimal]
+ >=x11-libs/libdrm-2.4.46"
+DEPEND="${RDEPEND}
+ >=app-emulation/spice-protocol-0.12.0
+ x11-base/xorg-proto"
+
+src_prepare() {
+ python_fix_shebang scripts
+
+ eautoreconf
+
+ xorg-3_src_prepare
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable xspice)
+ )
+ xorg-3_src_configure
+}