summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-11-19 12:25:11 +0100
committerJeroen Roovers <jer@gentoo.org>2016-11-19 12:27:40 +0100
commit0be2a9a671a343a2102a3491d723dbccea88061c (patch)
treec390bd95b0e379a554d7a322aef15f4b8b7d083f /x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.14.ebuild
parentdev-db/redis: remove useless unstable ebuilds (diff)
downloadgentoo-0be2a9a671a343a2102a3491d723dbccea88061c.tar.gz
gentoo-0be2a9a671a343a2102a3491d723dbccea88061c.tar.bz2
gentoo-0be2a9a671a343a2102a3491d723dbccea88061c.zip
x11-libs/c++-gtk-utils: Version bump.
Package-Manager: portage-2.3.2
Diffstat (limited to 'x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.14.ebuild')
-rw-r--r--x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.14.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.14.ebuild b/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.14.ebuild
new file mode 100644
index 000000000000..76f41f087b97
--- /dev/null
+++ b/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.14.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A library containing a number of classes and functions for programming GTK+ programs using C++"
+HOMEPAGE="http://cxx-gtk-utils.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/++/xx}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+gtk nls static-libs"
+SLOT="0"
+
+RDEPEND="
+ >=dev-libs/glib-2.26
+ gtk? ( x11-libs/gtk+:3 )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gtk) \
+ $(use_enable static-libs static) \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --without-guile
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}