summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-01-14 13:19:37 -0800
committerMatt Turner <mattst88@gentoo.org>2020-01-14 13:19:37 -0800
commit1459b3170fba09b7e933ffecc2b3011cda0e5cd9 (patch)
tree428cfc7627d0bfa814c01c79a69772b4a7a06254 /x11-libs/cairo/cairo-9999.ebuild
parentx11-libs/cairo: Drop IUSE=xcb (diff)
downloadgentoo-1459b3170fba09b7e933ffecc2b3011cda0e5cd9.tar.gz
gentoo-1459b3170fba09b7e933ffecc2b3011cda0e5cd9.tar.bz2
gentoo-1459b3170fba09b7e933ffecc2b3011cda0e5cd9.zip
x11-libs/cairo: Rename IUSE=gles2 to gles2-only
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/cairo/cairo-9999.ebuild')
-rw-r--r--x11-libs/cairo/cairo-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/x11-libs/cairo/cairo-9999.ebuild b/x11-libs/cairo/cairo-9999.ebuild
index 45d38bca293a..e6b26da64417 100644
--- a/x11-libs/cairo/cairo-9999.ebuild
+++ b/x11-libs/cairo/cairo-9999.ebuild
@@ -18,7 +18,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
HOMEPAGE="https://www.cairographics.org/ https://gitlab.freedesktop.org/cairo/cairo"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
-IUSE="X aqua debug gles2 +glib opengl static-libs +svg utils valgrind"
+IUSE="X aqua debug gles2-only +glib opengl static-libs +svg utils valgrind"
# gtk-doc regeneration doesn't seem to work with out-of-source builds
#[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
@@ -36,7 +36,7 @@ RDEPEND="
sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
>=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
- gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
+ gles2-only? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
opengl? ( >=media-libs/mesa-9.1.6[egl,X(+),${MULTILIB_USEDEP}] )
X? (
@@ -54,7 +54,7 @@ DEPEND="${RDEPEND}
# )"
REQUIRED_USE="
- gles2? ( !opengl )
+ gles2-only? ( !opengl )
"
PATCHES=(
@@ -99,7 +99,7 @@ multilib_src_configure() {
$(use_enable aqua quartz) \
$(use_enable aqua quartz-image) \
$(use_enable debug test-surfaces) \
- $(use_enable gles2 glesv2) \
+ $(use_enable gles2-only glesv2) \
$(use_enable glib gobject) \
$(use_enable opengl gl) \
$(use_enable static-libs static) \