summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-01-13 09:51:43 -0800
committerMatt Turner <mattst88@gentoo.org>2020-01-13 10:13:24 -0800
commit9e9e288b6f0e95521aae6540d423ec015ec4a0cd (patch)
treee9145dd28174166475fedb128de978a306e464ab /x11-libs/cairo/cairo-9999.ebuild
parentmedia-libs/mesa: Add Python 3.8 support (diff)
downloadgentoo-9e9e288b6f0e95521aae6540d423ec015ec4a0cd.tar.gz
gentoo-9e9e288b6f0e95521aae6540d423ec015ec4a0cd.tar.bz2
gentoo-9e9e288b6f0e95521aae6540d423ec015ec4a0cd.zip
x11-libs/cairo: Port to EAPI=7
Thanks to David Michael. Closes: https://bugs.gentoo.org/705130 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/cairo/cairo-9999.ebuild')
-rw-r--r--x11-libs/cairo/cairo-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-libs/cairo/cairo-9999.ebuild b/x11-libs/cairo/cairo-9999.ebuild
index f2e28c9ed364..6b69a9ab32b6 100644
--- a/x11-libs/cairo/cairo-9999.ebuild
+++ b/x11-libs/cairo/cairo-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils flag-o-matic autotools multilib-minimal
+inherit flag-o-matic autotools multilib-minimal
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -25,6 +25,9 @@ IUSE="X aqua debug gles2 +glib opengl static-libs +svg utils valgrind xcb"
# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
RESTRICT="test"
+BDEPEND="
+ virtual/pkgconfig
+ >=sys-devel/libtool-2"
RDEPEND="
>=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}]
>=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
@@ -45,8 +48,6 @@ RDEPEND="
>=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
)"
DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=sys-devel/libtool-2
X? ( x11-base/xorg-proto )"
#[[ ${PV} == *9999* ]] && DEPEND="${DEPEND}
# doc? (
@@ -125,6 +126,6 @@ multilib_src_configure() {
}
multilib_src_install_all() {
- prune_libtool_files --all
+ find "${D}" -name '*.la' -delete || die
einstalldocs
}