summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-02-20 21:51:33 +0100
committerDavid Seifert <soap@gentoo.org>2023-02-20 21:51:33 +0100
commit97e1c35454a1ea4f47cb20d7092899f6ca443447 (patch)
tree48b4e0c73f5e87a0447507448dff2f0572d5f9bb /x11-libs/dnd/dnd-1.1-r4.ebuild
parentx11-drivers/xf86-input-mtrack: update EAPI 6 -> 8 (diff)
downloadgentoo-97e1c35454a1ea4f47cb20d7092899f6ca443447.tar.gz
gentoo-97e1c35454a1ea4f47cb20d7092899f6ca443447.tar.bz2
gentoo-97e1c35454a1ea4f47cb20d7092899f6ca443447.zip
x11-libs/dnd: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-libs/dnd/dnd-1.1-r4.ebuild')
-rw-r--r--x11-libs/dnd/dnd-1.1-r4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-libs/dnd/dnd-1.1-r4.ebuild b/x11-libs/dnd/dnd-1.1-r4.ebuild
new file mode 100644
index 000000000000..4a703c80c2b6
--- /dev/null
+++ b/x11-libs/dnd/dnd-1.1-r4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="OffiX' Drag'n'drop library"
+HOMEPAGE="http://leb.net/offix"
+SRC_URI="http://leb.net/offix/${PN}.${PV}.tgz"
+S="${WORKDIR}/DND/DNDlib"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
+
+RDEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.diff
+ "${FILESDIR}"/Makefile-fix.patch
+)
+
+DOCS=(
+ # README is useless
+ CHANGELOG
+)
+
+src_configure() {
+ tc-export CC CXX RANLIB AR
+ econf --with-x
+}